
 

 

Greeting 

 

Thank you for choosing EmEditor Professional. EmEditor has been used and favored by many users 

because of its extremely high standard of quality and reliability. EmEditor has become my masterpiece, and I 

put all my effort into it. I highly recommend this software to all users.  

EmEditor can be evolved much more with your feedback. I would appreciate it if you would consider 

EmEditor for long term use and contact me anytime, by e-mail or on the forums, if you have questions or 

comments. 

 

 

Yutaka Emura 

President, Emurasoft, Inc. 

December 2014 

 

E-mail: tech@emurasoft.com 

Web: http://www.emeditor.com/ 
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Getting Started 

About License 

You must obtain a license for each computer you install the software on. Therefore, a license is needed for 

each terminal computer on a network, including remote terminal computers. If this software is for personal use 

and not for installation on corporate computers, you can install the software on up to 5 computers for your use 

only. If you need to purchase more than a single license, please purchase as many licenses as the number of 

computers you will install EmEditor on. You can purchase licenses through How to Purchase in EmEditor 

(Help>How to Purchase) or at http://www.emeditor.com/modules/buy-now0/ after carefully reading the 

instructions.  

About Support 

Emurasoft, Inc. offers e-mail support services (tech@emurasoft.com) free to customers who have 

purchased our products. Please note that we do not offer telephone support services. When you have a 

question, please tell us which version of EmEditor you are using (You can check the version by selecting 

About EmEditor from the Help menu), the version and edition of your Windows operating system, and any 

other details that might help us in assisting you. You can also refer to the FAQ and up-to-date information on 

the EmEditor home page, http://www.emeditor.com/. 

Premium Support 

Premium Support subscriptions give users access to top-priority support by email and phone and the 

opportunity to receive sample macros and plug-ins directly from the developer. In the event of a paid upgrade, 

Premium Support users receive the upgrade at no charge during the subscription period. If you are a Premium 

Support subscriber, please include your Premium Support license key when you email support. For information 

about purchasing a Premium Support subscription, please visit the EmEditor home page at 

http://www.emeditor.com/.  

http://www.emeditor.com/
http://www.emeditor.com/
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Getting a Registration Key 

 

You will need a registration key when you install 

EmEditor Professional v13. You should have 

received a registration key for EmEditor 

Professional v13 by email when you purchased a 

license. If you can ’t locate your registration key, 

you can visit the Resend Keys page at 

https://www.emurasoft.com/support/send_keys.php 

to request your registration key(s) be emailed to 

you if your product has been registered with 

Emurasoft. 

Downloading EmEditor 

 

Please visit the EmEditor home page at 

http://www.emeditor.com/ and click the Download 

button on the top of the page if you need the 32-

bit program. If you need the 64-bit program, 

please go to the Download page at 

http://www.emeditor.com/modules/download2/ 

and click the download link for the 64-bit program. 

 

https://www.emurasoft.com/support/send_keys.php
http://www.emeditor.com/
http://www.emeditor.com/modules/download2/
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Installation of EmEditor 

Please follow the steps below to install EmEditor. 

 

 

1. This dialog box appears when you have downloaded 

the program. Click on Run. 

 

2. Click on Run after you verify that the publisher is 

Emurasoft, Inc. 

 

3. The set up will continue after you click on Next. 
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4. Check I Accept and click on Next if you agree with the 

license agreement. 

 

5. Select the setup type that best suits your needs for 

EmEditor. The Typical setting is recommended for most 

users. Click on Next after selecting a setup type.  

 

6. The installation will continue after you click Install. You 

can go back and change your settings by clicking Back.  
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7. The installation process may take a few minutes. 

 

8. Installation will be complete when you click Finish. 

Deselect the check box if you do not wish to run EmEditor 

immediately. 

  

Enter a registration key and run EmEditor 

After the installation, run EmEditor by clicking on EmEditor in the All Programs of the Start menu at the 

left hand corner of the screen. Please follow the steps below to register your license with your registration 

key. 
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1. After the EmEditor window appears, a dialog box will 

pop up to prompt registration. Click Enter Registration 

Key. 

 

 

 

2. Enter your name and the registration key into the dialog 

box in EmEditor. Click OK to complete the section.  
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Enter a Maintenance Key 

If you purchase a maintenance key, you can enter a maintenance key to extend a maintenance plan.  Click 

the Enter Maintenance key button in the About dialog box, and then you can enter the maintenance key. 

 

1. This dialog box appears when the About EmEditor 

command is selected (Help > About EmEditor). Click 

Add Maintenance Key.  

 

 

 

 

 

 

 

 

 

  

 

 

 

 

2. Enter your maintenance key into the dialog box in 

EmEditor. Click OK to complete the section.  

 

Copyright & Illegal Usage policy 

We have made our best effort to create a high-quality product.  Emurasoft Inc, EmSoft k.k., resellers, and 

any affiliated groups or individuals are not responsible for any losses or damages resulting from the use or 

installation of the software. 

This program is copyrighted by Emurasoft Inc. This program and all related documents are protected by 

international and United States copyright law and international treaties. Unauthorized use or reproduction of 

this program will result in prosecution to the fullest extent of the law. 

Emurasoft is a registered trademark of Emurasoft Inc. 



8  Features 

 

Chapter 1: Features 

EmEditor is a powerful, easy-to-use, multi-feature text editor. EmEditor 14 features the following new 

elements: 

Enhanced Multiple Selections 

When multiple selections are made, cursors appear simultaneously at multiple locations. 

Percent-Encoding (URL Encoding) 

Encodes or decodes the selected text using the Percent encoding (URL Encoding). If the mouse pointer 

hovers on the text encoded with percent encoding, a tooltip will automatically appear with decoded text. 

Move Line Up/Down 

The Move Line Up and Move Line Down commands were added. By default, these commands were 

assigned as CTRL + SHIFT + UP and CTRL + SHIFT + DOWN.  If these shortcut keys don’t work, please go 

to Configuration Properties, Keyboard tab, and click Reset, or assign your favorite shortcut keys to these 

commands. 

 

 

EmEditor 13 features the following new elements:  

Multiple Selection Editing 

The new version allows you to select multiple locations within a document. To make multiple selections, after 

making one selection, make another selection with the mouse while pressing the CTRL key. Alternatively, you 

can press the F8 key, move the cursor to extend the selection, press the F8 key again to finish the selection, 

move the cursor again to go to the next selection position, and repeat this procedure until you make all 

selections. Moreover, the Add Next Occurrence command (CTRL+R) will find the same text as the word at 

the cursor. The Add Next Next Occurrence command will skip the next occurrence, but add the occurrence 

after the next one. The Select All Occurrences command (CTRL+SHIFT+A) will select all the occurrences. 

After you make multiple selections, you can type new text to replace all the selections at once. Pressing the 

BACKSPACE key removes the last character in each selection. Moreover, you can use many conversion 

commands against the selections. 

Split and Combine Documents  

The new version also allows you to combine or split very large files easily. The new Split Current 

Document into Several Files command allows you to split the current document into several files either every 

user-specified number of lines, or before every bookmarked line. It also allows you to specify a header and/or 

footer to each separated file. The new Combine Documents into a Single File command allows you to 

combine multiple documents into one file. 
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Multiple File Encoding Conversions 

You can now convert encodings of many files at the same time. To do this, first open all files that you want to 

convert with EmEditor, either by pressing CTRL+O to open the Open dialog and selecting multiple files, or by 

specifying "emeditor.exe *.*", for example, in the Command Prompt window. Then selecting Save All with 

Encoding in the File menu will allow you to save all documents with a specified encoding. 

Quick Launch 

The new Quick Launch command allows you to open a dialog box where you can type a partial keyword to 

search all the commands.  A list box is quickly filled with searched commands, and then you can select which 

list item you want to launch. The Quick Launch dialog box will search all EmEditor commands, plug-ins, 

macros, external tools, recently used files, folders, fonts, opened document file names, etc. 

Other New Features in Version 13 

 The Comment/Uncomment commands now work as begin/end comments (for example, /* ... */) in 

addition to line comments. EmEditor will choose begin/end comments when the middle of a line is 

selected. 

 A workspace now saves all bookmarks automatically. Bookmarks will no longer be erased when 

reloading files. 

 When creating a new file by specifying a non-existing file name in the Open dialog box, EmEditor will 

now create a zero-byte empty file. 

 The Help for each dialog box now contains information about all the controls without needing to navigate 

through branch items. The Help button was deprecated, and pressing the ? button or the F1 key will 

bring up the pertinent Help. 

 A progress bar and a percentage indicator are now displayed in the progress window. 

 The new Fast Binary Comparison allows for faster sort. Clearing the Stable Sort also allows for faster 

sort when stable sorting is not necessary. 

 Find in Files dialog box now shows all associated file extensions of the current configuration in the File 

Types text box when Current File Type is selected from the > menu. 

 High-DPI settings supported. 

 The new version allows you to select text by mouse outside of the text area specified by the Narrowing 

command. 

 The installer now allows you to add the Context Menu to Windows Explorer, and to have EmEditor check 

the updates. 

 The installer command line options were added: NOCHECKUPDATES, NOCONTEXTMENU,  

 NODESKTOP, NOIEEDITOR, NOIEVIEW, NOPATH, NOSHORTCUT, NOTRAYICON, and NOTXT. 

 EmEditor Free is back! This time, EmEditor Free is the same executable file as EmEditor Professional. 

After you try EmEditor Professional for 30 days, you can still use EmEditor Free without purchasing the 

product for personal use only. 

 When a user clicks on the left edge or the line numbers, a menu related to bookmarks now appears. 
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EmEditor 12 features the following new elements:  

Matching Tag Highlight 

The new version automatically highlights inside a tag and the matching tag at the cursor in XHTML and XML 

documents. This new feature makes it easy to read documents and find matching tags. This feature will work 

only when a document is a well-formed XML document. The feature may not work if ending tags are missing 

from a document such as an old HTML document. In order for this feature to work, the Highlight Matching Tag 

check box in the Highlight (2) tab of configuration properties must be set. 

Moreover, the Find Matching Tag and Matching Tag Extend commands were added to jump conveniently 

between a tag and the matching tag. By default, CTRL + . and CTRL + SHIFT + . are assigned as default 

shortcut keys. 

 

 

 

The following new features were introduced with EmEditor 11:  

Marker 

EmEditor currently allows users to set highlight strings. However, in previous versions, there were several 

limitations, such as the inconvenience of adding highlight strings temporarily, that have been rectified in the 

new version.  

 

The new marker feature allows you to specify strings to highlight temporarily. In the context menu displayed 

by right-clicking, selecting Add to Markers allows you to add the selected text or the word at the cursor position 

to the list of markers. The list of markers is displayed in the new Markers toolbar. Alternatively, you can drag 

and drop the selected text to the Markers toolbar to add the text to the list of markers. 

 

Right clicking on each marker in the Markers toolbar displays a context menu, and allows you to enable or 

disable each marker, search for each marker, or change the match condition (case sensitivity, only word, 

regular expressions, etc.). 

 

Each marker can be dragged and dropped to change the order of markers and to insert the marker text into 

the editor. Selecting the Customize Markers from the menu allows you to change the details about the markers. 

In the Marker List tab, you can change the marker colors, change the marker text, and delete unnecessary 

markers. 

 

The auto marker is a new feature to automatically select text that is the same as the selected text. The Auto 

Marker tab of the Customize Marker dialog allows you to specify details about the auto marker, such as 

retrieving the word at the cursor position, matching the word only, or case sensitivity. 
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Tooltip to show HTML/XML character reference 

If the mouse cursor hovers over the HTML/XML character references, the actual Unicode characters appear 

as a tooltip. Moreover, right-clicking on the tooltip allows to you copy the Unicode characters or convert the 

document text into the Unicode characters. 

Find toolbar 

The Find toolbar previously provided as a plug-in has become an EmEditor core feature. The new Find 

toolbar allows you to drag and drop the text from the editor or from another application to change the search 

string. Moreover, the Find toolbar extends its functionalities to allow replace in addition to find. 

Batch replace 

The new Batch >> button in the Replace dialog extends the dialog box to include a list for multiple 

Find/Replace combinations with options. Pressing the Batch Replace button then replaces all of the multiple 

matched strings with the respective specified strings. This new user interface allows much faster and more 

intuitive replace operations for frequent use of the replace feature. 

Other New Features in Version 11 

 The new Delete Duplicate Lines command allows you delete duplicate lines in the selection if a portion of 

text is selected, or in the entire document. 

 The sort commands now sort the selected text only when a portion of text is selected. 

 The new Recently Closed Files commands allow you to open recently closed files. 

 Supports the Hanja conversion of Korean IME. 

 The status bar now allows you to display the number of characters in the selection, the number of words in 

the selection, and the number of lines in the selection. Also, the display order can be customizable now. 

 Unicode Ideographic Variation Sequence (IVS) is now supported. (Supporting fonts are needed.) 

Compare documents and Synchronized Scrolling 

The new version of EmEditor allows you to compare two recently viewed files with ease. The comparison 

results are colored within the documents, arranged side by side. The Diff plug-in has been deprecated. After 

comparison, the Rescan command allows you to compare modified documents again with the same conditions. 

The Synchronize Scrolling command scrolls two recently viewed documents synchronously without 

comparison. 

Spell Check 

The new version of EmEditor allows you to check spelling in various languages using the Hunspell library, 

already used by many applications like OpenOffice and Firefox. As you type, misspelled words are marked 

with red wiggly underlines. EmEditor allows you to correct misspelled words quickly and easily. The new 

EmEditor installer includes a U.S. English dictionary. Additional dictionaries are available for download at the 
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OpenOffice.org wiki. Just copy *.dic and *.aff files into the Dictionaries sub folder of the EmEditor install folder 

(usually C:\Program Files\EmEditor\Dictionaries). 

Numbering 

The new Numbering command allows you to insert sequential numbers or characters at the cursor position 

or vertical selection. 

ASCII View side by side with Binary (Hexadecimal View) 

Binary (Hexadecimal View) mode now includes ASCII view side by side. 

Other New Features in Version 10 

 The CSV mode now allows you to include new lines in a cell. Embedded returns are displayed as M (CR) 

and/or J (LF) in the reversed background color when the Show Control Characters check box is checked in 

the Marks tab of configuration properties. 

 The context menu displayed by right-clicking on a folder in Windows Explorer now includes the new Find 

in Files with EmEditor command. 

 The auto recovery feature now opens the last used workspace automatically (the Recovered Files 

dialog has been deprecated). When updating EmEditor with the new installer, EmEditor windows will be 

automatically closed, and they will be reopened as the last used workspace. 

 The new installer now allows several language editions in a single installer (currently English and 

Japanese are included). 

 The new Update Checker that came with the new installer is used now (v9 Update Checker has been 

deprecated). 

 New command line option /cmp was added. 

 When localized language files are old, EmEditor now automatically uses English strings and dialog box 

resources whenever possible.  

 EmEditor now supports a combination of left (&l), center (&c), and right (&r) align for Print header and 

footer.  

 Binary (Hexadecimal View) mode now includes ASCII view side by side. 

 Vertical selection is now limited to logical selections (multiple selections because of line wraps do not 

count any more). 

 In the previous version, a new untitled document was opened after canceling the dialog box that appears 

when reloading a file with invalid characters. This has been fixed, except when opening a huge file 

asynchronously. 

 

EmEditor Professional also includes the following features: 

Large File Controller 

EmEditor is able to open files larger than 248 GB by opening a portion of the file with the custom bar - Large 

File Controller. The Large File Controller allows you to specify the beginning point, end point, and range of the 
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file to be opened. It also allows you to stop the opening of the file and monitor the real size of the file and the 

size of the temporary disk available. 

Vertical Selection Editing 

The vertical selection editing feature allows you to edit multiple lines quickly without using regular 

expressions. Please visit http://www.emeditor.com/modules/feature1/rewrite/tc_38.html for a detailed guide on 

vertical selection editing.  

Snippets Plug-in 

With this plug-in, you can write more text with fewer keystrokes. The Snippets plug-in features: 

 The snippet tree includes not only snippets, but also macros. 

 Trigger strings and shortcut keys (Tab by default) can be specified. 

 Tooltip hints can be specified; the tooltip appears when the trigger string matches the typed string. 

 TAB and SHIFT + TAB can be used to jump between placeholders. 

 The new shell code format allows you to use snippets as filters. The shell code allows you to pass the 

standard input to an external tool, and then receives the standard output and inserts it as a snippet. 

Brackets/Quotation Mark Auto-Complete 

Brackets/Quotation marks can be auto-completed. For example, typing {, will insert } automatically after {. 

When text is selected, typing " will surround the selection with " ". 

Narrowing 

The Narrowing command assigns only the selection as an editable area and makes the rest inaccessible. 

CSV, TSV and DSV 

When a CSV (Comma-separated), TSV (Tab-separated) or DSV (User-defined delimiter-separated) file is 

opened, all the separators line up vertically. You can select a specified column vertically, or sort values at a 

specified column. In conjunction with the narrowing mode, you can sort only selected lines. 

Full Screen View 

The full screen mode hides all menus, toolbars, and the status bar so that you can utilize the full screen with 

editing task. 

Clipboard History 

The Clipboard history is saved, and using the clipboardData object in a macro allows you to reference 

previous clipboard contents. Repeatedly selecting the new command "Cycle Clipboard Ring" (or CTRL + 

SHIFT + V by default) allows you to paste previously copied text. 

http://www.emeditor.com/modules/feature1/rewrite/tc_38.html
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Wildcard Support 

You can now specify file names with wildcard characters (* or ?) in the command line. With this feature, you 

can open multiple files in the Command Prompt at the same time. 

Workspace Including Undo Information 

EmEditor can save the Undo information with the workspace, and allows you to save untitled documents 

without naming the files. EmEditor can prompt you to save the workspace when it is about to exit. This prompt 

can be disabled through Tools > Customize…>Window.  

New External Tools 

The features related to the standard input and output were added to the external tool feature. This allows 

you to use an external tool as a filter. 

Save in Protected Folder 

In Windows Vista and later, with User Account Control enabled, EmEditor now allows you to save files into 

protected folders such as "C:\Program Files" after a prompt to elevate the privilege. 

Binary Editing 

Binary (ASCII View) and Binary (Hexadecimal View) were added to the available encodings so that you can 

edit binary files. In binary files, you can open up to 248 GB or 2.1 billion lines if viewed in the specified 

encoding. 

Improved Projects Plug-in 

The Projects plug-in was improved with solution templates, the toolbar, and the parameter information tooltip, 

etc. It also allows you to open Visual Studio solution files as read-only. 

Optimized to Open Large Files 

EmEditor allows you to easily open huge files - up to 248 GB or 2.1 billion lines - with only a little memory. 

EmEditor optimizes the speed to open a huge file, so it can open a huge file very quickly. The multithreaded 

design allows you to view documents during the opening of a file. A status window appears during the most 

time-consuming activities such as text editing, saving, searching, replacing, inserting and deleting, which 

allows you to cancel those activities at any time. Even with smaller files, EmEditor improves the overall speed 

in most everyday activities such as file opening, editing, and saving, as well as text searching and replacing. 

Plug-ins 

 The Projects plug-in and the Word Complete plug-in utilize the Custom Toolbar feature. 

 HTMLBar Plug-in - displays a toolbar filled with buttons which help you insert frequently used HTML tags 

and elements. 

 Projects Plug-in - displays folder trees and allows you to open files from the folder trees. 
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 Word Complete Plug-in - displays the list filled with previously used words and highlighted words defined 

in EmEditor, and lets you select a word from the list to complete your typing. 

 Explorer Plug-in – Displays the folder tree in the sidebar, allowing you to open files directly through the 

main interface. 

 Open Documents Plug-in – Displays a list of the open documents in the sidebar, allowing you to save, etc. 

directly through the main interface. 

 Outline Plug-in – Displays an outline of the document in the custom bar and/or sidebar. The outline acts as 

a guide for the documents, and is synchronized with documents changes. Editing the outline (ie: changing 

the order of sections) will also edit the main document. 

 Snippets Plug-in – See above. 

 WebPreview – Opens up an internet browser with a preview of the open document. 

 Word Count – Displays a word, line, character, etc. count of the open document. 

 

The functionality of EmEditor has been expanded by incorporating user-created plug-in support. For example, 

you can use the Decode Unicode plug-in to decode a selected text that is encoded by HTML/XML Character 

Reference or Universal Character Names. Plug-ins are written as Dynamic Link Library (DLL) files, and are 

stored in the 'plug-ins' folder, created automatically when EmEditor is installed.  See the Plug-ins section for 

more information about creating your own plug-ins.  

Keystroke and Mouse Operation Recording and Playback 

EmEditor can record and play keystrokes and mouse operations against other applications. This capability 

allows you to automate certain tasks on the Desktop, the browser, or your favorite applications. For developers, 

this ability can also be used for testing applications. The Window Object includes all sorts of properties that 

can tell almost everything about the window, and the Windows Collection can be used to enumerate top-level 

windows or child windows for a certain window. The new Shell Object was added to send keystroke and 

mouse activities and to enumerate or find top-level windows. 

Macro Toolbars 

The Macros Toolbar can be displayed. The Macros Toolbar displays all defined My Macros. Moreover, you 

can change the icon, title, and tooltip of a macro button using #icon directive, #title directive, and #tooltip 

directive, respectively. 

Portability Options (Ready for a USB Drive Install) 

You have the option to save all settings to INI files instead of the Registry. From the Import and Export 

Wizard (in the Tools menu), you have the option to export settings to INI files. Once EmEditor detects INI files 

in its directory, it does not save the settings to the Registry. The plug-in interface was extended to support the 

Registry and INI file manipulation.  
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Custom Bars 

Custom Bars can be displayed within the EmEditor window. With this feature, useful plug-ins such as 

Outlining, Web Preview, and Search Bar can be developed. Many features were added to support outlining 

and custom bars. 

Output Bar  

When a console program is specified as an external tool, its standard output can be displayed in the 

EmEditor window. This makes it easy to capture a compiler's output, to tag jump at an error, and to edit back 

to the source code. 

Quick Start 

EmEditor can be loaded without displaying its window at the EmEditor tray icon's startup. This makes 

EmEditor window launch much faster. (By default, this feature is disabled. It can be enabled from EmEditor 

Quick Start check box in the Shortcut tab of the Customize dialog box.) 

Other ActiveScript Support 

ActiveScript languages other than JavaScript and VBScript can be used. For instance, you can use 

PerlScript, PHPScript, Python, Ruby, and many other ActiveScript languages as long as the script engines 

you would like to use are installed on your system. 

Powerful Tab Features 

Enhanced tab features are stable since all windows run in a single window in a single process. 

 Tab or Button style can be selected. 

 Close button (×) on the right-side of the tab can be clicked to close the active document. 

 Window-grouping is supported, and any tab item can be dragged-and-dropped into another group to join 

or to create a new group. 

 Tab icons and the button width can be customized. 

 The command to run when double-clicking the tab or clicking the tab by the middle mouse button can be 

customized. 

 The mouse wheel rotation activates another document. 

 The context menu on the tab can be customized. 

 The New tab insert position, which tab should be activated when a tab is closed, and the window to open 

a new document with, can be customized. 

 The tab can be arranged by file names, types, modified times or the recently activated order. The Auto 

arrange can also be specified. 

 The tab can be extended to multiple rows or the width can be automatically adjusted when it doesn't fit in 

the window. 
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Application Error Handler Support 

Should an application error occur in EmEditor, the error handler will let you save modified files before it 

actually terminates. Should an application error occur inside a plug-in, EmEditor will allow you to disable the 

plug-in without terminating. 

Powerful, functionally-rich macros 

With EmEditor Professional, you can create functionally-rich macros using JavaScript or VBScript, allowing 

you to define most operations. Not only you can define a macro which records keystrokes that you use and 

reference repeatedly, but you can also write your own macros which can manipulate other applications, 

Windows files, or network functionalities. The macros are based on the Windows Scripting Host (WSH) engine, 

so you can use all of the powerful, robust objects available under the WSH. 

Keyword Highlighting 

EmEditor includes predefined colored-text configurations for the following languages: 

Bat, C#, C++, CSS, HTML, Ini, Java, JavaScript, JSP, Pascal (Delphi), Perl, PerlScript, PHP, Python, Ruby, 

SQL, TeX (LaTeX), VBScript, WindowsScript, x86 Assembler, XML, as well as basic text. Within the HTML 

configuration, text within ASP tags (<% ... %>) and standard script tags (<SCRIPT> ... </SCRIPT>) is 

formatted according to which scripting language is specified in the LANGUAGE attribute (JavaScript, VBScript 

or PerlScript).  Moreover, HTML-Embedded special syntax is available for JSP and PHP configurations. 

Unicode Support 

EmEditor supports Unicode, which is the preferred encoding method for multiple language support. Not only 

can you open Unicode files but you can also edit files as Unicode, therefore you can display multiple 

languages at the same time. EmEditor supports Unicode big endian, UTF-8, UTF-7, Baltic, Central European, 

Chinese Simplified, Chinese Traditional, Cyrillic, Greek, Japanese (Shift-JIS), Japanese (JIS), Japanese 

(EUC), Korean, Thai, Turkish, Vietnamese, Western European, and all other encodings available in Windows. 

Find in Files 

The Find in Files feature allows you to search for a string within specified files or folders containing a 

specified file type, by using regular expressions. EmEditor Professional allows you to further specify search 

characteristics, such as encodings, and the ability to exclude specific files from a search. 

Replace in Files 

Just like the Find in Files feature, you can use regular expressions to search for specific words and 

characters. You can also specify an encoding to use for the document. To prevent unwanted automated 

editing, such as inserting unintended words, EmEditor replaces the words you specify, but leaves the editor 

open without saving changes right away. Replaced words are highlighted to assist in confirming your changes. 

If you do not wish to keep the changes, they can easily be removed with the Undo command.  
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External Tools 

You can launch your favorite external tools from within EmEditor via toolbar buttons or keyboard shortcuts. 

For instance, you can run your favorite Internet browser to test out HTML files. 

Drag and Drop 

EmEditor supports Object Linking & Embedding (OLE) drag and drop, enabling you to copy or move 

selected text between EmEditor and other supported applications such as WordPad or Internet Explorer.  

For Web Designers 

EmEditor is an ideal tool for editing HTML, PHP, JSP and XML files. By specifying an Internet browser as an 

external tool, you can preview HTML files while editing them. HTML and scripting language keywords are 

highlighted according to HTML or independent scripting language configurations, which makes finding spelling 

errors and typos easy. Unicode characters are automatically converted to the HTML/XML character reference 

( &H10070; ) or named entity reference ( &copy; ). EmEditor can use a code page specified at the <META> tag 

"charset=" line, and furthermore, you can use plug-ins to insert various tags or verify XML documents with an 

XML Parser. 

Other features 

Other EmEditor features: 

 Find and Replace with regular expressions supporting Unicode. 

 Keyboard, toolbar, menu, font and color customization. 

 The window can be split to a maximum of 4 panes. 

 Clickable URLs and email addresses. 

 Microsoft IntelliMouse support. 

 Print features (print preview, color print, header/footer). 

 Box-select mode (Mouse select with ALT key). 

 Define multiple configurations and associate file extensions. 

 Save backups to the Recycle Bin. 

 Open recently used files from the tray icon on the task bar. 

 Supports Global Input Method Editor (IME) (Windows 98/Me). 

 Shortcut keys to insert accent marks and special characters.  

 The cursor jumps to the invalid character position if a null or invalid character is detected during the 

opening after the warning dialog. 

 Cursor size and color can be customized. 

 Text color and background color of custom bars can be specified. 
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Chapter 2: How to... 

File 

Supported File Types 

EmEditor can open and edit any text 

files written with Unicode, Unicode big 

endian, UTF-16, UTF-8, UTF-7,  Baltic, 

Central European, Chinese Simplified, 

Chinese Traditional, Cyrillic, Greek, 

Japanese (Shift-JIS), Japanese (JIS), 

Japanese (EUC), Korean, Thai, 

Turkish, Vietnamese, Western 

European,  or any other encodings 

available on Windows. 

In Windows 2000/XP/2003/Vista/7, 

more encodings are available by 

checking additional languages under 

Supplemental language support in 

the Languages tab of Regional and 

Language Options in the Control 

Panel. You can also check the encoding you want to use under code page 

conversion tables in the Advanced tab. 

Encodings you want to use can be added in the Define Encodings dialog box. 

New Line Marks can be CRs only, LFs only, or CR and LF pairs. 

Notes 

 You can edit Unicode text files, but languages that are written from right to 

left such as Arabic and Hebrew may be edited incorrectly. Not all Unicode 

control characters are supported. 

 Some display characters are not supported. You need to choose an 

appropriate font for the language you wish to use. 

 When a file contains null characters, the null characters will be converted 

into spaces. 

To Open an Existing File 

1. Click   on the toolbar. 

2. Select the file you want to open and click on the Open button. 
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Tips 

 Alternatively, from the Explorer right-click menu, 

Select Send To and then select EmEditor. 

 Alternatively, click the tray icon and select Open. 

 Recently used files can be selected from the File 

menu. 

To Create a New File 

1. Click   on the Toolbar. 

2. Enter your text in the new EmEditor window. 

Tips 

 Alternatively, double-click the tray icon.  

To Save an Edited File 

1. Click   on the Toolbar. 

2. If the file is not named, the Save As dialog will be 

displayed, allowing you to enter a name for the 

file. 

Tips 

 If you want to save a previously saved file with a 

different name, select the Save As command 

under the File menu. 

To Create Backups 

1. Click   (if you want to change only the current 

configuration) or   (if you want to change all 

configurations) to display the Backup tab.  

2. Check Save Backups to Backup Folder, and 

specify the Backup Folder. 

To Save Files Automatically 

1. Click  (if you want to change only the current configuration) or  (if you want to change all 

configurations) on the Toolbar to display the Auto Save tab. 

2. Check Auto Save, and specify how often you want to automatically save open files. 
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3. Specify the location of the folder where you would like open 

files to be saved to automatically. 

4. If you want to ensure that files will not be accidentally 

overwritten, check the Rename if the Same File Name 

Exists option. 

To Open a File by Double Clicking in Explorer 

1. Select the Customize command under the Tools menu. 

2. Select the File tab. 

3. Click the Associate with EmEditor button. 

4. Click the Add button. 

5. Enter the file extension you want to associate in the 

Extension text box, enter any name in the File Types text 

box, select an icon from the Sample Icon from This File 

text box and the Current Icon list box. 

6. In Explorer, icons whose extensions have been associated 

with EmEditor will change to the specified icons, and 

double-clicking on those icons will open those files with 

EmEditor. 

Tips 

 If you try to enter an extension already associated with 

another program, the message box "This extension is already associated with '...'. Are you sure you want 

to change the association?" appears. Selecting Yes will change the association, and double-clicking the 

file will no longer run the old associated program. However, deleting the new extension in the Associate 

with EmEditor dialog box will restore the association with the old program. 

 If you do not want to change the association, you can still open a file in Explorer by selecting EmEditor in 

the menu displayed by right clicking on the file. 

To Associate a File Extension with the Current Configuration 

1. Click  on the Toolbar and display the Associate tab.  

2. Make sure that Enable Association is checked. 

3. Click the Add button and enter the extension you want to associate with the current configuration. 

To Exit All 

Click in the top, right-hand corner of the window while pressing the SHIFT key. 

Tips 

Alternatively, you can exit all in the following ways. 

 Press ALT + SHIFT + F4. 

 Press ALT + SHIFT + X. 
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 Select Close All from the File menu. 

 Select Close from the File menu while pressing the SHIFT key. 

 Add the Close All button on the Toolbar, and click that button. 

 Click the tray icon and select Close All from the menu. 

To Save and Close All 

Select Save and Close under the File menu while pressing the SHIFT key. 

Tips 

Alternatively, you can save and exit all in the following ways. 

 Press CTRL + SHIFT + E. 

 Select Save All and Close from the File menu. 

 Click the tray icon, and select Save All and Close from the menu. 

Using Command Line Options 

Command line options can be specified in the Run dialog box in the Start menu or a Command Prompt 

window. 

Syntax 

Open a file or files 

"File1" "File2" "File3" ... [/r] [/fh] [/nr] [/sp] [/l LineNumber] [/cl 

ColumnNumber] [/cp encoding] [/c "Config"] [/mf "MacroPath"] 

Create a new file 

[/cd] [/sp] [/c "Config"] [/mf "MacroPath"] 

Create a new file and paste 

[/i] [/cd] [/sp] [/c "Config"] [/mf "MacroPath"] 

Create a new file and paste with quote 

[/iq] [/cd] [/sp] [/c "Config"] [/mf "MacroPath"] 

Create a new file and paste with quote and returns 

[/iqr] [/cd] [/sp] [/c "Config"] [/mf "MacroPath"] 

Display the Tray Icon 

/ti 

Print a file 

"File" /p [/nr] [/sp] [/cp encoding] 

Compare two documents 

/cmp "File1" "File2" 
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Convert a file encoding 

"SrcFile" [/nr] [/sp] [/cp EncodingToOpen] [/c "Config"] /cps EncodingToSave 

/ss+ /sa "DestFile" 

To save without the Unicode signature (BOM), use /ss- instead of /ss+. 

Display Find in Files dialog box 

/fd 

Display Replace in Files dialog box 

/rd 

Find in files 

/fc "FindWhat" [/fr] [/fw] [/x] [/fn] [/fu "FilesToIgnore"] [/cp encoding] 

"path" 

This command is called internally when the Find button is selected in the Find in Files dialog box. To 

search without matching case, use /fi instead of /fc. 

Replace in files 

/fc "FindWhat" [/fr] [/fw] [/x] [/ko] [/fu "FilesToIgnore"] [/cp encoding] 

"path" /rw "RepalceWith" [/bk "BackupFolder"] 

This command is called internally when the Replace All button is selected in the Replace in Files dialog 

box. To search without matching case, use /fi instead of /fc. /ko and /bk cannot be specified 

simultaneously. 

Open a file and replace 

"File" /rc "FindWhat" [/fw] [/x] [/cp encoding] /rw "RepalceWith" 

This command is called internally during the Replace in Files process. To search without matching case, 

use /ri instead of /rc. 

Restore workspace 

/ws 

This command is called internally when the Restore Workspace command is selected. 

Save workspace 

/wss 

This command is called internally when the Save Workspace command is selected. 

Grab text with EmEditor 

/eh 

This command is called from the Tray Icon when the shortcut key to grab text with EmEditor defined in 

the Customize Tray Icon dialog box is pressed. 

Display Help 

/? 



24  How to… - File 

 

 

 

Options 

/? displays Help. 

/act 
activates EmEditor if it is already running, or launches EmEditor if it is not already 

running. 

/bk 

"BackupFolder" 
specifies a backup folder when replacing in files.   

/c "Config" sets the configuration. 

/ca closes all documents. 

/car closes all documents including a hidden window if the "Quick Start" option is enabled. 

/cd set the current directory as the default folder in the Open dialog box. 

/cjl /cjl customizes the Jump List on Windows 7 or later. 

/cl 

ColumnNumber 
logical column number. 

/clw clears the workspace. 

/cmp "File1" 

"File2" 
compares two documents. 

/cp Encoding 

sets an encoding to open as.  An encoding can be one of Encoding Constants. A 

combination with following values can be specified.  

131072 Detects Unicode signature (BOM). 

262144 Detects UTF-8. 

524288 Detects HTML/XML Charset. 

1048576 Detects all encodings. 
 

/cps Encoding sets an encoding to save as.  An encoding can be one of Encoding Constants. 

/di  specifies the working folder when creating a new document. Used internally by EmEditor. 

/eh grabs a text box contents. 

/fc "FindWhat" find in files (case sensitive). 

/fd displays the Find in Files dialog box. 

/fi "FindWhat" find in files (ignore case). 

/fh highlights searched strings. 

/fn displays only file names when finding in file.  

/fu 

"FilesToIgnore" 
ignores the following file or folder names. 
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/fr search in sub folders when finding in files (use with /fc or /fi).  

/fw searches only words. 

/hide runs EmEditor as a hidden window when the "Quick Start" option is enabled. 

/i pastes a text string from the Clipboard. 

/ipi refreshes the plug-in list. used from plug-in installers. 

/iq pastes a text string in quotes from the Clipboard. 

/iqr pastes a text string in quotes and returns from the Clipboard. 

/ko keeps modified files open when replacing in files. 

/l LineNumber move cursor to the logical line number. 

/mf specifies a macro file to run. 

/n always start as a new file. 

/ncp 
suppresses "The specified file does not exist. Open as a new file?" prompt when a 

specified file is not found. 

/ne specifies event-triggered macros should be disabled. 

/nr does not add the file path to the recent file list. 

/od displays the Open dialog box to select files to open. 

/p prints the file. 

/pos left, top, 

right, bottom 
specifies the window position with four integers (left, top, right, bottom). 

/r read-only mode. 

/rc "FindWhat" replaces in files (case sensitive). 

/rd displays the Replace in Files dialog box. 

/rh opens HTML files as read-only. Used internally. 

/ri "FindWhat" replaces in files (ignore case). 

/rr Opens files in folders recursively. 

/rw specifies a string to be replaced with. 

/sa "DestFile" specifies a file name to save as after the encoding conversion. 

/sca saves and closes all opened documents. 

/scrlf saves the file using CR+LF as return method after the encoding conversion. 

/scr saves the file using the CR only as return method after the encoding conversion. 

/slf saves the file using the LF only as return method after the encoding conversion. 

/sp 
specifies that a new separate process from other EmEditor windows should be run. This 

option is useful when a new EmEditor window must be launched from another application 
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because the application must monitor the process termination so it can detect the file 

modification. If this is specified, however, some features including tab operations will be 

disabled, and will void support. 

/ss+ saves the file with a Unicode signature (BOM) after the encoding conversion. 

/ss- saves the file without a Unicode signature (BOM) after the encoding conversion. 

/ti displays the Tray Icon. 

/uob uses the Output Bar to display the Find in Files results. 

/x find in files using a regular expression. 

/ws restores the workspace. 

/wss saves the workspace. 

 

Examples 

/rr *.htm 

opens all .htm files including all sub folders. 

/p "filename" 

prints filename. 

/r "filename" 

opens filename in read only mode. 

/c "Normal" "filename" 

opens filename in the default configuration. 

/l 123 "filename" 

opens filename, jumps to 123rd line and display it. 

/fh 

highlights string of last search. 

/ti 

opens as a tray icon. 

/fi "ABC" "c:\Temp\*.txt" 

searches for the string ABC from all files with the extension .txt in the c:\Temp folder while ignoring case. 

/fi "abc" /fr /fw /fn /fu "_*;*.bak" /cp 65536 "c:\test\*.htm;*.txt" 

searches for the string abc from all files with the extension .htm and .txt in the c:\test folder while 

ignoring case. It searches sub folders, searches only words, displays only file names, ignores file or 

folder names matching "_*;*.bak", and uses the system default encoding. 

/fc "[a-e]" /fr /x /fu "_*;*.bak" /cp 65536 "c:\test\*.htm;*.txt" 
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searches for text matching a regular expression [a-e] from all files with the extension .htm and .txt in the 

c:\test folder while not ignoring case. It searches sub folders, ignores file or folder names matching 

"_*;*.bak", and uses the system default encoding. 

"c:\test\utf16.txt" /cp 65537 /cps 65001 /ss- /sa "c:\test\utf8.txt" /scrlf 

converts a UTF-16LE file c:\test\utf16.txt to UTF-8 without a Unicode signature and saves as 

c:\test\utf8.txt. The return method is converted to CR+LF. 

Tips 

 The string searched for in files must be after /fc or /fi. 

 If no options are specified, the selected file will simply be opened. 

 If /c is not specified and the associated extensions of the configuration are the same, open the file with 

that configuration. 

 If a folder name is specified instead of a file name, the Open dialog box with that folder will be displayed. 

 Command line options are case sensitive. For instance /r will not be recognized if written as /R. 

To Open a File from the Recently Used Folder 

1. Click the tray icon and select Recent Folder. 

2. Select and click on the folder you want to open. 

3. Select the file that you want to open from the Open dialog box. 

Edit 

To Open or Close the Input Method Editor 

Press CTRL + F11 to open or close the Input Method Editor (IME). 

Tips 

 To open the IME automatically when running EmEditor, click on the Toolbar, display the General tab, and 

check Run Input Method Editor. 

To Move the Cursor Position 

Press the arrow keys to move the cursor up, down, left, or right. 

Tips 

 To move the cursor position with the mouse, simply click the destination point. 

Alternatively, you can use the following shortcut keys. 

 CTRL+ RIGHT Move one word to the right. 

 CTRL+ LEFT Move one word to the left. 

 HOME Move to the start of the current line. 

 ALT+ HOME Move to the start of the current logical line. 
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 END Move to the end of the current line. 

 ALT+ END Move to the end of the current logical line. 

 PAGE UP Move up one page. 

 PAGE DOWN Move down one page. 

 CTRL+ HOME Move to the top of the file. 

 CTRL+ END Move to the bottom of the file. 

To Undo the Last Edit 

Click   on the Toolbar. 

Tips 

 Alternatively, click CTRL + Z to undo the last edit. 

 To redo the last undone edit, click   on the Toolbar, or press CTRL + Y on the Toolbar. 

 The number of times you can undo is dependent only on the amount of memory available. 

To Select a Portion of a Document 

Click at the beginning of the selection, move the mouse to the end of the selection while holding the left 

mouse button down, and then release the mouse button. 

Tips 

 Alternatively, press arrow keys while pressing the SHIFT key. 

 Alternatively, press the F8 key, and then press arrow keys. 

 To select lines, click on the left edge of the window, or press CTRL + F8. 

 To select vertically (in a rectangular block), use the mouse to select while pressing the ALT key, or press 

SHIFT+ CTRL + F8. 

To Select the Entire Document 

Select Select All under the Edit menu. 

Tips 

 Alternatively, press CTRL + A to select the entire document. 

To Insert or Delete Returns at Wrap Points 

Select the text within which to insert or delete returns, select Advanced under the Edit menu, and then 

select the Insert Returns command or the Delete Returns command. 

Tips 

 This operation will be disabled when lines are not wrapped. 
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To Convert Between Uppercase and Lowercase 

Select the text you want to convert between uppercase and lowercase, select Convert Selection under the 

Edit menu, and then select Uppercase or Lowercase. 

To Set Read-Only Mode 

Select Read Only under the Edit menu. 

Notes 

 If the document has been modified, the warning message Are you sure to want to abandon the 

changes and continue? will appear. Selecting Yes will abandon the changes. 

To Do Tag Jumps 

If the file name (line number): format exists at the beginning of the line, placing the cursor on that line and 

selecting the Tag Jump command in the Edit menu will jump to the specified line in the specified file. 

Tab Indent 

Selecting the text and pressing the TAB key will not replace the selected text with a tab, but will indent the 

selected text to the right. SHIFT + TAB will indent the text to the left. 

To Paste in Quotes 

1. Select All Commands... under the Tools menu. 

2. Select Edit, Paste and then Paste in Quotes. 

Tips 

By default, you can press CTRL + B to paste in quotes. 

To Insert Special Characters 

Select Advanced under the Edit menu, and then select Insert Special Character. 

Alternatively, you can use the default shortcut keys for the following 

characters: 

Letter with a grave accent : à è ì ò ù À È Ì Ò Ù 

CTRL + ` (grave accent), the letter 

Letter with an acute accent : á é í ó ú ý Á É Í Ó Ú Ý ś ź Ś Ź 

CTRL + ' (apostrophe), the letter 

Letter with a circumflex : â ê î ô û Â Ê Î Ô Û 

CTRL + SHIFT + 6, the letter 

Letter with a tilde : ã ñ õ Ã Ñ Õ ẽ ũ Ẽ Ũ 

CTRL + SHIFT + ` (grave accent), the letter 
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Letter with a diaeresis : ä ë ï ö ü ÿ Ä Ë Ï Ö Ü Ÿ 

CTRL + SHIFT + ; (semi colon), the letter 

(On many keyboards, Shift + ; represents : (colon)) 

Letter with a ring above : å Å 

CTRL + SHIFT + 2, a or A 

(On many keyboards, Shift + 2. represents @) 

Ligature : æ œ Æ Œ 

CTRL + SHIFT + 7, a, A, o or O 

(On many keyboards, Shift + 7 represents &) 

Sharp : s ß 

CTRL + SHIFT + 7, s 

(On many keyboards, Shift + 7 represents &) 

c or C letter with a cedilla : ç Ç 

CTRL + , (comma), c or C 

eth letter : ð Ð 

CTRL + ' (apostrophe), d or D 

o or O letter with a stroke : ø Ø 

CTRL + /, o or O 

Cent sign : ¢ 

CTRL + /, c 

Inverted question mark : ¿ 

ALT + CTRL + SHIFT + / 

(On many keyboards, Shift + / represents ?) 

Inverted exclamation mark : ¡ 

ALT + CTRL + SHIFT + 1 

(On many keyboards, Shift + 1 represents !) 

Degree sign : ° 

CTRL + SHIFT + 2, space 

(On many keyboards, Shift + 2 represents @) 

Copyright sign : © 

ALT + CTRL + C 

Registered sign : ® 

ALT + CTRL + R 

Trademark sign : ™ 

ALT + CTRL + T 
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Euro sign : € 

ALT + CTRL + E 

Single opening quote : ‘ 

CTRL + ` (grave accent), ` (grave accent) 

Single closing quote : ’ 

CTRL + ' (apostrophe), ' (apostrophe) 

Double opening quote : “ 

CTRL + ` (grave accent), " 

Double closing quote : ” 

CTRL + ' (apostrophe), " 

Note 

If these shortcut keys do not work, you may need to reset your properties. Display the Keyboard tab in 

Properties, and press the Reset button. 

Latin Extended Characters Reference 

 

00A0   00A1 ¡ 00A2 ¢ 00A3 £ 00A4 ¤ 00A5 \ 00A6 ¦ 00A7 § 

00A8 ¨ 00A9 © 00AA ª 00AB « 00AC ¬ 00AD - 00AE ® 00AF ¯ 

00B0 ° 00B1 ± 00B2 ² 00B3 ³ 00B4 ´ 00B5 µ 00B6 ¶ 00B7 · 

00B8 ¸ 00B9 ¹ 00BA º 00BB » 00BC ¼ 00BD ½ 00BE ¾ 00BF ¿ 

00C0 À 00C1 Á 00C2 Â 00C3 Ã 00C4 Ä 00C5 Å 00C6 Æ 00C7 Ç 

00C8 È 00C9 É 00CA Ê 00CB Ë 00CC Ì 00CD Í 00CE Î 00CF Ï 

00D0 Ð 00D1 Ñ 00D2 Ò 00D3 Ó 00D4 Ô 00D5 Õ 00D6 Ö 00D7 × 

00D8 Ø 00D9 Ù 00DA Ú 00DB Û 00DC Ü 00DD Ý 00DE Þ 00DF ß 

00E0 à 00E1 á 00E2 â 00E3 ã 00E4 ä 00E5 å 00E6 æ 00E7 ç 

00E8 è 00E9 é 00EA ê 00EB ë 00EC ì 00ED í 00EE î 00EF ï 

00F0 ð 00F1 ñ 00F2 ò 00F3 ó 00F4 ô 00F5 õ 00F6 ö 00F7 ÷ 

00F8 ø 00F9 ù 00FA ú 00FB û 00FC ü 00FD ý 00FE þ 00FF ÿ 

0100 Ā 0101 ā 0102 Ă 0103 ă 0104 Ą 0105 ą 0106 Ć 0107 ć 

0108 Ĉ 0109 ĉ 010A Ċ 010B ċ 010C Č 010D č 010E Ď 010F ď 

0110 Đ 0111 đ 0112 Ē 0113 ē 0114 Ĕ 0115 ĕ 0116 Ė 0117 ė 

0118 Ę 0119 ę 011A Ě 011B ě 011C Ĝ 011D ĝ 011E Ğ 011F ğ 

0120 Ġ 0121 ġ 0122 Ģ 0123 ģ 0124 Ĥ 0125 ĥ 0126 Ħ 0127 ħ 

0128 Ĩ 0129 ĩ 012A Ī 012B ī 012C Ĭ 012D ĭ 012E Į 012F į 
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0130 İ 0131 ı 0132 Ĳ 0133 ĳ 0134 Ĵ 0135 ĵ 0136 Ķ 0137 ķ 

0138 ĸ 0139 Ĺ 013A ĺ 013B Ļ 013C ļ 013D Ľ 013E ľ 013F Ŀ 

0140 ŀ 0141 Ł 0142 ł 0143 Ń 0144 ń 0145 Ņ 0146 ņ 0147 Ň 

0148 ň 0149 ŉ 014A Ŋ 014B ŋ 014C Ō 014D ō 014E Ŏ 014F ŏ 

0150 Ő 0151 ő 0152 Œ 0153 œ 0154 Ŕ 0155 ŕ 0156 Ŗ 0157 ŗ 

0158 Ř 0159 ř 015A Ś 015B ś 015C Ŝ 015D ŝ 015E Ş 015F ş 

0160 Š 0161 š 0162 Ţ 0163 ţ 0164 Ť 0165 ť 0166 Ŧ 0167 ŧ 

0168 Ũ 0169 ũ 016A Ū 016B ū 016C Ŭ 016D ŭ 016E Ů 016F ů 

0170 Ű 0171 ű 0172 Ų 0173 ų 0174 Ŵ 0175 ŵ 0176 Ŷ 0177 ŷ 

0178 Ÿ 0179 Ź 017A ź 017B Ż 017C ż 017D Ž 017E ž 017F ſ 

Search 

To Find a Text String 

1. Click   on the Toolbar to display the Find dialog.  

2. Enter the text string you would like to find. You can search 

up or down from the current position in the document. 

Tips 

 Check Match Case to differentiate between uppercase 

and lowercase. 

To Replace a String 

1. Select Replace in the Search menu. 

2. Enter the text string to be replaced and the text string to 

replace it with. 

3. Click Replace Next to replace the next occurrence of the text string. 

Tips 

 Check Match Case to differentiate between uppercase and lowercase. 

 Click Replace All to replace all the occurrences of the text string. 

To Find a String in Files 

1. Click   on the Toolbar.  

2. Enter the text string to search for, the file type(s) (separated with a semicolon if more than one), and the 

folder(s) to search. 

Tips 

 Check Match Case to differentiate between uppercase and lowercase. 
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 Check Look in Subfolders, to also search subfolders. 

To Replace in Files 

1. Select the Replace in Files command under the Search menu to display the Replace in Files dialog box. 

2. Enter the text string to search for, the text string to replace it with, the file type(s) (separated with a 

semicolon if more than one) and the folder(s) to search, and press the Replace All button. 

3. If you check the Keep Modified Files Open check box, all files that have had changes made will be left 

open, so that you can verify the changes. 

4. If the changes are correct, you can select the Save and Close All command. If you want to cancel the 

changes, you can select the All Commands command, and select File > Close > Close All without Save 

command. 

Tips 

 Check Look in Subfolders, to also search subfolders. 

 If you do not check the Keep Modified Files Open check box, changes to files will be made immediately. 

If this is checked, the number of files replaced will be limited to the Maximum Number of Files to 

Replace if Kept Open text box in the Status tab of the Customize dialog box. 

To Use Regular Expressions 

Regular expressions can be used to find text patterns within an open document or in multiple files. A regular 

expression is a pattern of text that consists of ordinary characters, or literals, (for example, letters a-z) and 

special characters, known as metacharacters. The pattern describes one or more strings to match when 

searching text. 

To use regular expressions: 

1. Select the Find (to find text patterns in the current file), Replace (to find text patterns and replace them), 

or Find in Files option (to find text patterns in multiple files) under the Search menu. 

2. Check the Use Regular Expressions box and any other search parameters like Match Case. 

3. Enter the regular expression to search for and click Find. If using Find in Files, also enter the file type(s) 

(separated with a semicolon if more than one) and the folder(s) to search. If using Replace, also enter the 

text to replace the found text pattern with (back references can also be used - see below). 

To Remove Highlight from Found Strings 

To remove the highlight from strings that matched a search, select Erase Highlight under the Search menu. 

Regular Expression Syntax 

EmEditor regular expression syntax is based on the Perl regular expression syntax. 

Literals 

All characters are literals except: ".", "*", "?", "+", "(", ")", "{", "}", "[", "]", "^", "$" and "\". These characters are 

literals when preceded by a "\". A literal is a character that matches itself. For example, searching for "\?" will 

match every "?"in the document, or searching for "Hello" will match every "Hello" in the document. 



34  How to… - Search 

 

 

Metacharacters 

The following tables contain the complete list of metacharacters (non-literals) and their behavior in the 

context of regular expressions. 

\ 
Marks the next character as a special character, a literal, or a back reference. For example, 'n' 
matches the character "n". '\n' matches a newline character. The sequence '\\' matches "\" and 
"\(" matches "(". 

^ 
Matches the position at the beginning of the input string. For example, "^e" matches any "e" 
that begins a string. 

$ 
Matches the position at the end of the input string. For example, "e$" matches any "e" that ends 
a string. 

* 
Matches the preceding character or sub-expression zero or more times. For example, zo* 
matches "z" and "zoo". * is equivalent to {0,}. 

+ 
Matches the preceding character or sub-expression one or more times. For example,'zo+' 
matches "zo" and "zoo" , but not "z". + is equivalent to {1,}. 

? 
Matches the preceding character or sub-expression zero or one time. For example, “do(es)?" 
matches the "do" in  "do" or "does". ? is equivalent to {0,1}. 

{n} 
n is a nonnegative integer. Matches exactly n times. For example, 'o{2}' does not match the "o" 
in "Bob" but matches the two o's in "food". 

{n,} 
n is a nonnegative integer. Matches at least n times. For example, 'o{2,}' does not match "o" in 
"Bob" and matches all the o's in "foooood". "o{1,}" is equivalent to 'o+'. 'o{0,}' is equivalent to 
'o*'. 

{n,m} 
m and n are nonnegative integers, where n <= m. Matches at least n and at most m times. For 
example, "o{1,3}" matches the first three o's in "fooooood". 'o{0,1}' is equivalent to 'o?'. Note 
that you cannot put a space between the comma and the numbers. 

? 

When this character immediately follows any of the other quantifiers (*, +, ?, {n}, {n,}, {n,m}), the 
matching pattern is non-greedy. A non-greedy pattern matches as little of the searched string 
as possible, whereas the default greedy pattern matches as much of the searched string as 
possible. For example, in the string "oooo", 'o+?' matches a single "o", while 'o+' matches all 
'o's. 

. 

Matches any single character. For example, ".e" will match text where any character precedes 
an "e", like "he", "we", or "me". In EmEditor Professional, it matches a new line within the range 
specified in the Additional Lines to Search for Regular Expressions text box if the A 
Regular Expression "." Can Match the New Line Character check box is checked. 

(pattern) 

Parentheses serve two purposes: to group a pattern into a sub-expression and to capture what 
generated the match. For example the expression "(ab)*" would match all of the string 
"ababab". Each sub-expression match is captured as a back reference (see below) numbered 
from left to right. To match parentheses characters ( ), use '\(' or '\)'. 

\1 - \9 

Indicates a back reference - a back reference is a reference to a previous sub-expression that 
has already been matched. The reference is to what the sub-expression matched, not to the 
expression itself. A back reference consists of the escape character "\" followed by a digit "1" to 
"9", "\1" refers to the first sub-expression, "\2" to the second etc. For example, "(a)\1" would 
capture "a" as the first back reference and match any text "aa". Back references can also be 
used when using the Replace feature under the Search menu. Use regular expressions to 

locate a text pattern, and the matching text can be replaced by a specified back reference. For 
example, "(h)(e)" will find "he", and putting "\1" in the Replace With box will replace "he" with 

"h" whereas "\2\1" will replace "he" with "eh". 
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(?:pattern) 

A subexpression that matches pattern but does not capture the match, that is, it is a non-
capturing match that is not stored for possible later use with back references. This is useful for 
combining parts of a pattern with the "or" character (|). For example, 'industr(?:y|ies) is a more 
economical expression than 'industry|industries'. 

(?=pattern) 

A subexpression that performs a positive lookahead search, which matches the string at any 
point where a string matching pattern begins. For example, "x(?=abc)" matches an "x"only if it 
is followed by the expression "abc". This is a non-capturing match, that is, the match is not 
captured for possible later use with back references. pattern cannot contain a new line. 

(?!pattern) 

A subexpression that performs a negative lookahead search, which matches the search string 
at any point where a string not matching pattern begins. For example, "x(?!abc)" matches an 
"x" only if it is not followed by the expression "abc". This is a non-capturing match, that is, the 
match is not captured for possible later use with back references. pattern cannot contain a new 
line. 

(?<=pattern) 

A subexpression that performs a positive lookbehind search, which matches the search string 
at any point where a string matching pattern ends. For example, "(?<=abc)x" matches an "x" 
only if it is preceded by the expression "abc". This is a non-capturing match, that is, the match 
is not captured for possible later use with back references. pattern cannot contain a new line. 
pattern must be of fixed length. 

(?<!pattern) 

A subexpression that performs a negative lookbehind search, which matches the search string 
at any point where a string not matching pattern ends. For example, "(?<!abc)x" matches an "x" 
only if it is not preceded by the expression "abc". This is a non-capturing match, that is, the 
match is not captured for possible later use with back references. pattern cannot contain a new 
line.pattern must be of fixed length. 

x|y 
Matches either x or y. For example, 'z|food' matches "z" or "food". '(z|f)ood' matches "zood" or 
"food".  

[xyz] 
A character set. Matches any one of the enclosed characters. For example, '[abc]' matches the 
'a' in "plain".  

[^xyz] 
A negative character set. Matches any character not enclosed. For example, '[^abc]' matches 
the 'p' in "plain".  

[a-z] 
A range of characters. Matches any character in the specified range. For example, '[a-z]' 
matches any lowercase alphabetic character in the range 'a' through 'z'.  

[^a-z] 
A negative range of characters. Matches any character not in the specified range. For example, 
'[^a-z]' matches any character not in the range 'a' through 'z'. 

Character Classes 

The following character classes are used within a character set such as "[:classname:]". For instance, 

"[[:space:]]" is the set of all whitespace characters. 

alnum Any alphanumeric character. 

alpha Any alphabetical character a-z, A-Z, and other character. 

blank Any blank character, either a space or a tab. 

cntrl Any control character. 

digit Any digit 0-9. 

graph Any graphical character. 

lower Any lowercase character a-z, and other lowercase character. 

print Any printable character. 

punct Any punctuation character. 



36  How to… - Search 

 

 

space Any whitespace character. 

upper Any uppercase character A-Z, and other uppercase character. 

xdigit Any hexadecimal digit character, 0-9, a-f and A-F. 

word Any word character - all alphanumeric characters plus the underscore. 

unicode Any character whose code is greater than 255. 

Single character escape sequences 

The following escape sequences are aliases for single characters: 

0x07 \a Bell character. 

0x0C \f Form feed. 

0x0A \n Newline character. 

0x0D \r Carriage return. 

0x09 \t Tab character. 

0x0B \v Vertical tab. 

0x1B \e ASCII Escape character. 

0dd \0dd An octal character code, where dd is one or more octal digits. 

0xXX \xXX 
A hexadecimal character code, where XX is one or more hexadecimal digits (a Unicode 
character). 

0xXXXX \x{XXXX} 
A hexadecimal character code, where XXXX is one or more hexadecimal digits (a 
Unicode character). 

Z-'@' \cZ Z-'@' 
An ASCII escape sequence control-Z, where Z is any ASCII character greater than or 
equal to the character code for '@'. 

Word Boundaries 

The following escape sequences match the boundaries of words: 

\< Matches the start of a word. 

\> Matches the end of a word. 

\b Matches a word boundary (the start or end of a word). 

\B Matches only when not at a word boundary. 

Character class escape sequences 

The following escape sequences can be used to represent entire character classes: 

\w Any word character - all alphanumeric characters plus the underscore. 

\W Complement of \w - find any non-word character 

\s Any whitespace character. 

\S Complement of \s. 

\d Any digit 0-9. 

\D Complement of \d. 

\l Any lower case character a-z. 

\L Complement of \l. 
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\u Any upper case character A-Z. 

\U Complement of \u. 

\C Any single character, equivalent to '.'. 

\Q 
The begin quote operator, everything that follows is treated as a literal character until a \E end quote 
operator is found. 

\E The end quote operator, terminates a sequence begun with \Q. 

Replacement Expressions 

The following expressions are available for the Replace With box in the Replace dialog box and in the 

Replace in Files dialog box. 

\0  Indicates a back reference to the entire regular expression. 

\1 - \9 

Indicates a back reference - a back reference is a reference to a 
previous sub-expression that has already been matched. The reference 
is to what the sub-expression matched, not to the expression itself. A 
back reference consists of the escape character "\" followed by a digit 
"1" to "9", "\1" refers to the first sub-expression, "\2" to the second etc. 

\n A new line. 

\r 
A carriage return in case of Replace in Files. See also To Specify New 

Lines. 

\t A tab. 

\L Forces all subsequent substituted characters to be in lowercase. 

\U Forces all subsequent substituted characters to be in uppercase. 

\H 
Forces all subsequent substituted characters to be in half-width 
characters. 

\F 
Forces all subsequent substituted characters to be in full-width 
characters. 

\E Turns off previous \L, \U, \F, or \H. 

(? 
n:true_expression:false_expression) 

If sub-expression N was matched, then true_expression is evaluated 
and sent to output, otherwise false_expression is evaluated and sent to 
output. 

Notes 

 In Find in Files and in Replace in Files, the carriage return (\r) and the line feed (\n) must be specified 

carefully. See To Specify New Lines for details. 

 In order for some escape sequences to work in EmEditor, like "\l", "\u" and their complements, the Match 

Case option has to be selected. 

Copyright Notice 

The regular expression routines used in EmEditor use Boost library Regex++. 

Copyright (c) 1998-2001 Dr John Maddock 

To Specify New Lines 

The following tables show how to specify new lines. 
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Find Dialog box, Replace dialog box - Find, Replace with 

Use Regular Expressions is on \n or \r\n (same meaning) 

Use Regular Expressions is off (Use Escape Sequence)  \n or \r\n (same meaning) 

Find in Files dialog box, Replace in Files dialog box - Find 

Use Regular Expressions is on \r\n, \r, or \n (depends on actual new line method) 

Use Regular Expressions is off(Use Escape Sequence)  \n or \r\n (same meaning) 

Replace in Files dialog box - Replace with 

  Keep Modified Files Open is on Keep Modified Files Open is off 

Use Regular Expressions is on 
\r\n, \r, or \n (depends on actual 
new line method) 

\r\n, \r, or \n (depends on actual 
new line method) 

Use Regular Expressions is off (Use 
Escape Sequence) 

\n or \r\n (same meaning) 
\r\n, \r, or \n (depends on actual 
new line method) 

Tips 

 In case of "\n or \r\n (same meaning)", you cannot search new lines by distinguishing CR+LF, CR only, and 

LF only. 

 In case of "\r\n, \r, or \n (depends on actual new line method)", you need to specify "\r\n" if the actual new 

line is CR+LF, "\r" if CR only, or "\n" if LF only. Usually CR+LF (\r\n) is used on Windows Operating 

Systems, CR (\r) is used on Macintosh, and LF (\n) is used on Unix. 

View 

To Customize the Toolbar 

1. Select Customize Toolbars… under the Tools menu. 

2. Select the toolbar you would like to customize and click the Customize 

button. 

3. Select a command from the Available Toolbar Buttons list on the left and 

click the Add button to add it to the Current Toolbar Buttons list and your 

toolbar. Select from the Current Toolbar Buttons list on the right and click 

the Remove button to remove a command from your current toolbar. You 

can also drag and drop commands between the two lists. 

Tips 

 Alternatively, double-click an empty area on the 

Toolbar to display Customize Toolbar. 

 Drag a button on the toolbar while pressing the 

SHIFT key to change its position. Drag a button off 

the Toolbar to remove it. 
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 Selecting Toolbar from the View menu will show or hide the Toolbar. 

Buttons on the Toolbar 

Buttons available on EmEditor Professional 

 New Text Create a new Text file. 

 Open Open an existing file. 

 Close and Open Close the file and open an existing file. 

 Save Save the file. 

 Save All Save all the files. 

 Reload Reload the file. 

 Print Print the file. 

 Print Preview Displays preview of how this document will print. 

 Exit Quit EmEditor. 

 Exit All Save the file and exit. 

 Cut Cut the selection and put it on the Clipboard. 

 Copy Copy the selection and put it on the Clipboard. 

 Paste Insert Clipboard contents. 

 Undo Undo the last action. 

 Redo Redo the last undone action. 

 Jump Jump to a specified line. 

 Find Find a string. 

 Find Next Find previous occurrence. 

 Find Previous Find next occurrence. 

 Replace Replace a word. 

 Erase Highlight Erase highlight. 

 Find in Files Search for a string in multiple files. 

 No Wrap Show lines without wrapping. 

 Wrap by Characters Show lines wrapping by specified characters. 

 Wrap by Window Show lines wrapping by window size. 

 Wrap by Page Wrap lines according to page width. 

 Font Change font settings. 

 Properties for Current Change properties for currently selected configuration. 
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Configuration 

 Properties for all Configurations Change properties for all configurations. 

 Select Configuration (popup 
menu) 

Show a popup menu to select a configuration. 

 Customize Customize the common application settings. 

 Record or Finish Quick Macro Record or Finish Quick Macro. 

 Run Quick Macro Run Quick Macro. 

 Always on Top Toggle to show this window always on top. 

 Toggle Bookmark Toggle bookmark on the current line. 

 Previous Bookmark Go to the previous bookmark. 

 Next Bookmark Go to the next bookmark. 

 Clear bookmarks Clear all bookmarks. 

 Save and Close Save and Close the current file. 

 Save and Close All Save and Close all open files. 

 Find Matching 
Parenthesis/Bracket 

Moves the cursor to the corresponding parenthesis/bracket. 

 Duplicate Line Duplicates the current logical line. 

 Insert Special Character Insert special character. 

 Marks Toggle new lines, EOF and tab marks. 

 Comment Comment out the selection. 

 Uncomment Removes comment marks in the selection. 

 Increase Line Indent Increase line indent in the selection. 

 Decrease Line Indent Decrease line indent in the selection. 

 Save Macro Save the temporary macro. 

 Edit Macro Edit the selected macro. 

 Select Macro Select a macro. 

 Toggle Horizontal Split Toggle the horizontal window split. 

 Combine Windows Combine multiple windows. 

 Increase Font Size Increase the display font size. 

 Decrease Font Size Decrease the display font size. 

 Replace in Files Replace text in multiple files. 

 Previous Bookmark in This 
Window 

Go to the previous bookmark in this window. 
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 Next Bookmark in This Window Go to the next bookmark in this window. 

 Delete Deletes the selection, or deletes one character at the right of the cursor. 

 Full Screen Toggles the full screen mode. 

 Sticky Vertical Mode Toggles the sticky vertical mode. 

 Collapse All Collapses the entire document while the outlining is displayed. 

 Expand All Expands the entire document while the outlining is displayed. 

 Save As Saves the current file with a new name. 

 Cycle Clipboard Ring Inserts one of the contents from the Clipboard history at the cursor position. 

 Normal Mode 
Clears the CSV (Comma-separated), TSV (Tab-separated), and DSV (User-
defined Delimiter-separated) modes. 

 CSV Mode Selects the CSV (Comma-separated) mode. 

 TSV Mode Selects the TSV (Tab-separated) mode. 

 DSV Mode Selects the user-defined DSV (Delimiter-separated) mode. 

 Toggle Narrowing 
Sets or resets only the selection as editable area and make the rest 
inaccessible. 

 Sort A to Z Sort text at the current column in ascending order. 

 Sort Z to A Sort text at the current column in descending order. 

 Sort Smallest to Largest Sort numbers at the current column in ascending order. 

 Sort Largest to Smallest Sort numbers at the current column in descending order. 

Compare Compares two recently viewed documents without specifying options. 

Rescan Rescans the compared documents and refresh the results. 

Synchronize Scrolling 
Synchronizes scrolling of two recently viewed documents without specifying 

options. 

Reset 
Resets comparison or synchronized scrolling mode and clears comparison 

results. 

Line Numbers Shows or hides line numbers. 

Ruler Shows or hides the ruler. 

Auto Indent Enables or disables the auto indent. 

Insert Spaces for Tabs Inserts spaces for tabs. 

Wrap Indent Enables or disables the wrap indent. 

Tab Columns Displays a popup menu to select tab columns. 
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Indent Columns Displays a popup menu to select indent columns. 

HTML/XML Character Reference 

to Unicode 
Decodes the selected text from HTML/XML Character Reference. 

Unicode to HTML/XML Character 

Reference 
Encodes the selected text to HTML/XML Character Reference. 

Universal Character Names to 

Unicode 
Decodes the selected text from Universal Character Names. 

Unicode to Universal Character 

Names 
Encodes the selected text to Universal Character Names. 

Check Spelling Checks spelling of the document. 

 Explorer Explorer Plug-in. 

 FindBar FindBar Plug-in. 

 HTMLBar HTMLBar Plug-in. 

 Open Documents Open Documents Plug-in. 

 Outline Outline Plug-in. 

 Projects Projects Plug-in. 

 Search Search Plug-in. 

 Snippets Snippets Plug-in. 

 Web Preview Web Preview Plug-in. 

 Word Complete Word Complete Plug-in. 

 Word Count Word Count Plug-in. 

The Status Bar 

The Status Bar shown on the bottom of the window displays the following information by default. 

 The command explanation of the currently selected menu item or the Toolbar button. 

 The currently selected configuration. 

 The current line and column at the cursor. 

 Encoding method used to open. 

 Overwrite mode (OVR) 

 Read only mode (READ) 

Tips 

 You can double-click on most items to change their settings. 

 Information displayed on the Status Bar can be customized in the Status tab of the Customize dialog box. 
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To Change Fonts 

1. Select Font… under the View Menu, or click  on the 

Toolbar.  

2. Choose a Font Category, and click on Change…to specify a 

font.  

3. Select Font, Font style, and Size. 

To Change Text Color 

1. Click  (if you want to change only the current configuration) 

or  (if you want to change all configurations) to display the 

Display tab. 

2. Select an item or items from the list. 

3. Click the Text Color button or the Background Color button to 

change the color. 

To Change Wrapping Mode 

Click  on the Toolbar to not wrap lines at all,  to wrap by the specified number of characters,  to wrap 

by the size of the window, or  to wrap by the size of the page. 

Tips 

 To change the character counts when wrapping by the specified characters, click  (if you want to change 

only the current configuration) or  (if you want to change all configurations) to show the General tab and 

change the Normal Line Margin and Quoted Line Margin. 

To Inspect the Character code at the Cursor 

Select Character Code... under the View menu. 

To Customize Menus 

1. Select Customize Menus... under the Tools menu. 

2. Select either Main Menu or Context Menu. 

3. To insert a new menu, select where you want to insert a new menu and click either Insert Above or Insert 

Below. 

4. Define a menu property. 
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Customize 

To Display Line Numbers and or the Ruler 

1. Click  (if you want to change only the current configuration) or  (if you want to change all 

configurations) to display the General tab. 

2. Click Show Line Numbers to display line numbers, or click Show Ruler to display the ruler. 

To Create a Notepad-Compatible Diary 

1. Click  to display the File tab. 

2. Check Notepad-Compatible Diary. 

To Open Japanese JIS or  EUC Coded Files 

1. Click  to display the File tab.  

2. Select Japanese (Auto-Detect) from the Opening Encoding combo box. 

To Change the Color on Quoted Lines 

1. Click  (if you want to change only the current configuration) or  (if you want to change all 

configurations) to display the Display tab.  

2. Select Quoted Line from the list and click the Text button to change the color. 

Tips 

 Set characters in Quote Marks to define a line as Quoted Line. 

To Adjust Space Between Lines 

1. Click  (if you want to change only the current configuration) or  (if you want to change all 

configurations) to display the Display tab. 

2. Change Line Space to adjust the space between lines. 

Tips 

 The value 1 is equal to one tenth of the character's height. 

To Show CR and LF with Different marks 

1. Click  (if you want to change only the current configuration) or  (if you want to change all 

configurations) to display the Marks tab.  

2. Check Show CR and LF with Different Marks. 
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To Change the File types in the Open Dialog 

1. Select the Customize command to display the File tab of the Customize dialog box. 

2. Specify file types as *.txt;*.bat in the Custom File Filter text box. 

3. Select Custom from the File Types drop-down list box in the Open dialog. 

To Change the Keyboard Shortcuts 

1. Click  (if you want to change only the current configuration) or  (if you want to change all 

configurations) to display the Keyboard tab. 

2. Select a category and a command. 

3. Enter a shortcut key in Press New Shortcut Key. 

4. Click the Add button. 

To Set Overwrite Mode 

Overwrite mode is activated by pressing the Insert key. Note that the Status Bar displays OVR when in 

overwrite mode. 

Tips 

 Press the Insert key to return to Insert mode. 

To Clear Recently Used Files and Find and Replace History 

1. Select the Customize command to display the History tab of the Customize dialog box. 

2. Click the Clear History button. 

To Highlight Specified Strings 

1. Click  (if you want to change only the current configuration) or  (if you want to change all 

configurations) to display the Highlight (1) tab in Properties. 

2. Make sure that Highlight these Words is checked. 

3. Click the Add button, and enter a string to highlight. 

To Specify Non-wrap Words 

1. Click  (if you want to change only the current configuration) or  (if you want to change all 

configurations) to display the No Wrap tab in Properties. 

2. Make sure that Enable Non-Wrap Words is checked. 

3. Click the Add button to enter words you do not want separated in the process of wrapping lines. 

To Set High Speed Scroll 

1. Click  (if you want to change only the current configuration) or  (if you want to change all 

configurations) to display the Scroll tab in Properties.  

2. Select Double Line Scroll and Faster Cursor Movement. 
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To Define Encodings 

1. Select the Define Encodings command under the Tools menu. 

2. Click the New button if you want to define a new encoding. 

3. Select the Encoding and the Font Category, and enter the Name for this encoding. 

Tips 

To open a file with a defined encoding, select the specified encoding in the Open dialog box. 

To Define a New Configuration 

1. Click  and select Define Configuration from the menu. 

2. Click the New button, and name the new configuration. 

3. Click the Properties button to change the new configuration properties. 

Tips 

 By defining multiple configurations, you can effectively select other configurations. 

 To copy and modify another configuration, select a configuration and click the Copy button. 

To Select a Configuration 

 If you associate a file extension or extensions with a configuration, the configuration associated with the 

file name extension will be selected automatically when a file is opened. If syntax keywords are defined for 

the configuration, the syntax will be highlighted accordingly. 

 If you are creating a new document, select the correct configuration under the Tools menu and syntax will 

automatically be highlighted as you type if syntax keywords are defined for that configuration. 

Tips 

 Most options related to how syntax is highlighted can be changed on the Highlight (1) and Highlight (2) 

pages in Properties for Current Configuration under the Tools menu. 

To Create a New Syntax File 

1. First export a current syntax file so you have a structure to work with. To export a current syntax file, 

select a configuration that offers syntax highlighting such as Perl. Select Properties for Current 

Configuration from the Tools menu and select the Highlight (1) tab. Click on the Export button, select 

the location where you would like to save the syntax file, and give it a descriptive name. 

2. Open the exported syntax file and note the structure. You will want to specify some of the options as well 

as replace the existing keywords with keywords specific to the new syntax file you are creating. An 

explanation of the options, which correspond to the settings on the Highlight (1) and Highlight (2) pages 

in Properties for Current Configuration, follows: 

#Highlight= Either on or off depending on whether or not you want to highlight syntax. 

#BeginTag= Specify the character used as an opening tag. For example, < for HTML syntax. 

#EndTag= Specify the character used as a closing tag. For example, > for HTML syntax. 
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#CommentBegin= Specify the character(s) used to mark the beginning of comments. For example, /* for 
C++ syntax. 

#CommentEnd= Specify the character(s) used to mark the end of comments. For example, */ for C++ 
syntax. 

#LineComment1= Specify the character(s) used to mark line comments. For example, // for C++ syntax. 

#LineComment2= Specify additional character(s) used to mark line comments. 

#SingleQuote= Either on or off depending on whether or not you want text strings enclosed in single 

quote marks to be highlighted. 

#DoubleQuote= Either on or off depending on whether or not you want text strings enclosed in double 

quote marks to be highlighted. 

#ContinueQuote= Either on or off depending on whether or not you want text strings enclosed in quotes to 

span lines. 

#Escape= Specify the character used as an escape for quote marks. 

#ScriptBegin= Specify the character(s) used to mark the beginning of a script. 

#ScriptEnd= Specify the character(s) used to mark the end of a script. 

#SpecialSyntax= Specify HTML, HTML-Embedded, or off depending on the mix of HTML and script 

languages, if any, in the same document. 

 HTML is used when HTML tags specifying the script language (<SCRIPT 
type=...>) exist in the HTML document. HTML is also appropriate for ASP files 

that include scripts beginning with the <% mark. This is usually the case for 
VBScript, JavaScript, PerlScript, CSS, etc. 

 HTML-Embedded is appropriate when working with script languages such as 

PHP or JSP and the characters that normally mark the beginning of scripts in 
such languages are specified with #ScriptBegin. 

 

#HighlightBraces= Either on or off depending on whether or not you want braces to be highlighted. 

#Keyword= #Keyword options include: 

 color= Specify the color of the highlight. You can preview the color choices in 
the Display tab in Properties for Current Configuration. If you scroll through 

the list located there you will notice Highlight (1) - (10). 

 word= Specifying on will highlight keywords only if they are whole words. For 
example, if the keyword is run and you specify word=on, the run portion of 
runner will not be highlighted. 

 rightall= Either on or off depending on whether or not you want to highlight 

everything to the right of a keyword match in addition to the keyword.  

 case= Either on or off depending on whether or not you want to enable case 

sensitivity for keyword matches.  

 insidetag= Specifying on will highlight keywords only if they occur within tags. 

 regexp= Specifying on will highlight keywords matched by using a regular 

expression. 

3. Once you have completed and saved your syntax file, you can create a new configuration and import the 

newly created syntax file, or import the newly created syntax file into an existing configuration. 

Tips 

 In the syntax file, the escape character is '^', and the following three characters must be escaped: '#', ';', 

and '^' itself. 



48  How to… - Macro 

 

 

To Enable Wrap Indent 

1. Click  (if you want to change only the current configuration) or  (if you want to change all 

configurations) to display the General tab.  

2. Click the Tab/Indent button. 

3. Check Wrap Indent. 

To Enable Virtual Space 

1. Click  (if you want to change only the current configuration) or  (if you want to change all 

configurations) to display the General tab. 

2. Check Enable Virtual Space. 

To Enable Smooth Scroll 

1. Click  (if you want to change only the current configuration) or  (if you want to change all 

configurations) to display the Scroll tab. 

2. Check Smooth Scroll. 

3. Adjust Speed. 

Macro 

To Record or Run Macro 

1. Click  on the Toolbar.  

2. Perform the operations you want recorded. 

3. Finish recording by clicking  again on the Toolbar. 

4. To run the recorded macro, click   on the Toolbar. 

Tips 

 EmEditor cannot record all operations. For example, mouse cursor movement is not allowed during the 

quick macro, because it cannot be recorded. 

 By default, SHIFT + F4 (Start/Stop Macro Record) and F4 (Run Macro) keys are assigned as these 

commands. 
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Plug-ins 

To Install Plug-ins 

1. Download the plug-ins you want to install from the Internet. Many plug-ins are available from the 

Emurasoft Home Page. 

2. Follow the directions included with the downloaded plug-ins to properly install them. Usually, copying the 

file with a .DLL extension to the PlugIns folder in the EmEditor directory (usually, C:\Program 

Files\EmEditor3\PlugIns) will complete the installation. 

3. When you run EmEditor, the plug-ins menu item that you installed will be added under the Tools menu 

and a button will be added to the toolbar. 

Tips 

 Use the newest version of EmEditor and the plug-ins to ensure that they work together properly. 

 You can customize toolbar buttons, menus and keyboard shortcuts. 

To Change Plug-in Properties 

1. With advanced plug-ins that have properties, select Customize Plug-ins... under the Tools menu. 

2. Select the plug-in that you want to change and click Properties. 

Tips 

 With plug-ins that do not have properties, you cannot change the properties. 

To Uninstall Plug-ins 

1. With Plug-ins that have uninstalling functions, select Customize Plug-ins... under the Tools menu. 

2. Select the plug-in that you want to uninstall, and click Uninstall. 

Tips 

 With plug-ins that do not have uninstalling functions, you cannot select the Uninstall button. Instead, you 

may manually delete the .DLL files from the C:\Program Files\EmEditor\PlugIns folder. 

 Instead of uninstalling, you can just disable a plug-in. To disable a plug-in, clear the check box of the item 

you want to disable in the Customize Plug-ins dialog box. 

To Develop Plug-ins 

You can develop plug-ins that extend EmEditor functions by using the C Programming Language. For details 

refer to the EmEditor Plug-ins Help on the Emurasoft Home Page. 
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To Use the Explorer Plug-in 

The Explorer plug-in is installed by default with EmEditor Professional. This plug-in displays the folder tree 

and allows you to open a file from the folder tree. To use the Explorer plug-in: 

1. Click   on the Plug-ins bar. Or in the Tools menu, point to Plug-ins, and then click Explorer. The 

Explorer custom bar will appear. 

2. Find and click a file to open from the folder tree, and the file will be opened with EmEditor. 

Tips 

 Press the F6 key or ESC key to set the keyboard focus back to the editor. 

 To enter the path directly, use the Path drop-down list. 

 To display only certain file types, set the filter in the Filter drop-down list. Wild cards (*, ?) can be used. To 

separate multiple file specifications, use a semicolon (;). 

 Right-click on the list to view hidden files, refresh, or clear the Path and Filter history. 

 Single-click opens an item by default. You can change this behavior from the plug-in properties. 

To Use the FindBar Plug-in 

The FindBar plug-in is installed by default with EmEditor Professional. This plug-in displays a toolbar filled 

with the Find drop-down text box and several options, which helps you to find strings without accessing the 

Find dialog box. To use the FindBar plug-in: 

1. Click   on the Plug-Ins bar. Or in the Tools menu, point to Plug-ins, and then click FindBar. The Find 

toolbar will appear. 

2. Set or clear any options: 

Incremental 

Search 

When this is checked, the search immediately starts as you type in the Find drop-down list box. 

(The keyboard shortcut is ALT + I while the Find drop-down list has the keyboard focus.) 

Search All 
Open Documents 

When this is checked, the search is carried out in all open documents. (The keyboard shortcut is 
ALT + S while the Find drop-down list has the keyboard focus.) 

Match Case 
Match cases when searching for a string. (The keyboard shortcut is ALT + C while the Find 

drop-down list has the keyboard focus.) 

Use Regular 
Expressions 

Enable regular expressions. For more information on regular expression syntax, see To Use 
Regular Expressions. (The keyboard shortcut is ALT + X while the Find drop-down list has the 

keyboard focus.) 

Use Escape 
Sequence 

Enable escape sequences. You can use the following characters as escape sequences. For 
more information on escape sequences, see Use Escape Sequence check box. (The keyboard 
shortcut is ALT + E while the Find drop-down list has the keyboard focus.) 

Search Only 
Word 

Search words only. A word is defined as a string that begins and ends with any of these 
characters: A - Z, a - z, 0 - 9, or an underscore. Strings surrounded by full-width characters are 
considered as words. (The keyboard shortcut is ALT + O while the Find drop-down list has the 

keyboard focus.) 

Move to Search down from the current position by choosing Find Down. If the word is not found by the 



How to… - Plug-ins  51 

 

 

Start/End of 
Document 

end of the file, it will continue searching from the top of the file. By choosing Find Up, search 

from the current position up to the beginning of the file. If the word has not been found, it will 
continue searching from the bottom of the file. (The keyboard shortcut is ALT + M while the Find 

drop-down list has the keyboard focus.) 

3. Type in a string that you want to search for in the active document, and press ENTER to search forward or 

SHIFT + ENTER to search backward. 

Tips 

You can assign a keyboard shortcut for this plug-in command, so you can move the focus to the plug-in Find 

drop-down list easily. See also To Change the Keyboard Shortcuts. 

 To Use the HTMLBar Plug-in 

The HTMLBar plug-in is installed by default with EmEditor Professional. This plug-in displays a toolbar, filled 

with buttons, which helps you insert frequently used HTML tags and elements. To use the HTMLBar plug-in: 

1. Open an HTML file, and click  on the Plug-Ins bar. Or in the Tools menu, point to Plug-ins, and then 

click HTMLBar. The HTML toolbar will appear. 

2. Click any button of the HTML tag or element you would like to insert in the HTML document. 

HTMLBar Plug-in Customizable Buttons 

In order to customize the toolbar buttons: 

1. Right click  on the Plug-in toolbar, then click Properties. The HTML Bar Properties box is displayed.  
2. Click on the Customize Buttons button. The Customize Buttons dialog box will appear. The predefined 

buttons are listed. You can click the New button to add a new button, or the Properties button to edit the 
selected button. When you click the New button or the Properties button, the Button Properties will 

appear, where you can set the following options:  

Icon selects an icon for the button. 

Title 
specifies a title for the button. The title is also displayed as a tooltip when a mouse 

hovers over the button. 

Insert Tags (Begin 

and End) 

specifies begin and end tags to insert for this command. For instance, if you want 

the button to underline text, enter "<u>" in the Begin text box and "</u>" in the End 

text box. You can use special macros and insert them easily by clicking the ">" 

arrow and choosing one of the items in the list. For instance, \{Path} inserts the file 

path of the current document, \{PickFullPath} allows you to select a document in an 

Open dialog box, and \{PickColor} allow you to select a color in the Color dialog 

box. 

Special Commands 

(Table, Font, 

Unindent, Heading, 

Form, Customize) 

These commands do specific tasks and are not customizable in details. 

Table: displays the Insert Table dialog box where you can specify the rows and 

columns of the table, and inserts the table in the HTML document. 

Font: displays the Font dialog box where you can select a font, and insert the font 
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tag. 

Unindent: removes indent for the selected lines. 

Heading: If you press this button, a context menu appears with items from H1 to 

H6. Selecting one of these items inserts the corresponding tag (<h1> to <h6>). 

Form: If you press this button, a context menu appears with form and form element 

items. 

Customize: displays the Customize Buttons dialog box. 

Separator Inserts a separator between buttons. 

 

Tips 

By default, the HTMLBar plug-in doesn't appear automatically when an HTML file is opened. You 
can change this behavior from the plug-in Properties, which can be accessed by right-clicking the 
plug-in button on the Plug-ins bar, and selecting the Properties. 

To Use the Open Documents Plug-in 

The Open Documents plug-in is installed by default with EmEditor Professional. This plug-in displays the list 

of open documents, and allows you to activate, close, or save selected documents within the list. To use the 

Open Documents plug-in: 

1. Make sure that tabs are enabled. When tabs are enabled, the Enable Tabs menu item is checked in the 
Window menu.  

2. Click the   on the Plug-ins bar. Or in the Tools menu, point to Plug-ins, and then click Open 
Documents. The list of open documents will appear in the Open Documents custom bar.  

Context Menu Options 

Right-click on the list of open documents and the context menu will appear.  

Choose to: 

    Activate, Save, Close or other operations against the selected document.  

    Refresh or Select All documents.  

    Close All Others in Group, Close All Previous, or Close All Next.  

    Create a New Group or New Minimized Group.  

    Move a document to Next Group or Previous Group.  

    Arrange the documents by Name, Type, Modified, Active, Ascending Order, Descending Order, or 

Auto Arrange.  

    View the Full Path, or Title, or a Blend of the two. 

 

Tips 

 Press the F6 key or ESC key to set the keyboard focus back to the editor.  

 Click the middle mouse button to close the selected document in the list.  
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To Use the Outline Plug-in 

The Outline plug-in is installed by default with EmEditor Professional. There are two major functions in this 

plug-in:  

 

Outlining in the custom bar 

1. A tree view appears when you click the  on the Plug-ins bar. Or in the Tools menu, point to Plug-ins, 

and then click Outline. In the Outline custom bar, the outline appears as a tree.  

2.  You can click on nodes to expand or collapse levels. You can right click on the custom bar and expand all 

or collapse all.  

3. If you click on an item in the custom bar, the main text is synchronized.  

4. You can drag and drop an item, to change the order of the text.  

5. Selecting ALT+UP or ALT+DOWN moves the selected item up or down within the tree.  

6. You can right click on an item and click Select, and the corresponding text will be selected within the main 

text.  

7. The Outline custom bar shows up to 6 levels.  

 

Outlining as a guide 

1. A guide appears on the left side of the editor without the custom bar. By default this outline guide is 

synchronized with the custom bar.  

2. To disable this outlining guide even if the custom bar is displayed, right-click on the Outline button on the 

Plug-ins bar, select Properties, and clear the Display Outline as Guide check box.  

3. In the main text window, when the levels are closed, they display a [...] if there is more text. You can hover 

over the [...], to view the rest of the text.  

4. You can right click and expand all or collapse all, or even expand or collapse to a specific level.  

5. Some useful keyboard shortcuts include, ALT+RIGHT to expand, and ALT+LEFT to collapse.  

6. ALT+UP jumps up a node and ALT+DOWN jumps down a node.  

 

Properties 

You can change the properties for each configuration. In a text document, by default the plug-in uses spaces 

to outline. C++ configuration uses { and } open and close curly brackets to outline. For C++ the custom bar 

only shows 1 level. XML uses open and close tags to outline. XML can show up to level 6 in the custom bar. 

For each configuration, you can customize these settings to fit your needs. 

 

Custom Bar Position 

Selects where the custom bar should be positioned in the EmEditor window. 

 

Turn off Outline Guide when Custom Bar is not displayed 
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Specify whether the Outline Guide should be synchronized with the Custom Bar or not. It is set as 

synchronized by default. 

 

Configuration 

Selects a configuration for which you would like to change the settings. 

 

Display Outline as Guide 

If this is checked, the plug-in displays the outlining as a guide on the left side of the editor without the custom 

bar. 

 

Type 

Determines how outlining is calculated. Select one from the following: 

 Number of Braces {}: outlining is calculated by number of braces. This may be useful for many 
programming languages. 

 Number of Spaces: outlining is calculated by number of spaces or tabs at the beginning of each line. 
This may be useful for general purposes. 

 Custom: outlining is calculated according to the specified settings below. 

 Number of Brackets []: outlining is calculated by number of brackets. This may be useful for some 
programming languages. 

 Custom (Specify Begin as Level 1/End as Level 2): outlining is calculated according to the specified 
settings below. Level 1 is set as the begin string and level 2 as the end string. 

 

 

Custom Bar Max Level 

Specifies the maximum outlining level to be displayed in the Custom Bar. This, however, does not limit the 
maximum outlining level for the guide- it is always six. 

 

Level 1-6 

If the "Regular Expression" is unchecked, enter character(s) that a line should begin with. For instance, enter 
"." to match only the lines beginning with ".". If the "Regular Expression" is checked, enter a regular expression 
that should match for the specified level. For instance, enter "^\d.*?$" to match only the lines beginning with a 
number. 

 

Tips 

 Press the F6 key or ESC key to set the keyboard focus back to the editor. 

 The custom bar position can be set to top, bottom, right or left by right-clicking the plug-in button on the 

Plug-ins bar, and selecting the Properties. 

To Use the Projects Plug-in 

The Projects plug-in is installed by default with EmEditor Professional. This plug-in displays folder trees and 

allows you to open files from the folder trees.  
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To create a new project using the Projects plug-in: 

1. Click  on the Projects bar. Or in the Tools menu, point to Plug-ins, and then click Projects. The 

Projects custom bar will appear.  

2. Right-click in the Projects bar, and select New Projects.  

3. Right-click on Untitled Project, and select Add Existing Files.  

4. Select all files you want to include in the project.  

 

The Projects Plug-in Commands 

Right clicking on the Projects bar shows the following options: 

Expand/Collapse expands or collapses the node. 

Open All opens all files in the folder. 

Open opens the file. 

Open as Read-Only opens the file as read-only. 

Open with Encoding opens the file with a specified encoding. 

New Folder creates a new folder. 

Cut cuts the selected item and moves it to the Clipboard. 

Copy copies the selected item and pastes it to the Clipboard. 

Paste inserts the contents of the Clipboard. 

Remove removes the selected item. 

Rename renames the selected item. 

Run Solution runs the solution. 

New Solution creates a new solution. 

Open Solution opens an existing solution. 

Save Solution As saves the solution file with a new name. 

List of Recent Solutions opens a specified recently accessed solution (multiple items). 

New Project creates a new project. 

Open Project opens an existing project. 

Save Project As saves the project file with a new name. 

Add Existing Files adds existing files to the project. 

Add Active File adds the active file to the project. 

Add All Open Files adds the all open files to the project. 

List of Recent Projects opens a specified recently accessed project (multiple items). 

Set as Startup Project sets the specified project as the startup project. 
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File Name Only displays the file name only for each item. 

Relative Path displays the relative path for each item. 

Full Path displays the full path for each item. 

Refresh Symbol List refreshes the symbol list for the current project. 

Refresh All Symbol Lists refreshes the symbol lists for all projects. 

Symbol List shows or hides the symbol list. 

Configuration lists the available configurations. 

Platform lists the available platforms. 

Properties for Current Solution Template displays the properties for the current solution template. 

Solution Templates defines solution templates. 

Plug-in Properties displays the plug-in properties. 

List of Tools runs a specified tool. 

 

The Projects plug-in toolbar 

 New Solution creates a new solution. 

 Open Solution opens an existing solution. 

 Run Solution runs the open solution. 

 Parameter 

Information 
displays the parameter information. 

 Go to 

Definition 
causes the cursor to jump to definitions. 

 Pop Browse 

Context 
causes the cursor to return to the previous. 

 Symbol List displays a list of symbols. 

 Properties for 

Current Solution 

Template 

displays the customizable properties for the current solution template. The General tab 

includes the Solution Format, File Extension, and Read Only option. The Configurations 

tab includes Configurations, Platforms, and Macros. The Symbols tab includes, Refresh 

All Symbol Lists Automatically and Additional Parameters to Ctags. The Tools tab 

includes customizable tools. The Keyboard tab includes the option to assign commands 

to keyboard shortcuts for this plug-in. 

 Solution 

Templates 
displays the Solution Template dialog box. 
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 Plug-in 

Properties 
displays the plug-in Properties. 

 

Solution Templates 

Every solution you create, open, or save in the Projects plug-in belongs to a solution template. Each solution 

template specifies the associated file extension’s characteristics, including solution formats, macros, tools, and 

keyboard shortcuts. When you open a solution file, a solution template associated with the file extension is 

selected and behaves per the characteristics defined for the template. 

 

Solution Templates dialog box 

This dialog box appears when you click the  button. Available solution templates are displayed in the list. 

Click the Properties button to display the properties of the selected solution template. 

 

Solution Template Properties 

 

General tab 

Solution 

Format 
selects a solution format. Currently, only EmEditor and Visual Studio can be selected.  

File 

Extension 
specifies the file extension for solution files. When you open a solution file, a solution 

template associated with the file extension is selected. 

Read Only 
specifies whether the solution is read only. If you set the read only, you won't be able to add 

files to the solution, and the project files won't be overridden when a solution is saved.  

 

Configurations tab 

Configurations 
selects a defined configuration. Selecting <New> allows you to define a new configuration. 

Selecting <Edit> allows you to delete a configuration.  

Platforms 
selects a defined platform. Selecting <New> allows you to define a new platform. Selecting 

<Edit> allows you to delete a platform.  

Macros 
displays the list of defined macros. It allows you to specify a value for each macro and for 

the combination of each configuration and platform. 

New creates a new macro. 

Delete deletes a selected macro. 

Rename renames a selected macro. 

 

Symbols tab 
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Refresh All Symbol Lists 

Automatically 
specifies whether to update the symbol list when a new file is added.  

Additional Parameters to 

Ctags (advanced option) 

specifies additional parameters to Ctags. This is an advanced option, and 

setting incorrect parameters may prevent the symbol list from working 

properly.  

 

Tools tab 

Tools displays the list of defined tools. 

New creates a new tool. 

Delete deletes the selected tool. 

Copy copies the selected tool. 

Up moves the selected tool up on the list. 

Down moves the selected tool down on the list. 

Properties shows or edits the selected tool properties. 

 

Keyboard tab 

Commands lists available commands. 

Press New Shortcut Key enter shortcut key for the selected command. 

Current Keys current keys assigned to the selected command. 

Assign assigns the shortcut key to the currently selected command. 

Delete deletes the selected key. 

 

Creating Configurations and Macros for Solutions 

Under Configurations properties in the Properties for Current Solution Template dialog box, you can create 

new and edit configurations and macros.  

 

To create a new configuration: 

1. Click <Default> under configurations, then click <New>.  

2. You can specify the configuration name. For example, create a configuration named, Debug.  

3. You can create macros for each configuration.  

4. Under macros, click New. Name the macro OPTIONS and specify its value as /D _Debug.  

5. Now create another configuration named, Release.  

6. Under the Release configuration, for the macro named OPTIONS, specify its value as /O1.  

7. Now you have specified configurations, and macros for each configuration.  
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Creating Tools for Solutions 

Under Tools properties, in the Properties for Current Solution Template dialog box, you can create new tools. 

Tools Properties allows you to specify the Title, Command, Arguments, Initial Directory, Icon Path, and Current 

Icon, among other options. The Tools Properties provides some predefined Arguments, such as File Path and 

Current Line.  

 

To create a new tool: 

1. Click New in the Tools Properties dialog box.  

2. Name the tool, Compile.  

3. Specify the Command, for example, C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\cl.exe.  

4. Specify the Argument, for example, $(OPTIONS) $(Path).  

5. Specify the Initial Directory, for example, $(Dir).  

6. Specify the Icon Path and Current Icon.  

7. Click the Saves Files button to direct the tool to save the files.  

8. Click the Use Output Bar to specify the desired Output Encoding.  

9. When finished, click OK.  

 

Predefined Arguments 

$(Path) the full path and name of the active document. 

$(Dir) the directory of the active document. 

$(Filename) the file name of the active document without file extension. 

$(Ext) the file extension of the active document. 

$(RelPath) the relative path and name of the active document. 

$(CurLine) the line number of current line. 

$(CurText) the word of the current cursor position. 

$(Solution) the full path and name of the solution file. 

$(Project) the full path and name of the project file. 

$(SolutionDir) the directory of the solution. 

$(ConfigurationName) the active configuration name. 

$(PlatformName) the active platform name. 

$(FrameworkSDKDir) framework SDK directory with trailing backslash. 

$(VCInstallDir) the Visual C++ install directory with trailing backslash. 

$(VSInstallDir) the Visual Studio install directory with trailing backslash. 

$(WindowsSdkDir) the Windows SDK install directory without trailing backslash. 

$(LatestFrameworkDir) the Framework directory. 

$(SourceSafe) full path and name of Visual SourceSafe executable (ss.exe). 
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$(SccProjectName) the project name for SourceSafe. 

 

Sub Arguments 

f file name without extension. 

d directory. 

x file extension. 

 

Examples 

$(Project,d) returns the directory of the project file. 

$(Solution,f)  returns the file name without extension of the solution file. 

$(Solution,f).$(Solution,x) returns the file name with extension of the solution file. 

 

Tips 

 Press the F6 key or ESC key to set the keyboard focus back to the editor.  

 You may save Untitled Project by right-clicking on Untitled Project, and selecting Save Project As.  

To Use the Search Plug-in 

The Search plug-in is installed by default with EmEditor Professional. This plug-in searches opened 

documents for a string. To use the Search plug-in: 

1. Click  on the Plug-ins bar. Or in the Tools menu, point to Plug-ins, and then click Search. The 

Search custom bar will appear.  

2. Enter any word, phrase, or regular expression you want to search for in the Find text box. 

 Click the Match Case check box if the cases should be matched.  

 Click the Regular Expressions check box, if searching for regular expressions. 

3. Click Search or press the Enter key to start searching. 

4. The list of lines, including the searched string, will appear. 

5. Clicking an item in the list will jump to the specified line on the specified searched file. 

Tips 

 Press the F6 key or ESC key to set the keyboard focus back to the editor. 

 The custom bar position can be changed from the plug-in Properties. 

 To Use the Snippets Plug-in 

The Snippets plug-in is installed by default with EmEditor Professional. This plug-in allows you to insert 

words and phrases quickly. A snippet is a piece of text that you insert into your document and may contain 

plain text, placeholders, shell code, a macro, or regular expressions to transform text and various built-in and 

user-defined parameters. In the Snippets plug-in, you can create two types of items - snippets and macros. 
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To use the Snippets plug-in, Click  on the Plug-ins bar. Or in the Tools menu, point to Plug-ins, and 

then click Snippets. The Snippets custom bar will appear. 

 

Right-clicking on the Snippets bar shows the following options: 

Insert inserts the selected snippet. 

Edit edits the selected snippet. 

Select Snippet 
Displays a dialog box where you can type a few characters to select a snippet to 
insert. 

New Snippet creates a new snippet. 

New Macro creates a new macro. 

New Folder creates a new folder. 

Move Up moves the selected snippet up on the list. 

Move Down moves the selected snippet down on the list. 

Delete deletes the selected snippet. 

Delete All  deletes all of the snippets. 

Import to This Folder imports snippets to this folder. 

Import to Root imports snippets to the root folder. 

Export This Folder exports all snippets in this folder to the specified destination. 

Export All exports all snippets to the specified destination. 

Reset All (Import Default) resets all snippets and imports the default list of snippets. 

Trigger Keys shows or hides trigger keys. 

Configurations shows or hides configurations. 

Plug-in Properties displays the plug-in properties. 

Name arranges by name. 

Type arranges by type. 

Text arranges by text. 

Tip arranges by tip. 

Trigger arranges by trigger. 

Ascending Order arranges in ascending order. 

Descending Order arranges in descending order. 

Auto Arrange arranges snippets automatically. 

Properties displays the properties of the selected snippet or snippet folder. 

 

Snippets Plug-in Properties 

To adjust the properties of the snippets plug-in, right-click the Snippets Plug-in button on the Plug-ins bar 

and select Properties. 
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General tab 

Custom Bar Position sets the custom bar position. 

Run Background allows the snippets to work even if you close the Snippets custom bar. 

Default Shortcut Key specifies the default shortcut key; the initial default shortcut key is TAB. 

Verbosity adjusts the frequency of tips. 

Delay Time adjusts the delay time before a tip appears. 

 

Global Parameters tab 

Add adds a parameter and specifies its value. 

Delete deletes a parameter. 

 

Keyboard tab 

Commands lists available commands. (Popup Menu or Select Snippets) 

Press New Shortcut Key allows you to enter shortcut key for the selected command. 

Current Keys Current keys assigned to the selected command. 

Description Description for the selected command. 

Assign button Assign the shortcut key to the currently selected command. 

Delete button Delete the currently selected shortcut key. 

 

Snippets Folders Properties 

To adjust the properties of each of the snippets folders, right-click on a folder in the Snippets custom bar, 

and select Properties. 

 

General tab 

Name specifies the name of the snippets folder. 

 

Configurations tab 

Auto complete only with the following 

configurations 
specifies which configurations to auto complete 

with. 

Snippets sets the configuration to edit with for snippets. 

Macros sets the configuration to edit with for macros. 

 

Snippets Properties 
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To adjust the properties of each of the snippets, right-click on a snippet in the Snippets custom bar, and 

select Properties. 

 

General tab 

Name specifies the name of the snippets folder. 

Trigger specifies the trigger for the snippet. 

Shortcut specifies the shortcut for the snippet. 

Tip 
specifies the tip for the snippet.  

Type specifies the type (Snippet or Macro). 

Text specifies the text of the snippet. 

Edit allows a user to edit the snippet in the EmEditor window. 

 

Configurations tab 

Auto complete only with the following 

configurations 
specifies which configurations to auto complete 

with. 

Snippets sets the configuration to edit with for snippets. 

Macros sets the configuration to edit with for macros. 

 

Snippet Syntax 

Plain text 

You may include any plain text you want to insert into your document. To write plain text, most characters 

can be used, however, if you want to include \, $, or ` in your plain text, they must be escaped as \\, \$, and \`. 

 

Placeholders 

After you insert a snippet, the cursor position jumps between placeholders, and pressing the TAB key will 

jump forward to the next placeholder. 

 

You can define these tab stops within your snippet as ${n:default} where default is the default value that first 

appears when the snippet is inserted. When there is no default value, you can omit {} so the tab stop appears 

as $n, where n is an integer value between 0 and 9. When a user inserts a snippet, the first cursor position is 

at $1, and pressing TAB will forward the tab stop to next placeholder $2, $3, ... etc. The last tab stop is at $0. 

 

For instance, the following snippet inserts a hyperlink in HTML, and the first cursor position is at $1. While 

the cursor is at $1, if the user presses the TAB key, the cursor jumps to $2, and then to $0. 

 

<a target="$1" href="$2">$0</a> 

 

Snippets can include default values. The following snippet inserts a hyperlink with a default value. 
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<a target="${1:_blank}" href="${2:url}">$0</a> 

 

You can include a placeholder within a placeholder. The following snippet inserts a hyperlink tag with the 

target parameter selected. A user can decide to overtype the argument, delete it, or press the TAB key again 

to proceed to the next placeholder. 

 

<a ${1: target="${2:_blank}"} href="${3:url}">$0</a> 

 

Mirrors 

If you use the same placeholder index, all the values in these placeholders become the same or mirrored. 

The following snippet inserts a “for” loop. In this case, the value i is the default value for the placeholder $2, 

and placeholders with the same index are used in two other places. While the cursor is at ${2:i}, changing the 

value of i will be mirrored into the other places. 

 

for( ${1:int} ${2:i} = ${3:0}; $2 != ${4:10}; $2++ ){ 

    $0 

} 

 

Transformation 

You can transform the value of one placeholder into another by using a regular expression and a replace 

format. The syntax is: ${n/regexp/replace_format/option} where 

 

n: the index of the placeholder 

regexp: regular expression to search for 

replace_format: replace format 

option: currently only i (ignore cases) is supported 

 

 

The following example copies characters entered in the first line to the second line, except the first character 

is capitalized. 

 

$1 

${1/./\U\0/} 

 

Predefined parameters: 

$1 Placeholder 1 

$2 Placeholder 2 

$3 Placeholder 3 

$4 Placeholder 4 

$5 Placeholder 5 
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... 

$9 Placeholder 9 

$0 Last Placeholder 

${n:default} Placeholder n with default Text 

${Path} The full path name of the file. 

${Dir} The directory name of the current file. 

${Filename} The file name without its extension. 

${FilenameEx} The file name with its extension. 

${Ext} The file name extension. 

${LineText} Line at cursor position. 

${WordText} Word at cursor position. 

${SelText} The selected text. 

${CurCol} The logical column number of the cursor. 

${CurLine} The logical line number of the cursor. 

${Date} Today's date. 

${Time} The current time. 

${Charset} Charset (used in HTML meta tag) 

${TabSize} The tab size. 

${IndentSize} The indent size. 

${AutoIndent} 1 if auto indent is on, 0 if not. 

${UseSpacesForTabs} 1 if "Use Spaces for Tabs" is on, 0 if not. 

${AppVersion} The version of EmEditor. 

${PluginVersion} The version of the Snippets plug-in. 

${TM_FILENAME} Same as ${FilenameEx}. 

${TM_CURRENT_LINE} Same as ${LineText}. 

${TM_CURRENT_WORD} Same as ${WordText}. 

${TM_DIRECTORY} Same as ${Dir}. 

${TM_FILEPATH} Same as ${Path}. 

${TM_LINE_INDEX} Same as ${CurCol}. 

${TM_LINE_NUMBER} Same as ${CurLine}. 

${TM_SELECTED_TEXT} Same as ${SelText}. 

${TM_SOFT_TABS} Same as ${UseSpacesForTabs}. 

${TM_TAB_SIZE} Same as ${TabSize}. 

${PickFullPath,title,filter} The full path name of the selected file. The title is the title of the dialog box, and the 

filter is the file filter in the format: Text files|*.txt|All files|*.*|| 

${PickRelativePath,title,filter} The relative path name of the selected file. The title is the title of the dialog box, 

and the filter is the file filter in the format: Text files|*.txt|All files|*.*|| 

${PickColor} The RGB value of the selected color. 

${DefColor} The RGB value of the recently selected color. 
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You can also create your own parameter in this form ${parameter_name} where parameter_name is not 

predefined in the above list. When a new user parameter is used, a dialog box appears where you can insert a 

new value, unless the value of a parameter can be saved in the Global Parameter tab of the Plug-in properties. 

 

Shell Codes 

You can define a shell code that can run a console application and then pass strings to its standard input. 

The standard output, as well as the standard error, from the console application is redirected to the cursor 

position of your text document. A shell code must be specified by the following format: 

 

`- appname 

stdin1 

stdin2 

... 

` 

 

If the resulting string ends with a new line (CR, LF or CR+LF), the new line will be removed. For instance the 

following snippet inserts the contents of the ${name} parameter in upper characters. 

 

`- powershell - 

# prompts for name then echos the hello greeting 

\$name = "${name}".ToUpper() 

"Hello \$name!" 

exit  

` 

 

 

If you don't want to parse snippet parameters, you can write: 

 

`!- appname 

stdin1 

stdin2 

... 

` 

 

If you want to run a command used in command prompt, you can define a shell code that can be passed into 

the Command Prompt window (cmd.exe) in this form `#cmd shell_code`. The value you specify is passed to 

cmd.exe in this form: "%COMSPEC% /c shell_code". The standard output, as well as the standard error, from 

the console application is redirected to the cursor position of your text document. For instance the following 

snippet inserts the current folder listing. You can include as many shell codes as you want within each snippet. 

 

`#cmd DIR` 
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Macros 

You can include a macro in a snippet in the form of `# `. The first character # indicates this is a macro, not a 

shell code. If this is an ActiveScript other than JavaScript, such as VBScript, PerlScript, PHPScript, or 

RubyScript, you will need to define the language using "#language=". For instance, if you wish to use VBScript, 

you would write `#language="VBScript"...`. The Interface object is used to pass values between the snippets 

and the EmEditor macro engine. The following sample inserts the content of the Clipboard to the cursor 

position. 

 

The clipboard contains `# Interface.write( clipboardData.getData("") );`. 

 

Interface.write() method passes the macro result to the snippet. You can also use Interface.writeln() instead 

to add a carriage return and a new line (CR+LF) at the end of the result. You can include as many macros as 

you want within each snippet. 

 

Parameters within default value, shell code or macros 

The placeholder default values can contain parameters, shell code or a macro. The following snippet inserts 

a <p> tag with the selected text between <p> and </p> if a selection exists. 

 

<p>${0:${SelText}}</p> 

 

Shell code and macros can contain parameters within their code or macro. The following snippet displays a 

dialog box where a user enters a value for the ${name} parameter to continue. 

 

`# var s = "${name}"; 

for( var i = 0; i != 5; i++ ){ 

Interface.writeln( s ); 

} 

` 

 

 

You will need to be careful that all \ and ` are proceeded by a \. For instance, the following snippet inserts 

"C:\Program Files\EmEditor". 

 

`# Interface.writeln( "C:\\\\Program Files\\\\EmEditor" ); ` 

 

This is because a backslash must be written as \\, and JavaScript also converts a backslash to \\. As a result, 

a single backslash converts to four backslashes (\\\\). 

 

If you don't want backslashes converted and if you don't need to include any parameters within a shell code 

or macro, you can include an exclamation mark (!) at the beginning of the code. That is--in shell code, you 

would write `!...` and in macros, you would write `!#...`. Therefore, the previous example can be rewritten as: 
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`!# Interface.writeln( "C:\\Program Files\\EmEditor" ); ` 

 

Tips 

 Press the F6 key or ESC key to set the keyboard focus back to the editor. 

 The custom bar position can be set from top, bottom, right or left by right-clicking the plug-in button on the 

Plug-ins bar, and selecting the Properties. 

To Use the Web Preview Plug-in 

The Web Preview plug-in is installed by default with EmEditor Professional. This plug-in previews the 

current document with an embedded web browser. To use the Web Preview plug-in: 

1. Click  on the Plug-ins bar. Or in the Tools menu, point to Plug-ins, and then click Web Preview. The 

Web Preview custom bar will appear.  

2. Open any web page file in EmEditor, and the web preview appears in the custom bar. 

3. If you edit the web page and want to have the change reflected on the preview, right click on the custom 

bar, and select Refresh. 

Tips 

 Press the F6 key or ESC key to set the keyboard focus back to the editor. 

 The custom bar position can be set from top, bottom, right or left by right-clicking the plug-in button on the 

Plug-ins bar, and selecting the Properties. 

To Use the Word Complete Plug-in 

The Word Complete plug-in is installed by default with EmEditor Professional. As you type in the document, 

this plug-in displays the list filled with previously used words and highlighted words defined in EmEditor, and 

lets you select a word from the list to complete your typing. 

 

The Word Complete plug-in can also complete recently searched strings. This process works the same as 

completing words, but instead of completing words, the plug-in completes strings. 

 

To use the Word Complete plug-in: 

1. Click   on the Plug-Ins bar. Or in the Tools menu, point to Plug-ins, and then click Word Complete so 

that it is checked.  

2. Type the first few characters of the word you want to insert into the document, and a list filled with 

previously used words and highlighted words defined in EmEditor will appear. 

3. Use the UP or DOWN key to select the word to insert, and press Enter. 
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Plug-in Properties 

 

Dictionaries 

 

Highlight Words 
The strings defined in the Highlight (1) tab of Configuration Properties are used as the 

candidates. 

Used Words in 
Document 

The words in the current document are used as the candidates. 

Limit Lines Limits words within the specified lines before and after the current cursor position.  

Include Previous 
Document 

Includes the previous document for the candidate list. 

Include All 
Documents in 
Group 

Includes all the documents in the same group window. 

Only if Same 
Configuration 

Includes all the documents but only with the same configuration as the current 
document. 

Words in 
Dictionary File 

The words in a separate file are used as the candidates. 

Dictionary File 
Specifies the full path and the file name of a separate file that should be used as the 
candidate list. 

Free Format (if 
not checked, line 
by line) 

Specifies that any files containing words separated by spaces, can be used as 
dictionary files. If not checked, each word must be separated by a new line. 

Clipboard 
Contents 

The words in the Clipboard are used as the candidates. 

File Names File names within the same folder as the current document are used as the candidates. 

Searched Strings Shows the history of strings searched for in the past. 

Refresh Rate 
Specifies how often the candidates are refreshed so the candidate list is updated with 
recently typed words. The higher this rate is, the fewer characters must be  typed 
before the list is updated. 

 

Matching Criteria 

Match Case 

Specifies whether a case should be matched. For instance, suppose ABC and abc are 
found in the current document (or a dictionary file). If Never is selected, either ABC or abc 
can be used as a candidate, and typing either A or a displays either ABC or abc. If Only in 
Candidates is selected, both ABC and abc are used as a candidate, and typing A or a 
displays both ABC and abc. If Both in Candidates and in Typing is selected, both ABC and 
abc are used as a candidate, but typing A displays only ABC, and typing a displays only 
abc. 

Priority 
If Last Used Word First is selected, the last selected word will be initially selected when 

the candidate list is displayed. If Alphabetical Order is selected, the top item of the matched 
items will be initially selected. 

Word Type 
If Normal Words is selected, each word begins with an alphabet and ends with alphabets 
or numbers. If Dot Syntax is selected, each word can include a dot (.). If HTML/XML is 
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selected, each word can begin with < or &, can contain / or - in the middle of the word, and 
can end with > or ;. If Custom is selected, a user can define how words can be listed in the 

text boxes below. 

First 
Characters 

If Custom is selected in the Word Type drop-down list, enters first character that each 

word can begin with, in addition to alphabets. 

Mid 
Characters 

If Custom is selected in the Word Type drop-down list, enters characters that each word 

can contain, between the first character and the last character, in addition to alphabets and 
numbers. 

Last 
Characters 

If Custom is selected in the Word Type drop-down list, enters last character that each 

word can end with, but should not contain in the first or mid characters. 

 

Options 

Display Icons in the Candidate 
List 

Displays small icons at the left of each item in the candidate list. 

Automatically Complete when 
Only One Candidate is 
Available 

Allows the plug-in to complete automatically when a user presses the 
keyboard shortcut assigned to Show Candidates Manually (typically 
CTRL+SPACE) if only one item is available for the candidates. 

Use Highlight Colors in the 
Candidate List 

Colors the candidate list with colors defined as highlighted strings. 

Automatically Hide the List 
when No Candidate List 

Automatically hides the candidate list if no item matches when you type. 

Show Only Matched Words in 
the Candidate List 

Limits the candidate list only to matched words. 

Automatically Show the 
Candidate List as Typed 

Automatically displays the candidate list as you type. 

Number of Characters 
Number of characters typed before the plug-in displays the candidate list 
automatically. 

Delay Time 
Time that the plug-in waits before it displays the candidate list 
automatically after it finds matched words. 

 

Keyboard 

Commands Lists available commands. 

Press New 
Shortcut Key 

Enter shortcut key for the selected command. 

Current Keys Current keys assigned to the selected command. 

Description Description for the selected command. 

 

Tips 

By default, EmEditor monitors the keystrokes and automatically displays the list when you start typing a word. 

To disable this behavior, right-click the plug-in button on the Plug-ins bar, select the Properties, and clear the 

Automatically Show the Candidate List as Typed check box. You can still display the list by pressing the 

keyboard shortcut. The default keyboard shortcut is CTRL+SPACE, but you can assign another keyboard 
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shortcut by selecting the Keyboard tab in Properties. The options in the plug-in Properties can be set for 

each configuration.  

To Use the Word Count Plug-in 

The Word Count plug-in is installed by default with EmEditor Professional. This plug-in counts words 

contained in the entire document and in a selection of text. The word count plug-in by default counts the words 

in the entire document. If you make a text selection, it will count the words in the selection. To use the Word 

Count plug-in: 

1. Select text where you want to count words or select no text, to count the entire document.  

2. Click  on the Plug-ins bar. Or in the Tools menu, point to Plug-ins, and then click Word Count.  

The Word Count custom bar appears. In the first column, the plug-in displays the types of query: characters, 

width, words, and lines. In the second column, the plug-in displays the count of words in the entire document. 

In the third column, the plug-in displays the count of words in the selected text only.  

 

You can click the Refresh Now button to recount the document and/or selection and update the word count, or 

press the "Refresh Automatically" button to reflect changes immediately. (This does not apply to a selection 

of text.)  

 

The Word Count Plug-in queries are customizable. Click on the Customize button of the Word Count bar. 

The Customize Queries dialog box appears where you can create new, delete, copy and order queries. You 

can also click Reset to return all queries to the default settings.  

To create a new query (such as Uppercase characters): 

1. Click New in the Customize Queries dialog box. The Query Properties box appears.  

2. Name the new query in the Title text box.  

3. Specify the type by Number of Characters, Widths, Number of Words, or Logical Lines.  

4. Select the Use Regular Expression check box. Some Regular Expression examples are available by 

clicking the > button next to the text box.  

Tips 

Properties of an existing query can also be edited by selecting the query to edit in the Customize Queries 

dialog box, and clicking Properties. 
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Window 

To Split a Window 

Select Split from the Window menu, and then click the point in the window where you would like the split to 

occur. 

To Arrange Windows 

Select Tile Horizontally or Tile Vertically from the Window menu to arrange the windows as tiles. 

To Activate Another Window 

Select the desired window from the Window menu. 

Tips 

 Alternatively, click the tray icon with the right mouse button, and select the desired menu. 
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Chapter 3: Frequently Asked Questions  

Setup 

Q. How do I install the new version of EmEditor? 

You can install the new version of EmEditor by downloading the latest version from the EmEditor website 

( http://www.emeditor.com/ ). The steps are as follows: 

1. If the tray icon is running, close it. To close the tray icon, right click on the tray icon on the task bar, and 

select Close Tray Icon. 

2. Uninstall the previous version of EmEditor from Control Panel. 

3. If the message box "Do you want to keep EmEditor settings before they are completely uninstalled?" 

appears, select "Yes" if you need to keep all your previous settings. It is recommended to select "No" 

unless you need to keep all your previous settings. 

4. You can download the new version at EmEditor website. 

( http://www.emeditor.com/ ). 

5. When you click the link for download, the File Download - 

Security Warning dialog box appears: 

6.  Clicking the Run button should start the downloading, and 

the Internet Explorer - Security Warning dialog box 

appears: 

7. Click Publisher: Emurasoft, Inc. 

8. Make sure you read This digital signature is OK in the 

Digital Signature Details dialog. If this phrase does not appear in the dialog box, the downloaded file is 

corrupted, and you will need to clear the Temporary Internet files, and try downloading again. Click OK to 

close the dialog box. 

9. Clicking the Run button will launch the Setup. Follow the instructions that appear on the screen to 

proceed with the setup. See the Installing EmEditor section of this manual for more details. 

Q. I am using an older version of EmEditor. Can I install a newer version of EmEditor 

without uninstalling the previous version? 

If you have been using EmEditor v11 or newer and want to maintain the same configurations, you do not 

need to uninstall the previous version. You can install the newest version with the same destination folder. The 

steps are as follows: 

1. Install the newest version. 

2. When the installation is complete, reboot Windows. 
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If you have been using a version of EmEditor older than v11, or don't want to maintain the same 

configurations of EmEditor, we recommend uninstalling the previous version completely and rebooting the 

computer before installing the newer version of EmEditor. The steps are as follows: 

1. Click the Start button and select Control Panel from the Start menu. Select the EmEditor (or EmEditor v3) 

from the Add or Remove Programs. Click the Delete button. 

2. Reboot Windows when uninstalling is complete. 

3. Install the new version. 

Q. Can both the old version of EmEditor and new version of EmEditor coexist on the 

same computer? 

No. The old version of EmEditor and new version of EmEditor can't coexist on the same computer. 

Q. Installation folder is set to C:\Program Files\EmEditor3. Is this correct? 

By default, the installation folder for EmEditor v3 is set to C:\Program Files\EmEditor3. For EmEditor v4 and 

later, the default installation folder is set to C:\Program Files\EmEditor. If you have installed EmEditor v4 or 

later without uninstalling EmEditor v3, the installation folder remains the same as the previous version (in this 

case C:\Program Files\Emeditor3). 

Q. What do I do if EmEditor crashes when starting or editing? 

1. If you have plug-ins installed, remove all plug-ins from the plug-ins folder, and try running EmEditor again. 

2. If the problem persists, select Add/Remove Programs in Control Panel to uninstall EmEditor. Reboot 

your PC, and reinstall EmEditor. 

3. If EmEditor crashes only when opening UTF-8 or Unicode files, select Font under the View menu, select 

Normal from the Character set list, select the Change button beside the Display Font box and check if 

the proper font is selected. 

Q. How can I remove the EmEditor Tray Icon permanently? 

Run the EmEditor installation again and make sure the Add the tray icon on the task bar check box is 

unchecked during the setup. This way you will not see the Tray Icon any more. You do not need to uninstall 

EmEditor before running the installation again. If this does not work, select Search from the Windows Start 

menu, and search for "emeditor.lnk". This file should be located in the Startup folder. Delete this file to remove 

the tray icon permanently. 

Q. How can I install EmEditor without displaying dialog boxes? 

During normal installation, dialog boxes will be displayed, and a user must click the "Next" button or set 

options. However, when you install EmEditor into multiple computers in corporate or group environments, you 

might want to use a batch or scripting file to automate the installation. On Version 6.00 or later, Windows 

Installer is used for installation, and the "quiet" installation is possible. 

For instance, if the EmEditor installation file is emed905ep32.msi, running the following command: 
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Emed905ep32.msi /q 

will install EmEditor with default settings without displaying any dialog boxes. If you wish to change the default 

settings, you can use following options: 

 

NOTRAYICON=1 does not display a tray icon on the task bar. 

NOTXT=1 does not associate text files to EmEditor. 

NOIEVIEW=1 does not use EmEditor to view source on Internet Explorer. 

NOIEEDITOR=1 does not add EmEditor to Internet Explorer HTML editor list. 

NOPLUGINS=1 does not install plug-ins. 

REGKEY=xxxxxx enters a registration key. 

 

For instance, if you wish to install EmEditor without associating text files to EmEditor, run: 

Emed905epx.msi /q NOTXT=1 

There are many options for Windows Installer. For details, run: 

msiexec /? 

to display the list of available commands. 

Q. How can I change the install folder? 

By default, the install folder is the same folder as the previous version, or \Program Files\EmEditor if this is a 

fresh install. To change the install folder, open Command Prompt, and run the installer with the TARGETDIR 

option. 

For instance, if the EmEditor installation file is emed905epx.msi, and if you want to install EmEditor to C:\path, 

run the following command: 

 

emed905epx.msi TARGETDIR="C:\path\" 

 

A backslash '\' is required at the end of the folder name. 

More than one versions of EmEditor cannot coexist on the same computer. If an old version is already installed, 

you must uninstall the old version first, or install the new version to the same folder as the old version. 

 

Q. How can I install an EmEditor syntax file? 

1. Choose Select Configuration under the Tools menu. 

2. Click Define Configuration at the very bottom of the list. 

3. Click the New button, select Use Default Configuration and click OK. 

4. Enter a descriptive name and click Enter. 

5. Click the Properties button and select the Highlight (1) tab. 

6. Click on the Import button, locate, and open the appropriate syntax file. 
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7. Finally, click on OK to close the Properties dialog box and click on Close to close the Configurations dialog 

box.  

 

If you want to enable associated extensions and specify an extension or extensions that EmEditor should 

associate with the configuration, follow these additional steps: 

8. Make sure the correct configuration is selected under the Tools menu. 

9. Click Properties for Current Configuration under the Tools menu. 

10. Select the Association tab and check the Enable Association box. 

11. Click Add and enter the appropriate extension or extensions. 

 

Q. I am using a new version (or a new beta version) of EmEditor. Can I install an older 

version of EmEditor without uninstalling the new version? 

No. You should uninstall the new version of EmEditor before installing an older version of EmEditor. Failure to 

do so might cause some new DLL files to remain in the install directory, which can be incompatible with the 

older version of EmEditor. Before you uninstall the newer version, you should exit all EmEditor windows, 

including the Tray Icon. When you uninstall the new version, you will be asked to keep all the settings. 

Selecting YES will keep all the settings that may be used in the older version of EmEditor. If you are asked to 

restart Windows during the installation, you should restart Windows. 

Q. When EmEditor Professional is installed, the associated text file icon does not 

become one of EmEditor’s icons. 

EmEditor Professional does not change the text file icon from Windows system icon any more. If you prefer 

one of EmEditor icons for text files, run EmEditor, select Customize in the Tools menu, select the File tab, 

click the Associate with EmEditor button. Select the "txt" icon in the list, click the Properties button, enter 

emedres.dll file in EmEditor folder (usually C:\Program Files\EmEditor\emedres.dll) in the Sample Icon from 

This File text box, and select the txt icon in the Current Icon list box.. 

File 

Q. When I try saving a file as a file name without an extension, ".txt" will be added 

automatically. How can I prevent an extension from being added to a file name? 

Surrounding the file name with quotation marks ("") will prevent an extension from being appended.  For 

example, "file" will just be saved as file instead of file.txt. 
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Q. When opening a file, EmEditor detects the file as a Western European even though 

it is actually a Japanese (Shift JIS) file. 

In the File tab of Properties, uncheck Detect All if it is checked. The code page detection can make 

mistakes, especially with small files. 

Q. How can I close all windows at the same time? 

Click X in the upper right corner of the window while pressing the SHIFT key. Alternatively, you can close all 

in the following ways: 

 Press ALT + SHIFT + F4. 

 Press ALT + SHIFT + X. 

 Select Close from the File menu while pressing the SHIFT key. 

 Add the Close All button to the Toolbar, and click that button. 

 Click the Tray Icon and select Close All from the menu. 

Q. How can I open from the same folder in the open dialog? 

Select Customize under the Tools menu, and check the Remember Last Folder check box in the 

Customize dialog box. 

Alternatively, display the Properties for the EmEditor 

shortcut that you usually use to run EmEditor, and add /cd in 

the Target text box. For instance, if the install folder of 

EmEditor is "C:\Program Files\EmEditor", enter "C:\Program 

Files\EmEditor\emeditor.exe" /cd. Moreover, fill the Start in 

text box as a folder you want to open from. 

Q. How can I save an empty file? 

Choose Properties for Current Configuration under the 

Tools menu. Choose the File tab, then click the  Saving… 

button and uncheck the Delete Empty Files when Saving 

box. 

Q. Printing font size is too small. 

Choose Properties for Current Configuration under the 

Tools menu and click the Font button in the Print tab to customize font and size. 

Q. When reading Macintosh text files, some characters are converted to different 

characters. How can I read Macintosh text files correctly? 

Macintosh uses slightly different code pages than Windows does. In Windows 2000/XP/2003/Vista/7, where 

Macintosh code pages are installed, you can convert Macintosh text files into Windows text files. First, select 
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the Define Encodings command under the Tools menu. In the Define Encodings dialog box, press the New 

button, and select a Macintosh encoding, for example, "10001 (MAC - Japanese)". Select an appropriate 

character set, for example, Japanese. Click OK twice to close dialogs. Next, select the Open command under 

the File menu, select your defined encoding, for example, "10001 (MAC - Japanese)" from the Code Page 

combo box, and then select a Macintosh file that you would like to read. In Windows 98/Me, where Macintosh 

code pages are not installed, you cannot read Macintosh text files correctly if they contain special characters 

that cannot be read by Windows code pages.  

 

Q. When I write a Java class with EmEditor and compile it I get an error that states that 

there are three invalid characters at the beginning of my class. This happens every 

time and I do not have any characters before the class keyword, which is where the 

error says they are. 

The three characters at the top of your file are the "Byte Order Mark" of a UTF-8 file. By default, a Java file is 

created as UTF-8 with BOM. You can change the default code page for new files from Java Properties > File 

tab > New Files button, and change the code page to Normal ANSI, or uncheck the Add a Unicode Signature 

(BOM) box.  

Q. When using a shared folder on a network, is it possible to prevent other users from 

making changes to a file that I have open and I am working on? 

Yes, it is possible. In the File tab of Properties, select Keep Locked from the Changed by Another 

Program combo box. Other users will still be able to open the file but they will not be able to save changes to 

the file until you have closed the file.  

Q. How do I print my document in color or in black 

and white? 

To print in black and white, click Properties for Current 

Configuration under the Tools menu, click the Print tab, and 

then select the Ignore Color and Underlines check box. To 

print in color, clear the check box. 

Q. What can I do to speed up opening a very large 

file? 

Some configurations could slow down performance. Check 

the following points: 

 Click Properties for Current Configuration under the Tools menu, and then click the General tab. If an 

item other than "No Wrap" is selected in the Wrap by list, it might slow down EmEditor since it needs to 



FAQ - File  79 

 

 

compute where to wrap lines. When you open a large file, select "No Wrap", or select the No Wrap 

command. 

Q. How can I paste a Japanese (or Korean, Chinese, etc.) Word document into 

EmEditor and save as a text file? 

If Windows does not display Japanese, Korean, or Chinese fonts properly, you will need to go to Control 

Panel, select Regional and Language Options, click the Languages tab, and then check Install files for 

East Asian languages. 

Open your Word document, select the text you want to copy, and then press CTRL + C to copy the text to 

the Clipboard. 

Launch a new EmEditor window and press CTRL + V to paste the Clipboard contents to the EmEditor 

window. You should see the text in Japanese (or Korean, Chinese, etc.). If you cannot see the text properly, 

select Japanese (or Korean, Chinese, etc.) from the Font Category sub menu under the View menu. If you 

still cannot see it properly, select the Font command under the View menu, and select an appropriate font, for 

instance, MS Gothic if it is Japanese. 

To save the document, select the Save As command under the File menu, and make sure you select either 

Unicode or UTF-8 from the Encoding drop-down list box. You may also select a locale-specific encoding such 

as Japanese (Shift-JIS) if you wish. 

Q. How can I open an XML file as Western European, not as UTF-8? 

If an XML file is opened as Unicode, display the Current Configuration Properties, select the File tab, and 

check Opening Encoding drop-down list box. If this is Unicode, select System Default. If Detect HTML/XML 

Charset check box is checked, an "encoding=" directive specified within an XML file is searched, and 

EmEditor uses the specified encoding if the directive is found. Note that the encoding specified for opening 

files is different from the encoding specified for new files or for saving files. 

Q. How can I start a new Java file or XML file as Western European, not as UTF-8? 

By default, Java files and XML files will start as UTF-8 when the New with Java or XML command is 

selected. You can change this default behavior by opening the Configuration Properties  for Java (or XML), 

selecting the File tab, clicking the New Files button, and then selecting System Encoding from the Encoding 

drop-down list box. Note that the encoding specified for new files is different from the encoding specified for 

opening files or for saving files. 

Q. EmEditor is specified as an external text editor from another application. Why 

doesn't the change made by EmEditor reflect the application? 

If EmEditor is specified as an external text editor from another application such as a mail client program, and 

if the application monitors the EmEditor process for its termination and the file change, the application might 

not reflect an edited and saved file with EmEditor. To work around this, specify the /sp option to instruct 

EmEditor to be launched as a separate process. In this case, however, each EmEditor window will be 

displayed as a separate group. 
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Q. Can I open GB18030 files? 

Yes. First, go to Define Encodings in the Tools menu, click New and select GB18030 in the Encoding 

drop-down list. When you open a file, make sure you select this new defined encoding. 

Q. How can I convert file encodings by the command line?  

Use the following command line options: 

 

cp Encoding --- sets an encoding to open as. 

cps Encoding --- sets an encoding to save as. 

sa "DestFile" --- specifies a file name to save as after the encoding conversion 

ss+ --- saves the file with a Unicode signature (BOM) after the encoding conversion. 

ss- --- saves the file without a Unicode signature (BOM) after the encoding conversion. 

 

For instance, if you want to convert a file from Western European (iso-8859-1) to UTF-8, use the following 

syntax: 

 

"windows1252.txt" cp 1252 cps 65001 ss- sa "utf8.txt" 

 

See Encoding Constants for the list of encodings. 

 

See Using Command Line Options for more information. 

Q. How can I open a file with a certain file extension by double clicking in Explorer? 

Select the Customize command under the Tools menu. Select the File tab. Click the Associate with 

EmEditor button, and you can enter the file extension to be associated with EmEditor. 

Q.  How can I open a file exclusively? 

Select Properties for All Configurations in the Tools menu (or after you open the file, select Properties 

for Current Configuration in the Tools menu). Select the File tab, and select Keep Locked in the Changed 

by Another Program drop-down list box. 
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Edit 

Q. How can I select text with the keyboard? 

Press F8 to toggle normal selection mode. Press CTRL + F8 to select whole lines, and SHIFT + CTRL + F8 

to toggle vertical selection mode. To change the keyboard settings, select Properties for Current 

Configuration under the Tools menu, and display the Keyboard tab. 

Q. Can I insert control characters such as form feeds? 

To insert control characters on EmEditor, select Advanced > Insert Special Characters under the Edit 

menu. Alternatively, you can type corresponding keys with CTRL (+ SHIFT) only if the corresponding keys 

have not been assigned for shortcut keys and if the Allow Insert Control Characters is checked in the 

General tab of Properties. 

Q. I cannot paste text correctly when the content in the Clipboard has been copied 

from another application such as Netscape Navigator. 

Some other applications, particularly Netscape Navigator, have problems translating text from ANSI to 

Unicode. Instead of using the regular Paste command, select All Commands under the Tools menu, then 

Edit > Paste > ANSI Paste. Alternatively, check Always Paste as ANSI in the General tab of the Current 

Configuration Properties dialog box. 

Q. How do I insert special characters? 

Select Advanced under the Edit menu, and then select Insert Special Character. To inspect a Unicode 

character code you want to insert, refer to the Latin Extended Characters Reference. You can also inspect a 

character by using the Character Map ( Start menu > All Programs > Accessories > System Tools > Character 

Map) if installed in your Windows Operating System. You might need to adjust the font to display special 

characters properly. 

Q. How can I select a column block of text (vertical selection)? 

To select in a box (select vertically), use the mouse to select while pressing the ALT key, or press SHIFT + 

CTRL + F8 to toggle Vertical Selection Mode. 

Q. Where can I download Microsoft Global IME? 

Global IME is not necessary because other language IMEs can be added from the Control Panel (Start 

menu > Settings > Control Panel > Date, Time, Language and Regional Options). 
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Q. How can I undo inserted strings character by character using the Undo command? 

By default, an entire inserted string will be undone by one Undo command. You can change this behavior by 

checking the Undo Character by Character check box in the Advanced tab of the Customize dialog box. 

You will then need to restart EmEditor. 

Q. How can I sort lines in alphabetical or numerical order? 

You can select the Sort A to Z, Sort Z to A, Sort Smallest to Largest, or Sort Largest to Smallest 

command to sort in alphabetical or numerical order. These are found on the toolbar.  

Q. How can I assign a shortcut key to insert a special character? 

Many shortcut keys are already assigned to insert many special characters by default. To see which keys 

are assigned, go to: Insert Special Characters. Any character can be assigned to your favorite shortcut key 

using a macro. For example, if you would like to insert ä with a shortcut key, write a macro (in this case, 

JavaScript):  

 

document.selection.Text="ä"; 

 

and save this file as a file, for example, InsertA.jsee. Select Select... in Macros, and select this file. Running 

this macro will insert this character. To assign a shortcut key to this macro, go to Configuration Properties, 

select the Keyboard tab, and then select My Macros from the Category drop-down list, and assign your favorite 

key to the macro. 

 

Search 

Q. How can I erase all the previous words in the Find box? 

Click Clear History in the bottom of the Customize dialog box, by choosing Customize under the Tools 

menu. 

Q. In the Find in Files dialog box, can I search for a string in Japanese JIS or EUC 

files? 

You can select Japanese JIS or Japanese EUC in the Encoding drop-down list box in the Find in Files 

dialog box. 

Q. Can I use regular expressions to search or replace? 

Yes. Regular Expressions are supported. 
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Q. How can I search for a word at the beginning of lines or a word at the end of lines? 

The beginning of a line can be represented as "^" and the end of lines can be represented as "$" if you 

check Use Regular Expression in the Find dialog box. Enter "^Search String" in Find field if you want to find 

"Search String" at the beginning of lines, or "Search String$" if you want to find "Search String" at the end of 

lines. 

A new line can be also represented as "\n" if you check Use Escape Sequence. Enter "\nSearch String" in 

Find field if you want to find "Search String" at the beginning of lines, or "Search String\n" if you want to find 

"Search String" at the end of lines. 

Q. What are examples of regular expressions? 

  strings surrounded by double-quotation marks 

".*?" 

 strings surrounded by [ ] 

\[[^\[]*?\] 

 variable names 

[a-zA-Z_][a-zA-Z_0-9]* 

 IP addresses 

([0-9]{1,3})\.([0-9]{1,3})\.([0-9]{1,3})\.([0-9]{1,3}) 

 URL 

(\S+)://([^:/]+)(:(\d+))?(/[^#\s]*)(#(\S+))? 

 lines followed by a tab 

\t.*$ 

 Hiragana 

[\x{3041}-\x{309e}] 

 Full-width Katakana 

[\x{309b}-\x{309c}\x{30a1}-\x{30fe}] 

 Half-width Kana 

[\x{ff61}-\x{ff9f}] 

 CJK ideographs 

[\x{3400}-\x{9fff}\x{f900}-\x{fa2d}] 

 CJK ideograph marks 

[\x{3000}-\x{3037}] 

 Hangul 

[\x{1100}-\x{11f9}\x{3131}-\x{318e}\x{ac00}-\x{d7a3}] 

 Insert // at start of lines 

Find: ^ 

Replace with: // 
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 Remove // at end of lines 

Find: ^// 

Replace: 

 Remove trailing whitespaces 

Find: \s+?$ 

Replace with: 

 Replace (abc) with [abc] 

Find: \((.*?)\) 

Replace: \[\1\] 

 Replace <H3 ...> with <H4 ...> 

Find: <H3(.*?)> 

Replace: <H4\1> 

 Replace 9/13/2003 with 2003.9.13 

Find: ([0-9]{1,2})/([0-9]{1,2})/([0-9]{2,4}) 

Replace: \3\.\1\.\2\. 

 Uppercase characters from a to z 

Find: [a-z] 

Replace: \U\0 

 Capitalize all words 

Find: ([a-zA-Z])([a-zA-Z]*) 

Replace: \U\1\L\2 

Q. Why doesn't EmEditor highlight strings including new lines? 

EmEditor has been designed to highlight strings line by line, rather than highlight strings containing new 

lines, in order to increase the performance of the program. 

 

Q. Why is the Find/Replace dialog box so big? 

The Find/Replace dialog box allows resizing by dragging the right bottom corner with the mouse. When the 

height of the dialog box is minimum, only a single line can be entered as a search string, while the taller dialog 

box allows multiple lines entered as a search string. 

 

Q. How can I enter a multiple-line string as a search string in the Find/Replace dialog 

box? 

In order to enter multiple-line string as a search string in the Find/Replace dialog box, drag the right bottom 

corner of the dialog box so the text box allows multiple lines. In order to enter a New Line, use CTRL + Enter.
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View 

Q. The cursor shape used to look like an 'I' but now it looks like a solid rectangle. 

When I type a letter, it is not inserted but overwrites an existing character. What 

happened? 

"Overwrite" mode is turned on. Press the Insert key on your keyboard to toggle "Overwrite" mode. 

Q. Can I display single-byte spaces as any marks? 

Yes. In the Marks tab of Properties, check the Show Spaces check box.  

Q. When I open a file using the default settings, it becomes unreadable, and if I choose 

another character set from the Font Category sub menu under the View menu, it 

becomes worse. But if I select a proper encoding when I open the file, it works. Why? 

EmEditor's internal processing is Unicode. EmEditor converts ANSI text to Unicode text when you open an 

ANSI file. When opening a file, you should select an encoding in the Open dialog box. If you don't select an 

encoding, EmEditor defaults the file to the system default encoding. In order to open a file with a different 

encoding, you need to select the desired encoding when you open the file. You can later change the encoding 

by choosing the Reload command under the File menu and selecting a different encoding option. 

Q. When do I use Font Category under the View menu? 

EmEditor cannot detect a language from Unicode files. You will have to manually choose a Font Category 

under the View menu to display a non-default character set in a Unicode file correctly. When creating a new 

file with a language other than default character set, you also need to select the Font Category you want to 

use. 

Q. How can I display continuous line numbers from page to page? I never had this 

problem, but now something changed in my configuration. 

In the General tab in the Current Configuration Properties dialog box, uncheck the Display Page 

Number check box. 

Q. What are logical coordinates and display coordinates? What is a logical line? 

Logical coordinates refer to the coordinates in a document regardless of the wrap mode in use. Returns due 

to the wrapping of lines are not counted. Logical lines refers to the number of lines, discounting lines formed by 

wrapping, in a document. Display coordinates, on the other hand, include wrapped lines in their sum. 
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Q. I display line numbers on the left edge of 

EmEditor window. When a line is wrapped, I 

do not want to see the line number 

incremented within the logical line. How do 

I configure this behavior? 

In the General tab in the Current Configuration 

Properties dialog box, select one of the logical 

coordinates options from the Line and Column 

Display as combo box. 

Q. I don't like the cartoony style toolbars. 

Can I use the old toolbar buttons? 

Yes. Select Customize Toolbar from the Tools 

menu, and select 16 color. 

Q. Can I change the Tray Icon on the Task bar to my favorite icon? 

Yes. Run Registry Editor (RegEdit.exe), and find HKEY_CURRENT_USER\Software\EmSoft\EmEditor 

v3\Common. Create a TrayIconFile value as REG_SZ and set the icon file path, and TrayIconIndex value as 

REG_DWORD and set the icon index. 

Q. How can I highlight previously searched strings more than once with different 

colors? 

In the Display tab in the Current Configuration Properties dialog box, enter how many times you want to 

highlight in the Search Colors edit box. To highlight with different colors, scroll down to the bottom of the 

Specify Part list box, select Search string (1), (2), ..., and click on Background Color or Text Color to select 

new colors to display searched strings. 

Q. How can I display an underline at the cursor position? 

In the Scroll tab in the Current Configuration Properties dialog box, check Horizontal Line. 

Q. How can I display URLs without breaking at specific characters (such as , 

(comma))? 

In the Link tab in the Current Configuration Properties dialog box, add characters you don't want to break 

URLs (such as , (comma)) to Recognize These Characters. 
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Q. The cursor vertical line is thin. Can it be thicker?  

In Windows Vista and 7, select Optimize Visual Display in the Control Panel, and select a greater number 

in the Set the Thickness of the blinking cursor drop-down list. 

 

In Windows XP, select Accessibility Options in Control Panel, select the Display tab, and adjust the 

Width under the Cursor Options. 

Q. How can I find the number of the words in the selection? 

You can use the WordCount plug-in, which is included in EmEditor Professional install. See also Use the 

Word Count Plug-in in this manual. 

Q. How can I decode Numeric Character References ("&#xxx") in Unicode characters? 

You can use the DecodeUnicode plug-in, which you can download from the EmEditor plug-in list. 

 

Q. How can I find the return type (e.g. CR, LF, CR+LF) for each line? 

If you set the Character Code at Cursor checkbox in the Status tab of the Customize dialog box, and 

when the cursor is at end of any line, you will see 0D+0A (CR+LF) or 0D (CR only) or 0A (LF only). You can 

also check the Show CR and LF with Different Marks in the Marks tab of Properties to distinguish the return 

types. Since each line can have different return types in EmEditor, this is how EmEditor displays the return 

types for each line. 

Q. How can I add the Marks button to the Toolbar? 

Double click on the toolbar (the basic one) border, and the Customize Toolbar dialog will appear, where 

you can select the Marks button and add it to the toolbar. Alternatively, you can select Customize Toolbar in 

the Tools menu, and then double-click the Toolbar 1 in the Toolbars list, where you can select the Marks 

button and add it to the toolbar. 

Q. How can I display line numbers? 

 Select Properties for Current Configuration in the Tools menu, click the General tab, and check 

Show Line Numbers. 

Customize 

Q. How can my favorite mail software run when clicking mail addresses? 

The e-mail program you want to use needs to be the default e-mail software. You can find an option to set 

the default e-mail software under Settings > Control Panel > Internet Options > Programs. If not found, in 

Explorer, select Options under the View menu, and select the File Types tab. Select URL:MailTo Protocol, 
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double-click open, and enter the mail software path and options on Application used to perform action. 

Refer to the e-mail program help because the options depend on each mail software. Some e-mail programs 

do not support this function. 

Q. Clicking URLs will not run my favorite web browser. 

After installing a second browser, you will be given the option to set the second browser as the default 

browser. Clicking a URL in EmEditor will start the second web browser at this point. 

Q. How can I make the year 4 digits when you insert dates? 

Customize the date format in the Locale, Control Panel. This specification is the same as Notepad. 

Q. How can I open the Input Method Editor (IME) automatically when running 

EmEditor? 

To open the IME automatically when running EmEditor, choose Properties for Current Configuration 

under the Tools menu and check the Run Input Method Editor check box in the General tab. 

Q. How can I copy configuration properties on one machine to another? 

You can copy them if you write the HKEY_CURRENT_USER\Software\EmSoft\EmEditor v3 key to a file by 

Registry Editor (Regedit.exe), copy the file to the other machine, and read the file by Registry Editor. You 

might need to change the folder names in the Properties by yourself. 

Q. Why is there no ASP configuration? 

The ASP syntax is included in the HTML configuration, and the embedded script (usually written in VBScript 

or JavaScript) will be highlighted according to the VBScript or JavaScript configuration. 

Q. What is "HTML" and "HTML-Embedded" in Special Syntax combo box in the 

Highlight (2) tab of Properties? 

HTML is used when HTML tags specifying the script language (<SCRIPT type=...>) exist in the HTML 

document. HTML is also appropriate for ASP files that include scripts beginning with the % mark. This is 

usually the case for VBScript, Javascript, PerlScript, CSS, etc. HTML-Embedded is appropriate when working 

with script languages such as PHP or JSP and the characters that normally mark the beginning of scripts in 

such languages, which are specified in the Script Begin box. 

Q. Can EmEditor encode Unicode characters as "Numerical Character References" 

(NCRs - those &#xxx; codes) when saving HTML or XML files? 

Yes. In the File tab in Properties, click the Saving button, and check Save Unicode as HTML/XML 

Character Reference. You can also click Use Named Entity Reference if you would like to save named 

entity references such as ©. For HTML and XML configurations, these checkboxes are checked by default. 
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However, EmEditor currently cannot decode or display 

NCRs as real Unicode characters when loading HTML 

or XML files. 

Q. There is no encoding available in the 

Reload sub menu under the File menu except 

Same Encoding, Detect All, System Default, 

UTF-16LE, UTF-16BE, UTF-8, and UTF-7. How 

can I add more code pages? 

If you do not install EmEditor properly, but just copy 

emeditor.exe from another PC and run it, some system 

encodings will not be available in your copy of EmEditor. 

To setup additional system encodings, log on with 

Power User or Administrator privileges if you use 

Windows NT/2000/XP, and select the Define Encoding command from the Tools menu, and click the Reset 

button. 

Encoding availability depends on which language system files you install in your copy of Windows. If you 

cannot find a particular encoding from within EmEditor, you can install additional language files from the 

Control Panel - Regional and Language Options. After language system files are installed in your copy of 

Windows, select the Define Encoding command from the Tools menu, and click the Reset button. 

Q. After updating EmEditor to the newest version, how can I add the new commands to 

a menu or add the new keyboard shortcuts? 

If the new commands do not show up in a menu, select Customize Menus under the Tools menu, and click 

on the Reset button to reset the menus to their defaults. To add new command shortcuts, click on the Reset 

button in the Keyboard tab of Properties for All Configurations. 

Q. How can I define two-keystroke keyboard shortcuts? 

You can define two-keystroke keyboard shortcuts by using a combination of the user menu features and the 

keyboard mapping features. By default, CTRL+K is predefined for the first key of two-keystroke shortcuts using 

User Menu (1). 

 

Some of the predefined shortcuts include: 

 

CTRL+K, K Toggle Bookmark 

CTRL+K, N Next Bookmark in this Document 

CTRL+K, P Previous Bookmark in this Document 

CTRL+K, L Clear All Bookmarks in this Document 

CTRL+K, C Comment Selection 

CTRL+K, U Uncomment Selection 
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 In this list, the second key can be activated with or without CTRL key. For instance, the Toggle Bookmark 

command can be activated by pressing K with CTRL, and then K again with or without CTRL. 

 

To add new two-keystroke shortcuts: 

 

1. In the Help menu select Keyboard Map. 

2. Click to select the All Configurations button on the Toolbar, if you want all of the configurations to use 

the same shortcuts (or deselect it to not use the same shortcuts). 

3. Scroll down the list to User Menu (2) and double-click. 

4. In the Configuration Properties, type a shortcut in the text box, Press a New Shortcut Key. For 

instance, CTRL+;. 

5. Click the Assign button, and click OK. 

6. Close the Keyboard Map window. 

7. Next, in the Tools menu select Customize Menus. 

8. Select User Menu (2) in the Menu to Customize list. 

9. Click the Insert Right button. 

10. In the Menu Properties, select a new command to assign a shortcut to. 

11. In the Name text box, use & to specify a new shortcut key. 

12. The character to the right of & specifies the second character. 

 

For instance, if you want to add New and Paste command and set "N" as the second shortcut key: 

 

1. Select File in the Category list. 

2. Select New and Paste in the Command list. 

3. Type &New and Paste in the Name text box. 

4. Click OK. 

 

Repeat this procedure to define as many commands as you prefer. 

 

By default, the user menu will appear 1 second after the first key is pressed. Second shortcut keys work 

before the user menu appears. You can change the delay time for each user menu by adjusting the Delay 

Time slider on the bottom of the Customize Menus dialog box. 

Macro 

Q. Can I use the VBScript MsgBox function? 

No. However, you can use the Popup method of the WshShell. You can also use the alert method or 

confirm method instead. 
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Plug-ins 

Q. How can I enable the Outline Guide (Code Folding) while hiding the Outline Custom 

Bar? 

In the Outline properties, clear the Turn off Outline Guide when Custom Bar is not displayed checkbox. 

Q. Why do I need to click the FindBar plug-in button twice in order to close the 

FindBar? 

When the FindBar is displayed, if you are in the Editor view, clicking the FindBar button in the Plug-ins 

toolbar changes the keyboard focus to the FindBar. Once the focus is on the FindBar, clicking the FindBar 

button in the Plug-ins toolbar again closes the FindBar. Thus, in order to close the FindBar when the focus is in 

the Editor view, you will need to click the FindBar button twice. 

The above behavior allows you to move the focus to the FindBar drop-down list by assigning a keyboard 

shortcut to this plug-in command. In order to allow this focus movement by a shortcut key, the above behavior 

is specification. 

Tools 

Q. How can I run an external compiler from EmEditor to compile the current file? 

See What are examples of External Tools configuration?, Compile by Visual C++ section. 

Q. Can I save multiple macros to files? 

Yes. You can save multiple macros to files by using the Save Macro command. 

Q. How can I do a Google search for the word at the current cursor position? 

Select the Customize Tools command, select the New button and enter 

"http://google.com/search?q=$(CurText)" in the Command text box. 

Q. I want to compile the opened file with an external tool in Command Prompt, but how 

can I keep the Command Prompt window from closing after the compilation is 

finished? 

Select the Customize Tools command, and select the New button and enter "cmd.exe" in the Command 

text box, and "/k "filename" $(Path)" in the Arguments text box. 
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Q. What are examples of External Tools configuration? 

 

Open Internet Explorer 

Command: C:\Program Files\Internet Explorer\iexplore.exe 

Arguments: $(Path) 

Initial Directory: $(Dir) 

Icon Path: C:\Program Files\Internet Explorer\iexplore.exe 

Check Save File 

 

Open Explorer 

Command: %WinDir%\explorer.exe 

Arguments: $(Dir) 

Initial Directory: $(Dir) 

Icon Path: %WinDir%\explorer.exe 

 

Open Command Prompt 

Command: %WinDir%\system32\cmd.exe 

Arguments: $(Dir) 

Initial Directory: $(Dir) 

Icon Path: %WinDir%\system32\cmd.exe 

 

Compile by Visual C++ 

Command: %WinDir%\system32\cmd.exe 

Arguments: /k "C:\Program Files\Visual Studio\Vc7\bin\vcvars32.bat"&&cl $(Path) 

Initial Directory: $(Dir) 

Icon Path: C:\Program Files\Visual Studio\Common7\IDE\devenv.exe 

Check Save File 

 

Run associated program 

Command: $(Path) 

Arguments: 

Initial Directory: $(Dir) 

Icon Path: 

Check Save File  

 

Search Google for a word at cursor or a selected text 

Command: http://google.com/search?q=$(CurText) 

Arguments: 

Initial Directory: 

Icon Path:   
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Check out from Microsoft Visual SourceSafe 

Command: %WinDir%\system32\cmd.exe 

Arguments: /k C:\(SourceSafe path)\Common\VSS\win32\SS.EXE checkout $/(path)/$(Filename).$(Ext) -

y(user name) 

Initial Directory: $(Dir) 

Icon Path: C:\(SourceSafe path)\Common\VSS\win32\SSEXP.EXE 

 

Check in to Microsoft Visual SourceSafe 

Command: %WinDir%\system32\cmd.exe 

Arguments: /k C:\(SourceSafe path)\Common\VSS\win32\SS.EXE checkin $/(path)/$(Filename).$(Ext) -y(user 

name) 

Initial Directory: $(Dir) 

Icon Path: C:\(SourceSafe path)\Common\VSS\win32\SSEXP.EXE 

Check Save File 

 

You can use the following predefined arguments in Command, Arguments, Initial Directory, and Icon Path. 

$(Path) The full path name of the file 

$(Dir) The directory name of the file 

$(Filename) The file name without its extension 

$(Ext) The file name extension 

$(CurLine) The logical line number of the cursor 

$(CurText) The selected text if selected, or the word at the cursor if not selected 

You can also specify environment variables, such as %WinDir% 

Window 

Q. What is the split window for? 

Sometimes it is convenient when you are writing at the bottom of the text to view the top of the text at the 

same time. You cannot open a different file on each pane of the split window.  

Q. How can I save the EmEditor window size, and always open EmEditor windows at 

the same size? 

First resize the EmEditor window to the desired size, then select the Customize command from the Tools 

menu, select the Window tab, click the Save Current Window Position button, and then click OK. 

Q. How can I always open EmEditor windows at the maximized size? 

First maximize the EmEditor window, then select the Customize command from the Tools menu, select the 

Window tab, click the Save Current Window Position button, check the Restore Window Position check 

box, and then click OK. 
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Q. How can I save the current positions of all EmEditor windows, and open all the 

windows at the same positions next time? 

Left click the mouse button on the Tray Icon to display the Tray Icon menu, and select the Save 

Workspace command to save file names and cursor positions of the current workspace. Next time you can 

select the Restore Workspace command to restore the previously saved windows with the same file name 

and cursor positions. 

You can also use the Save Workspace and Close All command to close all windows after saving the 

workspace, or use the Save Workspace, Save, and Close All command to save and close all windows after 

saving the workspace. 

Q. How can EmEditor display as if it were a tabbed window? 

Select the Enable Tabs command so it is checked.  

Q. Why doesn't the Cascade or Tile command work? 

When the tab is enabled, selecting the Cascade command or one of the Tile commands does not disable 

the tab. These commands cascade or tile only when multiple groups exist. Therefore, these commands make 

no sense when only one group exists. This change has been made due to users' request. To cascade or tile as 

in the previous manner, disable the tab first, then select one of these commands. New Horizontal Group and 

New Vertical Group commands allow you to tile windows even if only one group exists. 

Q. How can I make the EmEditor window stay open when I close the last open 

document? 

Select the Customize in the Tools menu, select the Window tab, and check the Do Not Close Last 

Document by Selecting Close Command check box. 

Q. Is there a way to make EmEditor move through document tabs in sequential order 

from left to right? 

Yes. Select Customize in the Tools menu, then select the Window tab, and clear the Switch to Last Used 

Window for Next Window check box. When unchecked, you can switch between the tabbed documents in 

order from left to right, or right to left, using CTRL+TAB, or CTRL+SHIFT+TAB respectively. When checked, 

pressing CTRL+TAB and CTRL+SHIFT+TAB, switch back and forth between the active document and the 

last viewed document. 
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Troubleshooting 

Q. How can I create a Dr. Watson log? 

Note: The following article does not apply to Windows Vista or 7. Windows Vista/7 does not include Dr. 

Watson. 

 

To create a Dr. Watson log: 

 

1. If an application error (crash) occurs inside a plug-in, the following dialog box appears: 

"An application error has occurred in the plug-in..." 

Press Cancel. 

2.  If an application error occurs in the EmEditor core, the following dialog box appears: 

"An application error occurred in EmEditor. EmEditor will try to save current documents." 

Press Cancel. Then the following system dialog appears: 

EmEditor has encountered a problem and needs to close. We are sorry for the inconvenience. 

If you see "Debug" button in the dialog, please "Debug". If the "Debug" button is not available, 

press "Don't Send" button. The Dr. Watson log will be usually written into the following location: 

C:\Documents and Settings\All Users\Application Data\Microsoft\Dr Watson\drwtsn32.log 

 

3. If no log is written, open Registry Editor (regedit.exe), and check the following key: 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug 

There should be no problem if the value of "Debugger" is  

Debugger = drwtsn32 -p %ld -e %ld –g 

If the value of "Auto" is: 

Auto = 1 

the Debug button will not appear in the previous dialog box, and the log will be automatically 

captured. If this value is 0, the Debug button will appear, and the Debug button will need to be 

pressed before the log is captured. 

 

If you experience an application error in EmEditor, you might need to send the Dr. Watson log (compressed 

to a Zip archive) to tech@emurasoft.com as an attachment with the detail information including EmEditor 

edition and version number, OS version, and procedure to reproduce your issue.

Uninstall 

Q. I was using EmEditor on a trial basis and decided I don't want to purchase it. How 

do I uninstall EmEditor? 

Close all running EmEditor programs (Note that EmEditor Help will be closed as well. If you are reading this 

page from the Help, we recommend writing down the information on this page before closing). Click the Start 
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button on the Windows Operating System and select Control Panel from the Start menu. Select Add or 

Remove Programs. Select EmEditor from the Add or Remove Programs dialog box, and then click the 

Delete button. Follow the instructions in the EmEditor Uninstall dialog box. We recommend restarting the 

Windows Operating System when the uninstalling is complete. 

Q. I have uninstalled EmEditor. When I double click a file to open the file, my computer 

looks for EmEditor. Since EmEditor does not exist in my computer anymore, I can't 

open the file. How do I open such a file? 

If you associate files using Associate with EmEditor in EmEditor, the original associations are supposed to 

be restored after having uninstalled EmEditor. However, if you associate files yourself in other applications 

such as Explorer, you need to restore the original associations yourself. Open Windows Explorer, click Tools, 

select Folder Options, and then click the File Types tab. Select extensions you want to delete in the 

Registered file types list box and click the Change button. In the resulting Open With dialog box, select a 

program other than EmEditor that you want to associate the file with. 

Q. After I uninstalled EmEditor, why isn't the source code displayed in Notepad when I 

select View Source from the context menu in Internet Explorer? 

Some earlier versions of EmEditor were not able to completely uninstall the registry information. Click the 

Start button and select Run from the Start menu. Type "RegEdit.exe" and click the OK button to start Registry 

editor. Search for HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\View Source Editor and 

delete the key. 

Q. After I uninstalled EmEditor, emedtray.exe and emedres.dll were still in the folder 

C:\Program Files\EmEditor. How do I delete them? 

These files should be deleted during the uninstalling process. In your situation, the files were not deleted. To 

delete these files manually, first delete the shortcut running a Tray Icon of EmEditor. Then follow the 

instructions found in: 

Q. How can I remove the EmEditor tray icon permanently? 

If you find the EmEditor tray icon running on your Taskbar, close it by selecting Close Tray Icon. You can 

then delete emedtray.exe and emedres.dll. 
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Appendix 

Links 

Official EmEditor Website 

EmEditor Home 

http://www.emeditor.com/ 

Emurasoft Customer Center 

https://www.emurasoft.com/support/ 

Glossary 

 

All Commands 

All Commands is one of the commands of EmEditor. By default, it is found under the Tools Menu. See also 

All Commands command. 

ANSI 

see System Default Encoding. 

ASCII 

An acronym for American Standard Code for Information Interchange. ASCII is a character set and encoding 

based on the Roman alphabet as used in modern English and other Western European languages. 

Big endian 

Big-endian is a method of encoding where data is stored so that the most significant byte is placed first in a 

binary sequence. 

BOM 

see Byte Order Mark. 
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Bookmark 

A function in EmEditor that allows a user to bookmark a line of text.  A bookmark is represented by a small 

rectangle at the beginning of a line of text.  EmEditor allows a user to toggle between bookmarks using the F2 

key. 

Byte Order Mark (BOM) 

A Byte Order Mark (BOM) is the character at code point FEFF. It is used to denote how the data in a 

Unicode, Unicode big endian, or UTF-8 file is encoded. In Unicode (little endian), the first byte of the file is FF, 

and the second byte is FE. In Unicode big endian, the first byte of the file is FE, and the second byte is FF. In 

UTF-8, the first byte of the file is EF, the second byte is BB and the third byte is BF. 

Carriage Return 

An ASCII character which instructs the display peripheral (monitors, printers, etc.) to move the cursor to the 

beginning of the next line. 

Character Class 

see Character Set. 

Character Set 

A group of alphabetic, numeric, and other characters needed to display text in a specific language.  

Character String 

A series of characters enclosed in single or double quote marks which can be manipulated as a group. 

COM 

see Component Object Model. 

Command Line 

A specific string of code which instructs a program to function in a certain way. 

Component Object Model (COM) 

A Microsoft created technology that allows users to write an object in any language (such as VBScript or 

JavaScript) and allows that object to interact with applications of any language. 

CR 

see Carriage Return. 
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Dialog Box 

Any type of pop-up box or window displayed on the screen to either display information, or request user 

input. 

Display Coordinates 

Coordinates in which line numbers include actual new lines (either carriage returns (CR) or line feeds (LF)) and 

wrapped lines in their sums, as opposed to logical lines. 

DLL 

see Dynamic Link Library. 

Document Object Model (DOM) 

A DOM is used by Web browsers to indicate how objects, such as text and images, are represented on a 

Web page.  A DOM identifies an object’s attributes and defines how an object can be manipulated. 

DOM 

see Document Object Model. 

Dynamic Link Library (DLL) 

A library of executable functions or data that can be used by a Windows application. 

Encoding  

The process of converting information into data for further processing by an application and/or the operating 

system. The number of different methods of encoding available depends on the operating system in use. 

Escape Sequence 

A series of characters which triggers a command in a device or program. 

Event 

An action or occurrence detected by a program. Events can be user actions, such as clicking a mouse 

button or pressing a key. 

Extensible Markup Language (XML) 

A subset of Standard Generalized Markup Language (SGML).  XML has a non-fixed format allowing for 

more flexibility and adaptability with the Web. 
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Extension 

A file name suffix beginning with a period, indicating the type of the file. Traditionally 3 alphabet characters 

after a period are used. For instance, a text file usually has .txt extension, and an HTML file usually has .htm 

extension. 

Full Width 

Characters of East Asian character sets whose glyph image extends across the entire character display cell. 

In legacy character sets, full width characters are normally encoded in two or three bytes. 

Half Width 

Characters of East Asian character sets whose glyph image occupies half of the character display cell. In 

legacy character sets, half width characters are normally encoded in a single byte. 

Hexadecimal 

A base-16 alphanumerical system used in various programming languages, usually written using characters 

0-9 and A-F. Useful because each hexadecimal figure can represent every byte (8 bits) as two consecutive 

hexadecimal digits. Hexadecimal numbers have either an "0x" or "U+" prefix or an "h" suffix.  

HTML 

see Hypertext Markup Language. 

Hypertext Markup Language (HTML) 

The standard markup language for documents on the World Wide Web. HTML is a small subset of Standard 

Generalized Markup Language (SGML). 

IME 

see Input Method Editor. 

Input Method Editor (IME) 

A program that allows users to enter characters and symbols of other languages using a standard keyboard. 

JavaScript 

A scripting language that can enhance the look of a Web site. JavaScript scripts can run on any type of 

server. 

Kana 

One of the writing systems used in Japanese. Symbols represent syllables and are often used in conjunction 

with Japanese pictorial symbols (kanji) to change the form of words. 
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Katakana 

A syllabic form of writing in Japanese that is used to transliterate non-Japanese words. 

LF 

see Line Feed. 

Line Feed 

An ASCII character which instructs the display peripheral (monitors, printers, etc) to move the cursor one 

line down. When following a CR, a LF is used to indicate a new line. 

Literals 

A literal is a character that matches itself. All characters are literals except: ".", "*", "?", "+", "(", ")", "{", "}", "[", 

"]", "^", "$" and "\". These characters are literals when preceded by a "\". 

Little-endian 

Little-endian is a method of encoding where data is stored so that the least significant byte is placed first in a 

binary sequence. 

Logical Coordinates 

Logical coordinates refer to the coordinates in a document regardless of whether the wrap mode is in use. In 

logical coordinates, line numbers are sums of the actual number of new lines in a document, and a column is 

the number of characters from the previous new line character or from the start of the document if it's the first 

line of the document. 

Logical Line 

Logical lines are sums of the actual number of new lines in a document, regardless of line wrapping. 

Macro 

A user-programmed saved sequence of commands that, when used, expands usability by enabling multiple 

commands to be automated into one process. 

MDI 

see Multi Document Interface. 

Message 

An instruction to a program object to perform a certain task. 
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Metacharacters 

see Regular Expression. 

Multi Document Interface (MDI) 

An interface that enables users to easily create applications with multiple windows. An MDI uses one 

window to display multiple windows. 

Null Character 

A character with the code value 0. It is not usually used in text files, and thus files containing null characters 

are programs or data files other than text files. These binary files (programs and data files except text files) 

cannot be edited by EmEditor. Another program, such as a binary editor, must be used to edit binary files if 

you need to edit them. 

Object Linking & Embedding (OLE) 

A program-integration technology for transferring and sharing information between programs. 

Overwrite Mode 

A typing mode in which the characters typed will write over any other characters already on the line. 

Plug-in 

A plug-in (or plugin) is a program that can interact with another program to provide a certain, usually very 

specific, function. 

Registry 

A database used to store preferences, settings and options for the operating system. 

Regular Expression 

A regular expression is a pattern of text that consists of ordinary characters, or literals, (for example letters 

a-z) and special characters, known as metacharacters. 

Separator 

A function in EmEditor that allows a user to create a separation between commands within a menu.  

String 

see Character String. 
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Syntax File 

A file that outlines which words or phrases a program recognizes as functionally important, and how to 

interpret them. In EmEditor, a syntax file (denoted by an .esy extension) is used to define which strings are 

highlighted and how a file of a certain file type is displayed in EmEditor. 

System Default Encoding 

A system encoding for non-Unicode programs used on the Windows Operating Systems. You can change 

the System Default Encoding by selecting the Control Panel, selecting Regional and Language Options, 

selecting the Advanced tab, and then selecting the Language for non-Unicode programs if you are using 

Windows 2000/XP/2003/Vista. The English Windows Operating System usually selects Western European by 

default. This is also called ANSI. 

System Registry 

see Registry. 

System Tray 

The small indented box on the far right side of the Windows Taskbar, which displays the time, date, and may 

or may not display programs which are currently running. Usually reserved for system operations. 

Toggle 

Switching back and forth between two computer operations using the same key or command. 

Tray Icon 

A small icon, which appears in the System Tray in Windows operating systems, which allows the user to 

access a program easily and quickly. 

Unicode 

An international standardized character set currently containing 34,168 distinct coded characters derived 

from 24 supported language scripts. In EmEditor, Unicode Little endian is default. See also Big endian and 

Little endian. 

Uniform Resource Locator (URL) 

A unique address that identifies the location of a page, file, or other type of resource on the Internet. 

URL 

see Uniform Resource Locator 
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UTF-7 

UTF-7 (7-bit Unicode Transformation Format) is a variable-length character encoding that is used to 

represent Unicode-encoded text using a stream of ASCII character for use in MIME messages. 

UTF-8 

UTF-8 (8-bit Unicode Transformation Format) is a lossless, variable-length character encoding, which uses 

groups of bytes to represent the Unicode standard for the alphabets of many of the world's languages. 

VBScript 

Visual Basic Scripting (VBScript) is a scripting language that can add functionality to, or enhance the look of, 

a Web site. VBScript is a subset of the Microsoft Visual Basic programming language. 

Web Browser 

A program, such as Mozilla Firefox, Google Chrome, Safari, Netscape Navigator, or Internet Explorer, which 

is used to view documents on the World Wide Web. 

Whitespace Character 

A character which doesn't visibly show on the screen, such as a space or a tab. 

Windows Scripting Host (WSH) 

Windows Scripting Host (WSH) is a language-independent scripting host for Windows Script compatible 

scripting engines, which allows the user to run scripts from both the Windows desktop and the command 

prompt. 

Wrap 

A feature that causes a program to force all text to fit within the defined margins. See also Wrap Point. 

Wrap Point 

The point at which text is forced to the next line due to the locations of the margins or page edges. 

WSH 

see Windows Scripting Host. 

XML 

See Extensible Markup Language. 
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XML Parser 

A tool used to convert XML information into a set of structures that an application can use. 


