Please test and fix this issue (3) first:

Default settings.
Enable “Save Cursor Position”.
Open file A, which is never opened in EmEditor.
Change cursor position.
Close A.
Reopen A.
** It doesn’t save the cursor position, till “Save Bookmarks” is once enabled.
** This issue will happen on another never-opened file after “Save Bookmarks” is disabled.

I will test issue 2 if issue 3 is fixed.