After resetting the highlight configuration the wordcomplete seems to be working properly, thanks!

I did notice a couple of spelling/typo errors on the Options tab for WordComplete configuration:

Display Icons in the Cadidate List
Automatically Hide the List when No Candiate is Matched

Keep up the great work!