I hope this issue was fixed on beta 5. If not, please let me know. Thanks!

Yes, in beta 5 both issues are fixed.

If you disable the multi-selection, you can still use the CTRL to select a word.

I don’t think it’s a good idea that each time when I need to select a couple of words I should open the configuration dialog, untick the checkbox, then select the phrase, then open the dialog again to tick the checkbox back. It’s definitely easier to manually aim at the word boundaries, just like in lousy editors which do not have this feature at all. It’s a pity that I can have either multi-selection, or word-selection, but not both of them… :-(

Maybe you could add a new command, so that it was at least possible to assign a hotkey and quickly switch between these two modes instead of going to the dialog each time?