BUG: Clearing History toggles several Find toolbar buttons OFF. For example, enable the following Find toolbar buttons: Incremental Search, Search All Open Documents, Match Case, Use Regular Expressions, Use Escape Sequence, Match Whole Word, (and In the Selection only if Search All Open Documents is not enabled) then go to Tools > Customise > History and click on Clear History. Exit EmEditor and re-start it – All the toolbar buttons you enabled have been disabled.

One other suggestion – can you allow Find history to be cleared by right-clicking over Find edit box and selecting a new context menu item “Clear Find history”.