FAQ

Install

Can you tell me how to install the new version of EmEditor?

You can install the new version of EmEditor by downloading the latest version from the EmEditor Home page. The steps are as follows:

1. If the tray icon is running, close it. To close the tray icon, right click on the tray icon on the task bar, and select Close Tray Icon.

2. Uninstall the previous version of EmEditor from Control Panel.

3. If the message box “Do you want to keep EmEditor settings before they are completely uninstalled?” appears, select “Yes” if you need to keep all your previous settings. It is recommended to select “No” unless you need to keep all your previous settings.

4. Select the type of EmEditor and the version of OS that you want by clicking one of the following links:

EmEditor Download

5. When you click the link for download, the File Download – Security Warning dialog box appears:

6. Clicking the Run button should start the downloading, and the Internet Explorer – Security Warning dialog box appears:

7. Click Publisher: Emurasoft, Inc.

8. Make sure you read This digital signature is OK in the Digital Signature Details dialog. If this phrase does not appear in the dialog box, the downloaded file is corrupted, and you will need to clear the Temporary Internet files, and try downloading again. Click OK to close the dialog box.

9. Clicking the Run button will launch the Setup. Follow the instructions that appear on the screen to proceed with the setup.

I am using a previous version of EmEditor. Can I install a newer version of EmEditor without uninstalling the previous version?

If you have been using a version of EmEditor v3.00 or newer, and want to maintain the same configurations, you do not need to uninstall the previous version. You can install the newest version with the same destination folder. However, before you install the newer version, you should exit all EmEditor windows including the Tray Icon. If you are asked to restart Windows during the installation, you should restart Windows.

If you have been using a version of EmEditor older than v3.00, or don’t want to maintain the same configurations of EmEditor, we recommend uninstalling the previous version completely and rebooting the computer before installing the newer version of EmEditor. The steps are as follows:

1. Click the Start button and select Control Panel from the Start menu. Select the EmEditor (or EmEditor v3) from the Add or Remove Programs. Click the Delete button.

2. Reboot Windows when uninstalling is complete.

3. Install the new version.

Can both the old version of EmEditor and new version of EmEditor coexist on the same computer?

No. The old version of EmEditor and new version of EmEditor can’t coexist on the same computer.

What do I do if EmEditor crashes when starting or editing?

1. If you have plug-ins installed, remove all plug-ins from the plug-ins folder, and try running EmEditor again.

2. If the problem persists, select Add/Remove Programs in Control Panel to uninstall EmEditor. Reboot your PC, and reinstall EmEditor.

3. If EmEditor crashes only when opening UTF-8 or Unicode files, select Font under the View menu, select Normal from the Character set list, select the Change button beside the Display Font box and check if the proper font is selected.

How can I remove the EmEditor Tray Icon permanently?

Run the EmEditor installation again and make sure the Add the tray icon on the task bar check box is unchecked during the setup. This way you will not see the Tray Icon any more. You do not need to uninstall EmEditor before running the installation again. If this does not work, select Search from the Windows Start menu, and search for “emeditor.lnk”. This file should be located in the Startup folder. Delete this file to remove the tray icon permanently.

How can I install EmEditor without displaying dialog boxes?

During normal installation, dialog boxes will be displayed, and a user must click the “Next” button or set options. However, when you install EmEditor into multiple computers in corporate or group environments, you might want to use a batch or scripting file to automate the installation. EmEditor uses Windows Installer for installation, and the “quiet” installation is possible.

For instance, if the EmEditor installation file is emed32_13.0.0.exe, running the following command:

emed32_13.0.0 /exenoui /q

will install EmEditor with default settings without displaying any dialog boxes.
If you wish to change the default settings, you can use following options:

NOCHECKUPDATES disables checking new versions of EmEditor periodically via the Internet.
NOCONTEXTMENU disables adding a shortcut to the Context Menu on Explorer.
NODESKTOP disables adding a shortcut to the Desktop.
NOIEEDITOR disables adding EmEditor to Internet Explorer HTML editor list.
NOIEVIEW disables View Source by EmEditor on Internet Explorer.
NOPATH disables adding the path to EmEditor to the PATH environment variable.
NOSHORTCUT disables adding a shortcut to the Program menu.
NOTRAYICON disables the tray icon.
NOTXT disables the association of text files.
REGNAME=name enters the name of licensee.
REGKEY=xxxxxx enters a registration key.

For instance, if you wish to install EmEditor specifying a registration key and the name of licensee, run:

emed32_13.0.0 /exenoui /q REGKEY=xxxxx REGNAME=name

emed32_13.0.0 /exenoui /q NODESKTOP=1

There are many options for Windows Installer. For details, run:

msiexec /?

to display the list of available commands.

Notes:
On Windows Vista or later, the installer must be run on Administrator privilege to avoid the User Account Control prompt. For instance, If you run the installer from Command Prompt, you will have to open the Command Prompt window by right-clicking the Command Prompt icon while pressing the SHIFT key, and then select Run as administrator.

How can I change the install folder?

By default, the install folder is the same folder as the previous version, or \Program Files\EmEditor if this is a fresh install. To change the install folder, open Command Prompt, and run the installer with the TARGETDIR option.

For instance, if the EmEditor installation file is emed700epx.msi, and if you want to install EmEditor to C:\path, run the following command:

emed700epx.msi TARGETDIR=”C:\path\”

A backslash ‘\’ is required at the end of the folder name.

More than one version of EmEditor cannot coexist on the same computer. If an old version is already installed, you must uninstall the old version first, or install the new version to the same folder as the old version.

How can I install an EmEditor syntax file?

1. Choose Select Configuration under the Tools menu.

2. Click Define Configuration at the very bottom of the list.

3. Click the New button, select Use Default Configuration and click OK.

4. Enter a descriptive name and click Enter.

5. Click the Properties button and select the Highlight (1) tab.

6. Click on the Import button, locate, and open the appropriate syntax file.

7. Finally, click on OK to close the Properties dialog box and click on Close to close the Configurations dialog box.

If you want to enable associated extensions and specify an extension or extensions that EmEditor should associate with the configuration, follow these additional steps:

8. Make sure the correct configuration is selected under the Tools menu.

9. Click Properties for Current Configuration under the Tools menu.

10. Select the Association tab and check the Enable Association box.

11. Click Add and enter the appropriate extension or extensions.

I am using a new version (or a new beta version) of EmEditor. Can I install an older version of EmEditor without uninstalling the new version?

No. You should unistall the new version of EmEditor before installing an older version of EmEditor. Failure to do so might cause some new DLL files to remain in the install directory, which can be incompatible with the older version of EmEditor. Before you uninstall the newer version, you should exit all EmEditor windows including the Tray Icon. When you uninstall the new version, you will be asked to keep all the settings. Selecting YES will keep all the settings that may be used in the older version of EmEditor. If you are asked to restart Windows during the installation, you should restart Windows.

When EmEditor Professional is installed, the associated text file icon does not become one of EmEditor’s icons.

EmEditor Professional does not change the text file icon from Windows system icon any more. If you prefer one of EmEditor’s icons for text files, run EmEditor, select Customize on the Tools menu, select the File tab, click the Associate with EmEditor button. Select the “txt” icon in the list, click the Properties button, enter emedres.dll file in EmEditor folder (usually C:\Program Files\EmEditor\emedres.dll) in the Sample Icon from This File text box, and select the txt icon in the Current Icon list box.

EmEditor does not run.

If Trend Micro Internet Security is installed, and the latest security update is installed, EmEditor may not run. Uninstalling Trend Micro Internet Security or removing the shortcut to Trend Micro Internet Security on the Desktop will resolve this issue.

How to create the 64-bit portable version.

To create the 64-bit portable version:

1. Download EmEditor Professional (64-bit installer) from the download page.

2. In the Command Prompt window of the Run dialog box, run the following command. A sub folder will be created, and all the installer contents will be extracted into the sub folder.

(Path)emed64_13.0.2.exe /extract
(if the installer file name is emed64_13.0.2.exe)

3. Copy all the contents in the folder into an install folder such as a USB portable drive.

4. In the same folder, create an empty file as eeUseIni.ini.

The above procedure creates the 64-bit portable version.

Crack, Keygen, Serial

Please go to Crack, Keygen, Serial.

Uninstall

I was using EmEditor on a trial basis and decided I don’t want to purchase it. How do I uninstall EmEditor?

Close all running EmEditor programs (Note that EmEditor Help will be closed as well. If you are reading this page from the Help, we recommend writing down the information on this page before closing). Click the Start button on the Windows Operating System and select Control Panel from the Start menu. Select Add or Remove Programs. Select EmEditor from the Add or Remove Programs dialog box. and then click the Delete button. Follow the instructions in the EmEditor Uninstall dialog box. We recommend restarting the Windows Operating System when the uninstalling is complete.

I have uninstalled EmEditor. When I double click a file to open the file, my computer looks for EmEditor. Since EmEditor does not exist in my computer anymore, I can’t open the file. How do I open such a file?

If you associate files using Associate with EmEditor in EmEditor, the original associations are supposed to be restored after having uninstalled EmEditor. However, if you associate files yourself in other applications such as Explorer, you need to restore the original associations yourself. Open Windows Explorer, click Tools, select Folder Options, and then click the File Types tab. Select extensions you want to delete in the Registered file types list box and click the Change button. In the resulting Open With dialog box, select a program other than EmEditor that you want to associate the file with.

After I uninstalled EmEditor, why isn’t the source code displayed in notepad when I select View Source from the context menu in Internet Explorer?

Some earlier versions of EmEditor were not able to completely uninstall the registry information. Click the Start button and select Run from the Start menu. Type “RegEdit.exe” and click the OK button to start Registry editor. Search for HKEY_LOCAL_MACHINESOFTWAREMicrosoftInternet ExplorerView Source Editor and delete the key.

After I uninstalled EmEditor, emedtray.exe and emedres.dll are still in the folder C:/Program Files/EmEditor. How do I delete them?

These files should be deleted during the uninstalling process. In your situation, the files were not deleted. To delete these files manually, first delete the shortcut running a Tray Icon of EmEditor. Then follow the instructions found in

Q. How can I remove the EmEditor tray icon permanently?

If you find the EmEditor tray icon running on your Taskbar, close it by selecting Close Tray Icon. You can then delete emedtray.exe and emedres.dll.

I cannot uninstall an older version of EmEditor from the "Add or Remove Programs" of Control Panel. How can I uninstall the older version?

If you can’t uninstall an older version, please run the installer for the old version with “/L*V log.txt” option, which will create a log file for uninstall. For example, if the installer is “emed64_14.3.1.exe”, please run:

emed64_14.3.1.exe /L*V log.txt

The log.txt file might contain useful information as to why the installer stops working.

Notes: The installer of the previous version can be found in one of the C:\ProgramData\Emurasoft\EmEditor\updates\update… folders, or you may find it from our Library at http://www.emeditor.com/library/#toggle-id-2.

If you get the following dialog box while trying to uninstall or install a new version:

“The feature you are trying to use is on a CD-ROM or other removal disk that is not available. Insert the ‘EmEditor Professional (…)’ disk and click OK.”

First, locate the installer of the previous version. Extract the installer with the “/extract” option. For example, if the installer is “emed64_14.3.1.exe”, you would run:

emed64_14.3.1.exe /extract

This will create a sub folder with file contents. Inside the folder, you will find a file with the file extention “.msi”, in this case “emed64_14.3.1.msi“.

When you uninstall, if you see the above dialog box, click the Browse button, and specify the above .msi file. Continue the process, and you should be able to uninstall the previous version.

If you are not sure which .msi file you need, you may find the information if you view the log.txt file.

Alternatively, if the uninstaller stops working when you try to uninstall from Control Panel, please try GeekUninstaller (freeware) or Revo Uninstaller (freeware) to uninstall.

If you need additional help, please email the log.txt file to our support at tech@emurasoft.com with detailed information.

File

When I try saving a file as a file name without an extension, ".txt" will be added automatically. How can I prevent an extension from being added to a file name?

Surrounding the file name with quotation marks (“”) will prevent an extension from being appended. For example, “file” will just be saved as file instead of file.txt.

When opening a file, EmEditor detects the file as a Western European even though it is actually a Japanese (Shift JIS) file.

On the File tab of Properties, uncheck Detect All if it is checked. The code page detection can make mistakes, especially with small files.

How can I close all windows at the same time?

Click X in the upper right corner of the window while pressing the SHIFT key. Alternatively, you can close all in the following ways:

  • Press ALT + SHIFT + F4.
  • Press ALT + SHIFT + X.
  • Select Close from the File menu while pressing the SHIFT key.
  • Add the Close All button on the Toolbar, and click that button.
  • Click the Tray Icon and select Close All from the menu.

How can I open from the same folder in the open dialog?

Select Customize under the Tools menu, and check the Remember Last Folder check box on the Customize dialog box.

Alternatively, display the Properties for the EmEditor shortcut that you usually use to run EmEditor, and add /cd in the Target text box. For instance, if the install folder of EmEditor is “C:\Program Files\EmEditor”, enter “C:\Program Files\EmEditor\emeditor.exe” /cd. Moreover, fill the Start in text box as a folder you want to open from.

How can I save an empty file?

Choose Properties for Current Configuration under the Tools menu and on the File tab uncheck the Delete Empty Files when Saving box.

Printing font size is too small.

Choose Properties for Current Configuration under the Tools menu and click the Font button on the Print tab to customize font and size.

When reading Macintosh text files, some characters are converted to different characters. How can I read Macintosh text files correctly?

Macintosh uses slightly different code pages than Windows does. In Windows 2000/XP/2003/Vista, where Macintosh code pages are installed, you can convert Macintosh text files into Windows text files. First, select the Define Encodings command under the Tools menu. In the Define Encodings dialog box, press the New button, and select a Macintosh encoding, for example, “10001 (MAC – Japanese)”. Select an appropriate character set, for example, Japanese. Click OK twice to close dialogs.

Next, select the Open command under the File menu, select your defined encoding, for example, “10001 (MAC – Japanese)” from the Code Page combo box, and then select a Macintosh file that you would like to read.

In Windows 98/Me, where Macintosh code pages are not installed, you cannot read Macintosh text files correctly if they contain special characters that cannot be read by Windows code pages.

When using a shared folder on a network, is it possible to prevent other users from making changes to a file that I have open and I am working on?

Yes, it is possible. On the File tab of Properties, select Keep Locked from the Changed by Another Program combo box. Other users will still be able to open the file but they will not be able to save changes to the file until you have closed the file.

How do I print my document in color or in black and white?

To print in black and white, click Properties for Current Configuration under the Tools menu, click the Print tab, and then select the Ignore Color and Underlines check box. To print in color, clear the check box.

What can I do to speed up opening a very large file?

Some configurations could slow down performance. Check the following points:

  • Click Properties for Current Configuration under the Tools menu, and then click the General tab. If an item other than “No Wrap” is selected in the Wrap by list, it might slow down EmEditor since it needs to compute where to wrap lines. When you open a large file, select “No Wrap”, or select the No Wrap command.

How can I paste a Japanese (or Korean, Chinese, etc.) Word document into EmEditor and save as a text file?

If Windows does not display Japanese, Korean, or Chinese fonts properly, you will need to go to Control Panel, select Regional and Language Options, click the Languages tab, and then check Install files for East Asian languages.

Open your Word document, select the text you want to copy, and then press CTRL + C to copy the text to the Clipboard.

Launch a new EmEditor window and press CTRL + V to paste the Clipboard contents to the EmEditor window. You should see the text in Japanese (or Korean, Chinese, etc.). If you cannot see the text properly, select Japanese (or Korean, Chinese, etc.) from the Font Category sub menu under the View menu. If you still cannot see it properly, select the Font command under the View menu, and select an appropriate font, for instance, MS Gothic if it is Japanese.

To save the document, select the Save As command under the File menu, and make sure you select either Unicode or UTF-8 from the Encoding drop-down list box. You may also select a locale-specific encoding such as Japanese (Shift-JIS) if you wish.

How can I open an XML file as Western European, not as UTF-8?

If an XML file is opened as Unicode, display the Current Configuration Properties, select the File tab, and check Opening Encoding drop-down list box. If this is Unicode, select System Default. If Detect HTML/XML Charset check box is checked, a “encoding=” directive specified within an XML file is searched, and EmEditor uses the specified encoding if the directive is found. Note that the encoding specified for opening files is different from the encoding specified for new files or for saving files.

How can I start a new Java file or XML file as Western European, not as UTF-8?

By default, Java files and XML files will start as UTF-8 when the New with Java or XML command is selected. You can change this default behavior by opening the Configuration Properties for Java (or XML), selecting the File tab, clicking the New Files button, and then selecting System Encoding from the Encoding drop-down list box. Note that the encoding specified for new files is different from the encoding specified for opening files or for saving files.

EmEditor is specified as an external text editor from another application. Why doesn’t the change made by EmEditor reflect the application?

If EmEditor is specified as an external text editor from another application such as a mail client program, and if the application monitors the EmEditor process for its termination and the file change, the application might not reflect an edited and saved file with EmEditor. To work around this, specify the /sp option to instruct EmEditor to be launched as a separate process. In this case, however, each EmEditor window will be displayed as a separate group.

Can I open GB18030 files?

Yes. First, go to Define Encodings on the Tools menu, click New and select GB18030 in the Encoding drop-down list. When you open a file, make sure you select this new defined encoding.

How can I convert file encodings by the command line?

Use the following command line options:

cp Encoding — sets an encoding to open as.
cps Encoding — sets an encoding to save as.
sa “DestFile” — specifies a file name to save as after the encoding conversion
ss+ — saves the file with a Unicode signature (BOM) after the encoding conversion.
ss- — saves the file without a Unicode signature (BOM) after the encoding conversion.

For instance, if you want to convert a file from Western European (iso-8859-1) to UTF-8, use the following syntax:

“windows1252.txt” cp 1252 cps 65001 ss- sa “utf8.txt”

See Encoding Constants for the list of encodings.

See Using Command Line Options for more information.

How can I open a file with a certain file extension by double clicking in Explorer?

Select the Customize command under the Tools menu. Select the File tab. Click the Associate with EmEditor button, and you can enter file extension to be associated with EmEditor.

How can I open a file exclusively?

Select Properties for All Configurations on the Tools menu (or after you open the file, select Properties for Current Configuration on the Tools menu). Select the File tab, and select Keep Locked in the Changed by Another Program drop-down list box.

Internet Explorer terminates when I view source of a local HTML file and then save the file.

On Windows XP, this issue appears when the Use Recycle Bin to Backup check box is checked in the Backup tab of configuration properties. Please clear the Use Recycle Bin to Backup check box.

What are three invalid characters at the beginning of my file?

The three characters at the top of your file is the “Byte Order Mark” of a UTF-8 file. By default, a Java file is created as UTF-8 with BOM. You can change the default code tab for new files from Java Properties > File tab > New Files button, and change the code tab to Normal ANSI, or uncheck the Add a Unicode Signature (BOM) box.

Edit

How can I select the text with the keyboard?

Press F8 to toggle normal selection mode. Press CTRL + F8 to select whole lines, and SHIFT + CTRL + F8 to toggle box selection mode. To change the keyboard settings, select Properties for Current Configuration under the Tools menu, and display the Keyboard tab.

Can I insert control characters such as form feeds?

To insert control characters on EmEditor v3, select Advanced > Insert Special Characters under the Edit menu. Alternatively, you can type corresponding keys with CTRL (+ SHIFT) only if the corresponding keys have not been assigned for shortcut keys and if the Allow Insert Control Characters is checked on the General tab of Properties.

I cannot paste text correctly when the content in the Clipboard has been copied from another application such as Netscape Navigator.

Some other applications, particularly Netscape Navigator, have problems translating text from ANSI to Unicode. Instead of using the regular Paste command, select All Commands under the Tools menu, then Edit > Paste > ANSI Paste. Alternatively, check Always Paste as ANSI on the General tab of the Current Configuration Properties dialog box.

How do I insert special characters?

Select Advanced under the Edit menu, and then select Insert Special Character. To inspect a Unicode character code you want to insert, refer to the Latin Extended Characters Reference. You can also inspect a character by using the Character Map ( Start menu > All Programs > Accessories > System Tools > Character Map) if installed in your Windows Operating System. You might need to adjust the font to display special characters properly.

See also To Insert Special Characters for the list of keyboard shortcuts.

How can I select a column block of text?

To select in a box, use the mouse to select while pressing the ALT key, or press SHIFT + CTRL + F8.

Where can I download Microsoft Global IME?

Global IME is not necessary because other language IMEs can be added from the Control Panel (Start menu > Settings > Control Panel > Date, Time, Language and Regional Options).

How can I undo inserted strings character by character using the Undo command?

By default, an entire inserted string will be undone by one Undo command. You can change this behavior by checking the Undo Character by Character check box on the Advanced tab of the Customize dialog box. You will then need to restart EmEditor.

How can I sort lines in alphabetical or numerical order?

You can select the Sort A to Z, Sort Z to A, Sort Smallest to Largest, or Sort Largest to Smallest command to sort in alphabetical or numerical order. These commands can be found in the Separated Values/Sort submenu on the Edit menu.

How can I check spelling?

On EmEditor Professional v10 or later, you can check spelling without using any plug-ins. On the Context Menu of EmEditor (the right-click menu), selecting Check Spelling will enable spelling. If this menu item is not visible, you can select Customize Menus on the Tools menu, select Context Menu on the list, and then click the Reset button.

Additional dictionaries are available for download at the extensions.OpenOffice.org (http://extensions.openoffice.org/). After download a dictionary, change the file extension from .oxt to .zip, extract the Zip file, and then copy *.dic and *.aff files into the Dictionaries sub folder of the EmEditor install folder (usually C:\Program Files\EmEditor\Dictionaries).

How can I assign a shortcut key to insert a special character?

Many shortcut keys are already assigned to insert many special characters by default. To see which keys are assigned, go to:

Insert Special Characters

Any character can be assigned to your favorite shortcut key using a macro. For example, if you would like to insert ä with a shortcut key, write a macro (in this case, JavaScript):

document.selection.Text=”ä”;

and save this file as a file, for example, InsertA.jsee. Select Select… on the Macros, and select this file. Running this macro will insert this character. To assign a shortcut key to this macro, go to Configuration Properties, select the Keyboard tab, and then select My Macros from the Category drop-down list, and assign your favorite key to the macro.

The Find Matching Parenthesis/Bracket command doesn’t work. How can I enable this command?

Please go to the Highlight (2) tab of configuration properties, and then check all items in the “Bracket Pairs” list so you can use CTRL+] to jump to the matching bracket.

The sort commands become disabled when a large file is opened. What are the conditions that disable the sort commands?

There are two factors that disable the sort commands.

1. Advanced tab of the Customize dialog box (Tools menu – Customize). The “Minimum File Size to Use Temporary File” must be larger than the file size you opened to sort in order to enable the sort commands.

2. If you are using the 32-bit version of EmEditor, in the Registry Editor, please find this key:

HKEY_CURRENT_USERSoftwareEmSoftEmEditor v3Common

And set a new REG_DWORD value MaxReserveBits as Decimal 24 (Hexadecimal 0x18). The default value is Decimal 20 (32-bit version of EmEditor) and Decimal 24 (64-bit version of EmEditor).

This value specifies the maximum number of lines that EmEditor can sort. You can’t specify the value more than 24. If 24 is specified, theoretically, the maximum number of lines is 16777216. However, if the OS can’t allocate a large memory, it may become less. In this case, you might want to restart Windows and run only EmEditor before you try again. If you are using the 64-bit version of EmEditor, the default value is Decimal 24, so setting the registry value is not required.

Are there Undo and Redo commands for the cursor position?

Yes, they are called the Back and Forward commands.
On the default keyboard shortcut, you can use the Back (ALT + LEFT) and Forward (ALT + RIGHT) keys.
The buttons for these commands can be added to a toolbar.

The paste command doesn’t work.

Please check Anti-Virus software. Sometimes, anti-virus programs block applications to access the Clipboard, and in that case, you will have to explicitly exclude EmEditor from blocking the Clipboard access.

Search

How can the Find dialog box show the previously searched string, not the word at the cursor?

On the right side of the Find drop-down list box, click the > button to display a menu, and select the Custom. Click the > button to display the menu again, and then select the Save as Default.

How can I erase all the previous words in the Find box?

Click Clear History in the bottom of the Customize dialog box, by choosing Customize under the Tools menu.

In the Find in Files dialog box, can I search for a string in Japanese JIS or EUC files?

In EmEditor Professional you can select Japanese JIS or Japanese EUC in the Encoding drop-down list box in the Find in Files dialog box. In EmEditor Standard, you cannot specify Encodings and cannot search Japanese JIS or EUC files.

Can I use regular expressions to search or replace?

Yes. Regular Expressions are supported.

How can I search for a word at the beginning of lines or a word at the end of lines?

The beginning of a line can be represented as “^” and the end of lines can be represented as “$” if you check Use Regular Expressions in the Find dialog box. Enter “^Search String” in Find field if you want to find “Search String” at the beginning of lines, or “Search String$” if you want to find “Search String” at the end of lines.

A new line can be also represented as “\n” if you check Use Escape Sequence. Enter “\nSearch String” in Find field if you want to find “Search String” at the beginning of lines, or “Search String\n” if you want to find “Search String” at the end of lines.

What are examples of regular expressions?

  • strings surrounded by double-quotation marks
    “.*?”
  • strings surrounded by [ ]
    [[^[]*?]
  • variable names
    [a-zA-Z_][a-zA-Z_0-9]*
  • IP addresses
    ([0-9]{1,3}).([0-9]{1,3}).([0-9]{1,3}).([0-9]{1,3})
  • URL
    (S+)://([^:/]+)(:(d+))?(/[^#s]*)(#(S+))?
  • lines followed by a tab
    t.*$
  • Hiragana
    [x{3041}-x{309e}]
  • Full-width Katakana
    [x{309b}-x{309c}x{30a1}-x{30fe}]
  • Half-width Kana
    [x{ff61}-x{ff9f}]
  • CJK ideographs
    [x{3400}-x{9fff}x{f900}-x{fa2d}]
  • CJK ideograph marks
    [x{3000}-x{3037}]
  • Hangul
    [x{1100}-x{11f9}x{3131}-x{318e}x{ac00}-x{d7a3}]
  • Insert // at start of lines
    Find: ^
    Replace with: //
  • Remove // at end of lines
    Find: ^//
    Replace:
  • Remove trailing whitespaces
    Find: s+?$
    Replace with:
  • Replace (abc) with [abc]
    Find: ((.*?))
    Replace: [1]
  • Replace 9/13/2003 with 2003.9.13
    Find: ([0-9]{1,2})/([0-9]{1,2})/([0-9]{2,4})
    Replace: 3.1.2.
  • Uppercase characters from a to z (EmEditor Professional only)
    Find: [a-z]
    Replace: U
  • Capitalize all words (EmEditor Professional only)
    Find: ([a-zA-Z])([a-zA-Z]*)
    Replace: U1L2

Why doesn’t EmEditor highlight multi-line strings?

EmEditor has been designed to highlight strings line by line, rather than highlight strings containing new lines, in order to increase the performance of the program.

Why is the Find/Replace dialog box so big?

The Find/Replace dialog box allows resizing by dragging the right bottom corner with the mouse.

How can I enter a multiple-line string as a search string in the Find/Replace dialog box?

On the right side of the Find drop-down list box, click the > button to display a menu, and select the Multiline. Moreover, drag the right bottom corner of the dialog box so the text box allows multiple lines. In order to enter a new line, use CTRL + ENTER.

View

The cursor shape used to look like ‘I’ but now it looks like a solid rectangle. When I type a letter, it is not inserted but overwrites an existing character. What happened?

“Overwrite” mode is turned on. Press the Insert key on your keyboard to toggle “Overwrite” mode.

Can I display single-byte spaces as any marks?

Yes. On the Marks tab of Properties, check the Show Spaces check box.

When I open a file using the default settings, it becomes unreadable, and if I choose another character set from the Font Category sub menu under the View menu, it becomes worse. But if I select a proper encoding when I open the file, it works. Why?

EmEditor’s internal processing is Unicode. EmEditor converts ANSI text to Unicode text when you open an ANSI file. When opening a file, you should select an encoding in the Open dialog box. If you don’t select an encoding, EmEditor defaults the file to the system default encoding. In order to open a file with a different encoding, you need to select the desired encoding when you open the file. You can later change the encoding by choosing the Reload command under the File menu choose an encoding to reload the file as.

When do I use Font Category under the View menu?

EmEditor cannot detect a language from Unicode files. You will have to manually choose a Font Category under the View menu to display a non-default character set in a Unicode file correctly. When creating a new file with a language other than default character set, you also need to select the Font Category you want to use.

How can I display continuous line numbers from page to page? I never had this problem, but now something changed in my configuration.

On the General tab in the Current Configuration Properties dialog box, uncheck the Display Page Number check box.

What are logical coordinates and display coordinates? What is a logical line?

Logical coordinates refer to the coordinates in a document regardless of the wrap mode in use. Returns due to the wrapping of lines are not counted. Logical lines refers to the number of lines, discounting lines formed by wrapping, in a document. Display coordinates, on the other hand, include wrapped lines in their sum.

I display line numbers on the left edge of EmEditor window. When a line is wrapped, I do not want to see the line number incremented within the logical line. How do I configure this behavior?

On the General tab in the Current Configuration Properties dialog box, select one of the logical coordinates options from the Line and Column Display as combo box.

I don’t like the new toyish Windows XP style toolbars. Can I use the old toolbar buttons?

Yes. Select Customize Toolbar from the Tools menu, and select 16 color.

Can I change the Tray Icon on the Task bar to my favorite icon?

Yes. Run Registry Editor (RegEdit.exe), and find HKEY_CURRENT_USERSoftwareEmSoftEmEditor v3Common. Create a TrayIconFile value as REG_SZ and set the icon file path, and TrayIconIndex value as REG_DWORD and set the icon index.

How can I highlight previously searched strings more than once with different colors?

On the Display tab in the Current Configuration Properties dialog box, enter how many times you want to highlight in the Search Colors edit box. To highlight with different colors, scroll down to the bottom of the Specify Part list box, select Search string (1), (2), …, and click on Background Color or Text Color to select new colors to display searched strings.

How can I display an underline at the cursor position?

On the Scroll tab in the Current Configuration Properties dialog box, check Horizontal Line.

How can I display URLs without breaking at specific characters (such as , (comma))?

On the Link tab in the Current Configuration Properties dialog box, add characters you don’t want to break URLs (such as , (comma)) to Recognize These Characters.

The cursor vertical line is thin. Can it be thicker?

In Windows Vista, select Optimize Visual Display in Control Panel, and select a greater number in the Set the Thickness of the blinking cursor drop-down list.
In Windows XP, select Accessibility Options in Control Panel, select the Display tab, and adjust the Width under the Cursor Options.

How can I find the number of the words in the selection?

You can use the Word Count plug-in, which is included in EmEditor Professional 6.00.1 or later. If you use EmEditor Standard, you can download the plug-in from the library.

How can I decode Numeric Character References ("&#xx") in Unicode characters?

You can select the Edit menu – Convert SelectionOthersHTML/XML Character Reference to Unicode.

How can I find the return type (e.g. CR, LF, CR+LF) for each line?

If you set the Character Code at Cursor checkbox in the Status tab of the Customize dialog box, and when the cursor is at end of any line, you will see 0D+0A (CR+LF) or 0D (CR only) or 0A (LF only). You can also check the Show CR and LF with Different Marks in the Marks tab of Properties to distinguish the return types. Since each line can have different return types in EmEditor, this is how EmEditor displays the return types for each line.

How can I add the Marks button to the Toolbar?

Double click on the toolbar (the basic one) border, and the Customize Toolbar dialog will appear, where you can select the Marks button and add it to the toolbar. Alternatively, you can select Customize Toolbar on the Tools menu, and then double-click the Toolbar 1 in the Toolbars list, where you can select the Marks button and add it to the toolbar.

How can I display line numbers?

Select Properties for Current Configuration on the Tools menu, click the General tab, and check Show Line Numbers.

In XHTML and XML documents, XML files, text inside a tag and the matching tag at the cursor becomes highlighted. Can you stop this behavior?

Yes, in the HTML and XML configuration properties, go to the Highlight (2) tab
and clear the Highlight Matching Tag check box.

How can I change the user interface language?

Please go to the Customize dialog, Language tab, and you can change the user interface language.

Customize

How can my favorite mail software run when clicking mail address?

The e-mail program you want to use needs to be the default e-mail software. You can find an option to set the default e-mail software under Settings > Control Panel > Internet Options > Programs. If not found, in Explorer, select Options under the View menu, and select the File Types tab. Select URL:MailTo Protocol, double-click open, and enter the mail software path and options on Application used to perform action. Refer to the e-mail program help because the options depend on each mail software. Some e-mail programs do not support this function.

Clicking URLs will not run my favorite web browser.

After installing a second browser, you will be given the option to set the second browser as the default browser. Clicking a URL on EmEditor will start the second web browser at this point.

How can I make the year 4 digits when you insert dates?

Customize the date format in the Locale, Control Panel. This specification is the same as Notepad.

How can I open the Input Method Editor (IME) automatically when running EmEditor?

To open the IME automatically when running EmEditor, choose Properties for Current Configuration under the Tools menu and check the Run Input Method Editor check box on the General tab.

How can I copy configuration properties on one machine to another?

You can copy them if you write the HKEY_CURRENT_USERSoftwareEmSoftEmEditor v3 key to a file by Registry Editor (Regedit.exe), copy the file to the other machine, and read the file by Registry Editor. You might need to change the folder names in the Properties by yourself.

Why is there no ASP configuration?

The ASP syntax is included in the HTML configuration, and the embedded script (usually written in VBScript or JavaScript) will be highlighted according to the VBScript or JavaScript configuration.

What is "HTML" and "HTML-Embedded" in Special Syntax combo box on the Highlight (2) tab of Properties?

HTML is used when HTML tags specifying the script language (SCRIPT type=…) exist in the HTML document. HTML is also appropriate for ASP files that include scripts beginning with the % mark. This is usually the case for VBScript, Javascript, PerlScript, CSS, etc. HTML-Embedded is appropriate when working with script languages such as PHP or JSP and the characters that normally mark the beginning of scripts in such languages, which are specified in the Script Begin box.

Can EmEditor encode Unicode characters as "Numerical Character References" (NCRs - those &#xx; codes) when saving HTML or XML files?

Yes. On the File tab in Properties, click Saving button, and check Save Unicode as HTML/XML Character Reference. You can also click Use Named Entity Reference if you would like to save named entity references such as ©. For HTML and XML configurations, these checkboxes are checked by default. However, EmEditor currently cannot decode or display NCRs as real Unicode characters when loading HTML or XML files.

There is no encoding available in the Reload sub menu under the File menu except Same Encoding, Detect All, System Default, UTF-16LE, UTF-16BE, UTF-8, and UTF-7. How can I add more code pages?

If you do not install EmEditor properly, but just copy emeditor.exe from another PC and run it, some system encodings will not be available in your copy of EmEditor. To setup additional system encodings, you can logon with Power User or Administrator privileges if you use Windows NT/2000/XP, and select the Define Encoding command from the Tools menu, and click the Reset button. Encoding availability depends on which language system files you install in your copy of Windows. If you cannot find a particular encoding from within EmEditor, you can install additional language files from Control Panel – Regional and Language Options. After language system files are installed in your copy of Windows, select the Define Encoding command from the Tools menu, and click the Reset button.

After updating EmEditor to the newest version, how can I add the new commands to a menu or add the new keyboard shortcuts?

If the new commands do not show up in a menu, select Customize Menus under the Tools menu, and click on the Reset button to reset the menus to their defaults. To add new command shortcuts, click on the Reset button in the Keyboard tab of Properties for All Configurations.

How can I define two-keystroke keyboard shortcuts?

You can define two-keystroke keyboard shortcuts by using a combination of the user menu features and the keyboard mapping features. By default, CTRL+K is predefined for the first key of two-keystroke shortcuts using User Menu (1).

Some of the predefined shortcuts include:

CTRL+K, K Toggle Bookmark
CTRL+K, N Next Bookmark in this Document
CTRL+K, P Previous Bookmark in this Document
CTRL+K, L Clear All Bookmarks in this Document
CTRL+K, C Comment Selection
CTRL+K, U Uncomment Selection

In this list, the second key can be activated with or without CTRL key. For instance, the Toggle Bookmark command can be activated by pressing K with CTRL, and then K again with or without CTRL.

To add new two-keystroke shortcuts:

1. On the Help menu select Keyboard Map.
2. Click to select the All Configurations button on the Toolbar, if you want all of the configurations to use the same shortcuts (or deselect it to not use the same shortcuts).
3. Scroll down the list to User Menu (2) and double-click.
4. In the Configuration Properties, type a shortcut in the text box, Press a New Shortcut Key. For instance, CTRL+;.
5. Click the Assign button, and click OK.
6. Close the Keyboard Map window.
7. Next, on the Tools menu select Customize Menus.
8. Select User Menu (2) on the Menu to Customize list.
9. Click the Insert Right button.
10. In the Menu Properties, select a new command to assign a shortcut to.
11. On the Name text box, use & to specify a new shortcut key.
12. The character to the right of & specifies the second character.

For instance, if you want to add New and Paste command and set “N” as the second shortcut key:

1. Select File in the Category list.
2. Select New and Paste in the Command list.
3. Type &New and Paste in the Name text box.
4. Click OK.

Repeat this procedure to define as many commands as you prefer.

By default, the user menu will appear 1 second after the first key is pressed. Second shortcut keys work before the user menu appears. You can change the delay time for each user menu by adjusting the Delay Time slider on the bottom of the Customize Menus dialog box.

CTRL + Mouse Wheel can change the font size, but can you disable this?

In the Customize dialog box, the Mouse tab, clear the “CTRL + Wheel to Change Font Size” check box.

Double-clicking a tab causes to create a new window. Can you disable this behavior?

Yes. please go to the Mouse tab of the Customize dialog box.
If the “New Group” is selected for the Left Mouse Button Double-Click, select “Undefined”.

Tools

How can I run an external compiler from EmEditor to compile the current file?

See FAQ: What are examples of External Tools configuration? -Compile by Visual C++ section.

How can I do a Google search for the word at the current cursor position?

Select the Customize Tools command, select the New button and enter “http://google.com/search?q=$(CurText)” in the Command text box.

I want to compile the opened file with an external tool in Command Prompt, but how can I keep the Command Prompt window from closing after the compilation is finished?

Select the Customize Tools command, and select the New button and enter “cmd.exe” in the Command text box, and /k “filename” $(Path)” in the Arguments text box.

What are examples of External Tools configuration?

  • Open Internet Explorer
    Command: C:\Program Files\Internet Explorer\iexplore.exe
    Arguments: $(Path)
    Initial Directory: $(Dir)
    Icon Path: C:\Program Files\Internet Explorer\iexplore.exe
    Check Save File
  • Open Explorer
    Command: %WinDir%\explorer.exe
    Arguments: $(Dir)
    Initial Directory: $(Dir)
    Icon Path: %WinDir%\explorer.exe
  • Open Command Prompt
    Command: %WinDir%\system32\cmd.exe
    Arguments: $(Dir)
    Initial Directory: $(Dir)
    Icon Path: %WinDir%\system32\cmd.exe
  • Compile by Visual C++
    Command: %WinDir%\system32\cmd.exe
    Arguments: /k “C:\Program Files\Visual Studio\Vc7\bin\vcvars32.bat”&&cl $(Path)
    Initial Directory: $(Dir)
    Icon Path: C:\Program Files\Visual Studio\Common7\IDE\devenv.exe
    Check Save File
  • Run associated program
    Command: $(Path)
    Arguments:
    Initial Directory: $(Dir)
    Icon Path:
    Check Save File
  • Search Google for a word at cursor or a selected text.
    Command: http://google.com/search?q=$(CurText)
    Arguments:
    Initial Directory:
    Icon Path:
  • Check out from Microsoft Visual SourceSafe
    Command: %WinDir%system32cmd.exe
    Arguments: /k C:\(SourceSafe path)\Common\VSS\win32\SS.EXE checkout $/(path)/$(Filename).$(Ext) -y(user name)
    Initial Directory: $(Dir)
    Icon Path: C:\(SourceSafe path)\Common\VSS\win32\SSEXP.EXE
  • Check in to Microsoft Visual SourceSafe
    Command: %WinDir%\system32\cmd.exe
    Arguments: /k C:\(SourceSafe path)\Common\VSS\win32\SS.EXE checkin $/(path)/$(Filename).$(Ext) -y(user name)
    Initial Directory: $(Dir)
    Icon Path: C:\(SourceSafe path)\Common\VSS\win32\SSEXP.EXE
    Check Save File

You can use the following predefined arguments in Command, Arguments, Initial Directory, and Icon Path.

$(Path) The full path name of the file.
$(Dir) The directory name of the file.
$(Filename) The file name without its extension.
$(Ext) The file name extension.
$(CurLine) The logical line number of the cursor.
$(CurText) The selected text if selected, or the word at the cursor if not
selected.

You can also specify environment variables, such as %WinDir%

Macros

Can I use the VBScript MsgBox function?

No. However, you can use the Popup method of the WshShell. You can also use the alert method or confirm method instead.

See Also Display a Message Box

Can I save multiple macros to files?

Yes. You can save multiple macros to files by using the Save Macro command.

Window

What is the split window for?

Sometimes it is convenient when you are writing at the bottom of the text, to view the top of the text at the same time. You cannot open a different file on each pane of the split window.

How can I save the EmEditor window size, and always open EmEditor windows at the same size?

First resize the EmEditor window to the desired size, then select the Customize command from the Tools menu, select the Window tab, click the Save Current Window Position button, and then click OK.

How can I always open EmEditor windows at the maximized size?

First maximize the EmEditor window, then select the Customize command from the Tools menu, select the Window tab, click the Save Current Window Position button, check the Restore Window Position check box, and then click OK.

How can I save the current positions of all EmEditor windows, and open all the windows at the same positions next time?

Left click the mouse button on the Tray Icon to display the Tray Icon menu, and select the Save Workspace command to save file names and cursor positions of the current workspace. Next time you can select the Restore Workspace command to restore the previously saved windows with the same file name and cursor positions.

You can also use the Save Workspace and Close All command to close all windows after saving the workspace, or use the Save Workspace, Save, and Close All command to save and close all windows after saving the workspace.

How can EmEditor display as if it were a tabbed window?

Select the Enable Tabs command so it is checked.

Why doesn’t the Cascade or Tile command work?

When the tab is enabled, selecting the Cascade command or one of the Tile commands does not disable the tab. These commands cascade or tile only when multiple groups exist. Therefore, these commands make no sense when only one group exists. This change has been made due to users’ request. To cascade or tile as the previous manner, disable the tab first, then select one of these commands. New Horizontal Group and New Vertical Group commands allow you to tile windows even if only one group exists.

How can I make the EmEditor window stay open when I close the last open document?

Select the Customize on the Tools menu, select the Window tab, and check the Do Not Close Last Document by Selecting Close Command check box.

Is there a way to make EmEditor move through document tabs in sequential order from left to right?

Yes. Select Customize on the Tools menu, then select the Window tab, and clear the Switch to Last Used Document for Next Document Command check box. When unchecked, you can switch between the tabbed documents in order from left to right, or right to left, using CTRL+TAB, or CTRL+SHIFT+TAB respectively. When checked, pressing CTRL+TAB and CTRL+SHIFT+TAB, switch back and forth between the active document and the last viewed document.

Plug-ins

How can I enable the Outline Guide (Code Folding) while hiding the Outline Custom Bar?

In the Outline properties, clear the Turn off Outline Guide when Custom Bar is not displayed checkbox.

Why do I need to click the FindBar plug-in button twice in order to close the FindBar?

When the FindBar is displayed, if you are in the Editor view, clicking the FindBar button in the Plug-ins toolbar changes the keyboard focus to the FindBar. Once the focus is on the FindBar, clicking the FindBar button in the Plug-ins toolbar again closes the FindBar. Thus, in order to close the FindBar when the focus is in the Editor view, you will need to click the FindBar button twice.

The above behavior allows you to move the focus to the FindBar drop-down list by assigning a keyboard shortcut to this plug-in command. In order to allow this focus movement by a shortcut key, the above behavior is specification.

Purchase and Update

If I purchase EmEditor, can I get the newer version for free? Or do I have to pay for the registration fee every time I get a new version?

If you purchase a lifetime license, you will get all the new versions for free.

If you purchase a normal license, you will get all the new versions for one year after your purchase date. After one year from the purchase date, you will still get the new versions as long as you subscribe a maintenance plan.

How can I find out whether the currently installed EmEditor is Professional or Standard?

Go to the Help menu in EmEditor, select the About EmEditor command. The About EmEditor dialog box should then appear. You can find version information in the upper part of the dialog box showing “EmEditor Professional” or “EmEditor Standard”, followed by the version number. Note that no distinctions exist between Standard and Professional in EmEditor Version 3.

What is the difference between Normal License and Lifetime License?

They both allow you to use the current version of EmEditor permanently.
However, if you would like to get upgrades for more than a year, with a normal license, you will have to purchase a maintenance plan. With a lifetime license, you will be eligible to receive free upgrades for the lifetime of the product.

When I try to update EmEditor, I see the dialog box that says "You might need to purchase an upgrade." How do I know if I need to purchase an upgrade?

Please go to Resend Keys page and enter the email address you used to purchase EmEditor. Our system will send a list of all the available keys to you, including the key of the latest version if your license is eligible.

Troubleshooting

How can I report a crash?

If EmEditor crashes, a crash report file will be created usually in the C:\ProgramData\Emurasoft\EmEditor\Error\ folder. Please email the most recent file (compressed to a Zip archive) to tech@emurasoft.com as an attachment with the detail information including procedure to reproduce your issue.

When I try to launch EmEditor, it is trying to load very large files. Can you disable this?

EmEditor is trying to load the last used workspace. In the Command Prompt, run:
emeditor.exe /clw
and the last used workspace will be erased, and an untitled EmEditor window will be launched.

When updating EmEditor, an error occurs and a system restart becomes required.

When updating EmEditor, the installer displays the following message, and a system restart may become required.

“The installer has insufficient privileges to access this directory: C:\Program Files\EmEditor. The installation cannot continue. Log on as administrator or contact your system administrator.”

It is possible that another application is holding the EmEditor install folder as opened. It is recommended that you close all applications before updating EmEditor. In particular, Brother Control Center (BrCtrlCntr.exe), which comes with Brother printers, might open the EmEditor folder, and thus close the Control Center you might find in the Taskbar Notification Area.

If the problem persists, use Process Explorer and search for any open handles to the EmEditor install folder.

Usually the system asks for a system restart only as a last alternative, and this is basically done so that the system can free up the resources that need to be updated. Especially when a system restart is prompted, use Process Explorer and search for any handles to C:\Program Files\EmEditor.

Download

Where can I download the free version of EmEditor (EmEditor Free)?

EmEditor Free and EmEditor Professional use the same binary program.
You can download EmEditor Free/Professional at the download page.
After you install EmEditor, you can select the “Downgrade” command to downgrade to the Free version.
The Downgrade command can be found by typing “Downgrade” in the Quick Launch window (Ctrl+Q).
Please see the description how to switch between the Professional version and the Free version.

Where can I download older versions of EmEditor?

You can download older versions of EmEditor from “EmEditor Old Versions” folder of the Library page.