#5053

Yutaka Emura
Keymaster

vha wrote:
Some strange behaviors when editing ReadOnly files:

– when typing text, nothing happens (which is because of the ReadOnly attribute). Maybe a popup box (once per file) should be displayed telling the file is ReadOnly

If this is a behavior that most people would like, I can change that. I can add this to wish list.

– when unchecking the ReadOnly attribute in the Edit menu you can start typing (which is ok). When you then save the file, you get again warned that the file is readonly (don’t know if this OK, since you deliberately unchecked the ReadOnly attribute).

– when you finally saved the file (confirming so again), the ReadOnly attribute is reset again in the Edit menu. Isn’t that a bug? Or should the unchecking of the ReadOnly attribute also uncheck the ReadOnly attribute of the file

These are because EmEditor does not change the file attribute when a user clicks Read Only after the file is opened. I will add it to wish list.