#7616

Yutaka Emura
Keymaster

Klortho wrote:
I have a file named “09.txt” that is encoded in UTF-8 without a BOM. I have found that the encoding that EmEditor opens it in depends on whether I select it from the recently used file list, or select it in the file-open dialog box.
– If I close the file, and then click File -> (select “09.txt” from the recently used list), it opens in UTF-8 without Signature (correct)
– If I close the file, and then click File -> Open, and then select it from the directory list, it opens in “Central European (ISO)”, which is wrong.

I tried changing the setting in Tools -> Properties for Current Configuration -> File tab, Opening Encoding, but that seems to have no effect. What is that box for?

Note that **even when the file has a BOM**, it still opens in “Central European (ISO)” when I use File -> Open. This, despite the fact that in the settings for current configuration, I definitely have “Detect BOM” and “Detect UTF-8” both set.

Thanks for any help you can provide!

When you open a file from File > Open, you will need to make sure the “Configured Encoding” in the Encoding drop-down list. I suspect “Central European (ISO)” is selected in ths drop-down. This option is remembered when you open a file, and so next time you open a file, you will need to make sure you are selecting a correct option. I hope this helps. Thanks!