#11215

Antnee
Member

Hi Yutaka,

The problem there is that the function name is buried under the /** parent, which is incorrect. However, I was unclear about my exact use-case, so apologies for that. I’d not realised that the problem for me occurs under classes. I’ve taken this screen shot for you to see. I’ve had to blur a few bits out as this is internal.

Just taking the visible code from the main window into account, what I expect is something more along the lines of:

class className
- private $allowIncompleteCollections
- private $cacheItemTypes
- private $cacheArticles
- private $cacheItems
...
- public function __construct()
- public function setXmlFeedPattern($pattern)

Or something like that. Basically, I expect that it will disregard characters that indicate comments. Since these can be defined in the Configuration Hightlight (2) tab, with multi-line (“Begin:”, “End:”) parameters and single line (“Line Comment:”) parameters, and it will then use the first line afterwards. If I change the “Make Comments Collapsible” option I just end up with loads of “/**” in there instead

Less important, since it begins heading into true IDE territory, would be for it to recognise bracket-pairs as containers for each level. For example:

class foo{
public function bar(){
if (baz()){
return TRUE;
}
}

private function baz(){
return TRUE;
}
}

I would expect this to appear in outline as:

class foo
- public function bar{
- - if (baz()){
- private function baz{

But oddly, all I see is this:

class foo{

This is weird. It’s also useless. The collapsing works in the editor for that code, which is good. However, it works based on the justification of each line. It really ought to be doing so based on the bracket-pairs, especially (in PHP and many other similar languages at least) the curly braces { and }

Do that, and EmEditor gets a second chance of being my primary editor, and not just my large file editor.

By the way, if I’m viewing any massive XML files, the Outline plugin still tries to process the entire document. It took a while for me to realise that my CPU was burning along at 100\% just because of this. Got very warm in the room! 😉