Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #21490

    Pepper Mint
    Participant

    1. CSV is slow
    I find moving around and editing a 56kb (file size) csv file to be very slow eg characters show up slower than I type. I find this strange since emeditor is very fast with large text files. Microsoft Excel handles the same csv file without slow downs. Is there anything I can do to speed things up?

    2. How to wrap cell content in csv?

    View post on imgur.com

    Notice that cells without multiple lines wraps content just fine. However, cells with multiple lines will not wrap content. Is there a way to fix this?

    Thanks for reading.

    #21491

    Yutaka Emura
    Keymaster

    Hello,

    1. I can’t reproduce slowness of CSV files. Can you send me a sample file at tech @ emurasoft.com? I will try to reproduce the issue. Please add detailed procedure to reproduce the issue.

    2. Newlines are expresssed as ^M^J (reversed M and J), whicn means CR + LF. According to CSV specifications, cells including newline(s) must be surrounded by double-quotes. Please refer to CSV specifications. https://en.wikipedia.org/wiki/Comma-separated_values

    Thanks!

    #21492

    Yutaka Emura
    Keymaster

    I received your email. Thank you.

    1. I believe you are talking about the cursor movement within a cell when you are editing it. This is due to the Cell toolbar, which synchronizes the cursor position with the cell in the editor. You might want to disable (hide) the Cell toolbar. Clear the “Automatically Show/Hide Cell Toolbar” menu in the Cell toolbar button. Nevertheless, I will try to optimize this for speed.

    2. This is how EmEditor shows multiple lines in a cell. Since EmEditor is developed as a text editor, not Excel, it is NOT easy to show wrapped lines in a cell as Excel does. The current style is a compromise where EmEditor still can handle embedded newlines in a cell while not loosing its speed.

    Thanks,

    #21494

    Pepper Mint
    Participant

    Thanks.

    re: 1. I tried turning off the cell toolbar. No difference. Seems the bigger the csv file, the slower it becomes. I look forward to the optimization. For now, I will use the “associated” program feature.

    re: 2. – i see. Thanks.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone