Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #4947

    AussieDan
    Participant

    Hi,

    I was excited to see the WordComplete feature, but noticed that the function completions are all in upper case.

    Is there an option I am missing to control the case of the built-in completions? If not then I would suggest that this is a bug.

    The built-in suggestions for PHP should match the case of the definitions, eg from the PHP manual.

    Dan

    #4952

    Yutaka Emura
    Keymaster

    Built-in suggestions come either from words already contained in the document, or from highlight words that are defined in the Configuration Properties > Highlight (1) tab. In the PHP case, keywords might come from HTML configuration, or even from JavaScript or VBScript. By default, all PHP and HTML keywords are lowercases. Did you import some other keywords or did you define keywords yourself? What kind of keywords eactly do you see uppcases? Scripting or PHP keywords? You might want to reset all configurations and see if you can see the difference.

    #4953

    AussieDan
    Participant

    Thanks for the information about where the suggestions come from, I will go through my configuration and see if I can find the problem.

    #4964

    AussieDan
    Participant

    After resetting the highlight configuration the wordcomplete seems to be working properly, thanks!

    I did notice a couple of spelling/typo errors on the Options tab for WordComplete configuration:

    Display Icons in the Cadidate List
    Automatically Hide the List when No Candiate is Matched

    Keep up the great work!

    #4975

    Yutaka Emura
    Keymaster

    AussieDan wrote:
    After resetting the highlight configuration the wordcomplete seems to be working properly, thanks!

    I did notice a couple of spelling/typo errors on the Options tab for WordComplete configuration:

    Display Icons in the Cadidate List
    Automatically Hide the List when No Candiate is Matched

    Keep up the great work!

    I fixed those spelling mistakes. Thanks for your report!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone