Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #20417

    Stefan
    Participant

    Hi Yutaka,

    for “Automatically Name Untitled Document check box”
    (If this is checked, when an untitled document is being saved,
    the first line of the document will be used to name the file.)
     
    the string taken from first line to name the Untitled Document,
     
    is shorten to 41 characters.
    For me that is to strict and cut my title, written in first line, much too much.

     
    I would like to have an option (even in the ini/Registry only)
    to increase that length. For me, I think 80 or 99 chars are enough.
    But I even think you can increase it to an even longer string
    as like 200 chars. We can always cut them in the Save-dialog box ourself.

    Please consider.
     
    Thank you for making EmEditor.

    #20421

    Yutaka Emura
    Keymaster

    Hello Stefan,

    The next version v15.5.0 will be released soon, and it will include a registry value. Also, the default value becomes 80 (it was 40 in older versions).

    The following REG_DWORD values can be set in the HKEY_CURRENT_USER\SOFTWARE\EmSoft\EmEditor v3\Common key to set the maximum length for the file name when the Automatically Name Untitled Document check box is checked in the Save Details dialog box.

    MaxNameUntitled: the maximum length for the file name including the terminating NULL character. Default: 0x50 (80)

    Thank you,

    #20431

    Stefan
    Participant

    Thank you very much for reply and improvement.
    Now this feature makes much more sense to me.

    #20437

    Stefan
    Participant

    v15.5.0 ,

    Works fine, both default ’80’ value and also adding ‘MaxNameUntitled=143’ to eeCommon.ini under ‘[Common]’ section.

     
    Thank you for making EmEditor.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone