Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #20600

    ujr
    Participant

    Hi,

    in column selection mode (alt+mouse), the backspace key behaves completely different than in regular selection mode:
    deleting works only inside the selected area (removes the column in front of the cursor) or does nothing at all when the cursor is positioned at the beginning of the selected part. In regular selection mode on the other side, backspace deletes the complete selection.
    Every other editor I came across works the same in both modes and it is rather confusing how it is handled in EmEditor. Is this behaviour by design or a bug? Can it be changed?

    Thanks

    #20601

    Yutaka Emura
    Keymaster

    Can you please write more details about the issue? You can also post or email screenshots or sample files with detailed step-by-step procedure.

    Thank you.

    #20602

    ujr
    Participant

    Okay –
    1) type some text, eg
    line1
    line2
    line3
    line4
    line5

    2) select “ine” in “line3” – press backspace – “ine” vanishes as expected
    2a) restore “line3”

    3) select “ine” in all lines by pressing “alt” when the cursor is between ‘l’ and ‘i’ in “line5”, drag with mouse between ‘e’ and ‘1’ – press backspace – on every line in selection the ‘e’ disappears (not the whole selection as I would expect)
    3a) restore text (ctrl-y)

    4) select the other way around (from in between ‘e’ and ‘1’ to ‘l’ and ‘i’ – press backspace – nothing happens

    Do the same in, say, Notepad++ or Visual Studio. I would expect the same behaviour in EmEditor. However, I don’t know if EmEditor behaves as designed. If so (ie, it’s not a bug) I’d like to know how I can toggle between behaviours.

    btw, part 3 works identically if there’s no selection at all (but only a column cursor between ‘e’ and the numbers.

    Thanks

    #20603

    Yutaka Emura
    Keymaster

    Hello,

    I am not sure why nothing happens when you press BACKSPACE on the step 4). You should see the vertical selection was converted to multiple selections, and you will see multiple rectangle frames (usually gray if you use the default theme). If you change color settings or theme, please go to configuration properties, the Display tab, and click the Reset button to reset to the default theme and see if you can reproduce the problem.
    Also, please make sure you are using the latest version of EmEditor.

    Thank you,

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone