Tagged: 

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #22002

    gordy
    Participant

    It seems to depend on the line endings of the source text – in this case I am copying from SQL Server Management Studio. If I paste into Excel first and re-copy then it pastes correctly into EmEditor.

    #22124

    gordy
    Participant

    still reproducible in 17.0.1

    #22126

    Yutaka Emura
    Keymaster

    Hello,

    Unfortunately, I am having a hard time understanding the issue. Can you please explain the issue in different words in details?

    Can you reproduce the issue without SQL Server Management Studio?

    Thanks,

    #22128

    gordy
    Participant

    I can reproduce it without ssms by using this powershell command to set the clipboard text:

    PS > scb ‘aaaa
    >> bbbb
    >> cccc
    >> dddd’

    the clipboard now contains 4 lines of text:
    aaaa
    bbbb
    cccc
    dddd

    paste it into EmEditor, then highlight the block using block-selection mode (alt+click), and paste again, the text becomes:
    aaaa
    aaaa
    aaaa
    aaaa

    #22129

    gordy
    Participant

    actually it’s easier to reproduce than that, in EmEditor simply copy the text without using block-selection and then paste using block-selection mode:

    ..here I’m typing 1 <enter> 2 <enter> 3 <enter> 4 .. <ctrl+a> <ctrl+c> then block-selecting and <ctrl+v>

    #22130

    Yutaka Emura
    Keymaster

    This is actually how EmEditor works currently. You should switch to the Block Selection mode BEFORE you copy the text.

    I understand some people would like an alternative behavior, and I will think about adding the option in future versions.

    Thanks,

    #22131

    gordy
    Participant

    In that case I would propose supporting the case where we’re copying text from other applications – like SSMS apparently copying a column is the same as copying lines w/CRLFs.

    It’s certainly unexpected to have the first line repeating, maybe just stop after the first line if there’s no CRLF highlighted. If not paying attention it’s easy to miss that the values aren’t what you thought you pasted and move on – this happened to me hence the bug report 😉

    #22194

    Yutaka Emura
    Keymaster

    The recent beta version changes the behavior per your request.
    Thanks!

    #22208

    sky
    Participant

    This change is very useful, especially when create Batch Replace List or similar TSV files from copy-data.
    Ex.

    on	1	a		
    on	2	b		
    on	3	c		
    on	4	d		
    on	5	e	

    Before v17.1.0 beta 4, need to paste into Excel two columns separately first, and then copy & paste back to EmEditor. Now it can be done in EmEditor.

    In addition, suggest also consider to add an option to CVS mode for this change in future version.
    Because when we try to copy & paste above “a~e” (a \n b \n c \n d \n e \n) vertical data from other software(ex. Excel),
    If paste to EmEditor CVS mode column 2 or later, “a” position is correct, but “b”~”e” position will be on the unexpected column 1.
    CSV

    If paste to Excel column B or later, “a” position is correct, and “b”~”e” position is correct as well.
    Excel

    #22213

    sky
    Participant

    It is great on v17.1.0 beta 5,
    In the past year, I had depended on Excel to help handle these, and then copy into EmEditor more than fifty times.
    Now, I can no need for Excel on this, thanks!

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone