Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #8148

    George Schizas
    Participant

    When the option to “Add a shortcut menu on Explorer” is enabled, Ctrl-Shift-click on a shortcut on the taskbar opens the file in EmEditor. What should happen is when you Ctrl-Shift-click on a shortcut on the Windows 7 Taskbar, the program runs with elevated access (real administrator)

    I’m using 64-bit EmEditor, version 9.14 on 64-bit Windows 7 Ultimate. I don’t remember seeing this error before.

    I’ve disabled the Explorer shortcut for now, but this really should be fixed…

    #8151

    Yutaka Emura
    Keymaster

    I am not exactly sure what you mean. Can you describe the procedure you tried, step by step, please? I really want to reproduce your issue, and fix any bugs you encountered. Thank you.

    #8153

    George Schizas
    Participant

    Environment is Windows 7, 64-bit, and I’m using the 64-bit version of EmEditor.

    1. Click on the Start button, find the “Command Prompt”, right click on it and select “Pin to Taskbar”.
    2. Enable the Context Menu shortcut (from Tools > Customize > Shortcut > More Shortcuts > “Add a shortcut to the Context Menu” on Explorer.
    3. Press shift and right click on the “Command Prompt” button on the taskbar.
    4. Select “Run as Administrator”
    5. Instead of the UAC prompt and the execution of the Command Prompt in an elevated mode, EmEditor opens cmd.exe (and asks about Binary ASCII, Binary Hex, encoding etc)

    Step 1 is really optional, you can right click on any shortcut and the “Run as Administrator” opens the file in EmEditor instead of running it elevated. When you disable the context menu, everything works properly.

    #8154

    George Schizas
    Participant

    Extra info:

    Shift-Right clicking on a taskbar button that isn’t running and selecting “Run as Administrator” is the same as Ctrl-Shift clicking on that entry.

    #8155

    Yutaka Emura
    Keymaster

    I reproduced this issue. It will be fixed in the next minor version. I am very sorry about this bug.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone