Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #7021

    shx
    Participant

    Thanks for a great product.

    I am confused about Ctags and symbol lists. Is this something that works only in “c”

    Is there a way of defining them for the language I am using?

    Thanks

    Steven

    #7023

    Yutaka Emura
    Keymaster

    shx wrote:
    Thanks for a great product.

    I am confused about Ctags and symbol lists. Is this something that works only in “c”

    Is there a way of defining them for the language I am using?

    Thanks

    Steven

    Not only “C”. Please see Ctags website http://ctags.sourceforge.net/ for information about the supported file list and available options.
    On version 8.0x, EmEditor Projects plug-in uses the following command line to pass to ctags.exe.

    useroption -n –fields=fKs -f tagfile -L filelist

    useroption can be defined by a user in the Projects plug-in (Properties for Current Solution Template > Symbols > Additional Parameters to Ctags). Both tagfile and filelist are temporary files the plug-in creates.

    #7024

    shx
    Participant

    Yutaka wrote:
    useroption can be defined by a user in the Projects plug-in (Properties for Current Solution Template > Symbols > Additional Parameters to Ctags). Both tagfile and filelist are temporary files the plug-in creates.

    Can you give an example of what would be in “Properties for Current Solution Template > Symbols > Additional Parameters to Ctags” to make ctags of everything surrounded by brackets, [….]

    Steven

    #7035

    shx
    Participant

    Any sample of what should be in “useroption ” would be appreciated.

    #7039

    shx
    Participant

    Where i am now up to,
    I created a ctags.cnf file as show below

    –langdef=neo –langmap=neo:.pub –regex-neo=/^.*([.*]).*/1/f, function/

    and when i run ctags.exe it generates this, which looks fine,

    !_TAG_FILE_FORMAT 2 /extended format; –format=1 will not append ;” to lines/ !_TAG_FILE_SORTED 1 /0=unsorted, 1=sorted, 2=foldcase/ !_TAG_PROGRAM_AUTHOR Darren Hiebert /dhiebert@users.sourceforge.net/ !_TAG_PROGRAM_NAME Exuberant Ctags // !_TAG_PROGRAM_URL http://ctags.sourceforge.net /official site/ !_TAG_PROGRAM_VERSION 5.7 // [#34] NeoStartup.pub /^ SetVar “[`]” “[#34]”$/;” f [#34] NeoSubroutine.pub /^.SetVar “[EmlToImport]” “[#34]c:x[HeaderSelected].eml[#34]”$/;” f [#34] NeoSubroutine.pub /^nz_ScriptControl_AddCode “oMsg.ImportFile([#34][emlToImport][#34] )”$/;” f [AttachmentID] NeoSubroutine.pub /^ nz_ScriptControl_Result “oMsg.GetContentID([V])” “[AttachmentID]”$/;” f [AttachmentType] NeoSubroutine.pub /^ If “[AttachmentType]” “=” “Video/Avi”$/;” f [AttachmentType] NeoSubroutine.pub /^ nz_ScriptControl_Result “oMsg.GetContentType([V])” “[AttachmentType]”$/;” f [AttachmentType] NeoSubroutine.pub /^. If “[AttachmentType]” “=” “Image/jpeg”$/;” f

    And when I go into the projects plug-in it says it is generating symbols,

    However no symbols appear.

    I would appreciate some help with this.

    #7046

    Yutaka Emura
    Keymaster

    shx wrote:
    Any sample of what should be in “useroption ” would be appreciated.

    “useroptions” can be any combination of options listed in http://ctags.sourceforge.net/ctags.html
    I am sorry I don’t currently suppoort new languages, but if many users prefer, I will look into this issue in future versions. Thanks!

    #7053

    shx
    Participant

    I have gotten the command line runnig of ctags.exe working based on what emeditor is sending. However, the useroption has to be at end of the line.

    This worked.

    “C:Program FilesEmEditorPlugInsctags.exe” -n –fields=fKs -f c:xtags.txt -L C:xfilelist.txt –langdef=neo –langmap=neo:.pub –regex-neo=/^.*([.*]).*/1/f, function/

    This didn’t.

    “C:Program FilesEmEditorPlugInsctags.exe” –langdef=neo –langmap=neo:.pub –regex-neo=/^.*([.*]).*/1/f, function/ -n –fields=fKs -f c:xtags.txt -L C:xfilelist.txt

    The only difference is that I put the useroptions at the end of the line.
    —–
    Update
    O.K. I solved the problem. I needed to surround the regex expression with quotes. Now it works 😀 😀 😀

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone