Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #6273

    Nufacik
    Member

    Hi all.

    Sorry for thit question, but I have ona problem.
    I like to setup SQL syntax for writing keywords as uppercase. I mean, if I write select, after space EmEditor change word select -> SELECT.
    I want this for every keywords…
    Haw can I set up SQL syntax to working like this ???
    Thank… (I am new in EmEditor (just 30 minutes), I like it)…

    Nuf.

    #6279

    Yutaka Emura
    Keymaster

    Nufacik wrote:
    Hi all.

    Sorry for thit question, but I have ona problem.
    I like to setup SQL syntax for writing keywords as uppercase. I mean, if I write select, after space EmEditor change word select -> SELECT.
    I want this for every keywords…
    Haw can I set up SQL syntax to working like this ???
    Thank… (I am new in EmEditor (just 30 minutes), I like it)…

    Nuf.

    This is similar to my post here:
    http://www.emeditor.com/modules/newbb/viewtopic.php?topic_id=846&post_id=2503&order=0&viewmode=flat&pid=2497&forum=12#forumpost2503

    Check your SQL configuration properties > Highlight (1) tab.

    #6285

    Nufacik
    Member

    Hi Yutaka.

    Of course, I have already setuped all keywords in Highlight (1) tab as uppercase. But, this working only if I write keyword, EmEditor show me autocomplete dialogbox with posibilitie words, I choose one and push enter. If I do this, keyword is changed tu uppercase. But this not working, if I write select, push space to continueing… dialog box will close, keyword select is still select and not SELECT. Is impossible confirming every word in autocomplete dialogbox… existing any others possibilities ??? May be this feature added in future. You can add this possibilitie into tab Highlight – where can user define keywords as underline, italic, bold – you can add UPPERCASE. EmEditor will change all keywords with this option tu uppercase.
    What are you thinking about it?

    Nuf

    #6293

    Yutaka Emura
    Keymaster

    Nufacik wrote:
    Hi Yutaka.

    Of course, I have already setuped all keywords in Highlight (1) tab as uppercase. But, this working only if I write keyword, EmEditor show me autocomplete dialogbox with posibilitie words, I choose one and push enter. If I do this, keyword is changed tu uppercase. But this not working, if I write select, push space to continueing… dialog box will close, keyword select is still select and not SELECT. Is impossible confirming every word in autocomplete dialogbox… existing any others possibilities ??? May be this feature added in future. You can add this possibilitie into tab Highlight – where can user define keywords as underline, italic, bold – you can add UPPERCASE. EmEditor will change all keywords with this option tu uppercase.
    What are you thinking about it?

    Nuf

    I am not exactly sure if I understand your questions, but do you want EmEditor to select “SELECT” when you type “select” and without pressing ENTER key? If you press ENTER after you type “select”, SELECT will be selected from the list.

    #6302

    Nufacik
    Member

    Hi Yutaka.

    Sorry if you dont understand me, may be it is becouse of my english… So, I try explain my question one more time and I will be more detailed. So, I want to use EmEditor for programming SQL codes (Oracle PLSQL). In this syntax people used to write keyword as uppercase. Like this example:
    PROCEDURE showtime
    IS
    CURSOR curTab
    IS
    SELECT table_name
    FROM user_table;
    nCounter NUMBER(6);
    BEGIN
    FOR recTab IN curTab LOOP
    DBMS_OUTPUT.PUT_LINE(TO_CHAR(nCounter) || ‘ – table: ‘ || recTab.table_name);
    END LOOP;
    END;

    So, as can you see, keyword is putted as UPPERCASE words. And here is my question…
    How can I setup EmEditor for this functionality… I can switch on WordCoplete. OK… if I write keyword “begin”, word complete show me little dialog vith this words, which is in dialog as “BEGIN”. My cursor is still on end of the worg “begin”, in dialog is highlited word “BEGIN”. A can do 2 things.
    1. I push enter. EmEditor aplicate word from dialog and transform word “begin” to “BEGIN”. This is nice, its OK. I can write next code… But, I must entered every keyword, if I want have keyword as uppercase.
    2. I push space. EmEditor close word complete dialog, space is addet next “begin” and I continueing in progrmming.

    And I want to this:
    I starting write “begin”… EmEditor show wordcomplete dialog to hinting pissibilities… If I dont choose noone, nothing happen. BUT, if I push space, EmEditr automaticaly transform “begin” to “BEGIN”. Because I have turn on checkbox To UpperCase in Highlight(1) option. Is is like after every keyword highlight this word and manualy change to uppercase function… What are you thinking about this functionality. It will be posiible add this to highlight option of SQL syntax???

    I pray for this in EmEditor… 😀

    #6335

    Yutaka Emura
    Keymaster

    Nufacik wrote:
    Hi Yutaka.

    Sorry if you dont understand me, may be it is becouse of my english… So, I try explain my question one more time and I will be more detailed. So, I want to use EmEditor for programming SQL codes (Oracle PLSQL). In this syntax people used to write keyword as uppercase. Like this example:
    PROCEDURE showtime
    IS
    CURSOR curTab
    IS
    SELECT table_name
    FROM user_table;
    nCounter NUMBER(6);
    BEGIN
    FOR recTab IN curTab LOOP
    DBMS_OUTPUT.PUT_LINE(TO_CHAR(nCounter) || ‘ – table: ‘ || recTab.table_name);
    END LOOP;
    END;

    So, as can you see, keyword is putted as UPPERCASE words. And here is my question…
    How can I setup EmEditor for this functionality… I can switch on WordCoplete. OK… if I write keyword “begin”, word complete show me little dialog vith this words, which is in dialog as “BEGIN”. My cursor is still on end of the worg “begin”, in dialog is highlited word “BEGIN”. A can do 2 things.
    1. I push enter. EmEditor aplicate word from dialog and transform word “begin” to “BEGIN”. This is nice, its OK. I can write next code… But, I must entered every keyword, if I want have keyword as uppercase.
    2. I push space. EmEditor close word complete dialog, space is addet next “begin” and I continueing in progrmming.

    And I want to this:
    I starting write “begin”… EmEditor show wordcomplete dialog to hinting pissibilities… If I dont choose noone, nothing happen. BUT, if I push space, EmEditr automaticaly transform “begin” to “BEGIN”. Because I have turn on checkbox To UpperCase in Highlight(1) option. Is is like after every keyword highlight this word and manualy change to uppercase function… What are you thinking about this functionality. It will be posiible add this to highlight option of SQL syntax???

    I pray for this in EmEditor… 😀

    I am sorry it took a long time before I can finally answer to your question. If you want the SPACE key to behave just like ENTER key, go to Word Complete Properties (Right-click on the Word Complete button on the Plug-ins toolbar), select SQL and double-click, click Keyboard tab, and select Complete in Commands drop-down list, and press SPACE in the Press New Shortcut Key. I hope this helps.

    #6346

    Nufacik
    Member

    Hi Yutaka.

    Your advice looks as the right solutions, but have 1 issue…
    If I write keyword, I press SPACE to complete word and selection from dialog. Aftewr this, keyword will change tu uppercase. Its fine, but I’m still on edn of the word. So I have tu pust one mor time space to move cursor about one char next… So, If I do this, aj write word and must pust 2 times space to continueing writing… this is only one “bug”… otherwise its look fine…

    #6354

    Yutaka Emura
    Keymaster

    Nufacik wrote:
    Hi Yutaka.

    Your advice looks as the right solutions, but have 1 issue…
    If I write keyword, I press SPACE to complete word and selection from dialog. Aftewr this, keyword will change tu uppercase. Its fine, but I’m still on edn of the word. So I have tu pust one mor time space to move cursor about one char next… So, If I do this, aj write word and must pust 2 times space to continueing writing… this is only one “bug”… otherwise its look fine…

    You are right. But I don’t think there are ways to work arund this now. I might think about adding this feature in future versions. Thanks!

    #6359

    Nufacik
    Member

    Great.
    Thanks…
    In what version? I have been vaiting with my free trial version 🙂

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone