Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #9830

    CaptainFlint
    Participant

    OS WinXP SP3, EmEditor 11.0.2.

    My system drive is D:. Sometimes I discover that a new directory named Emurasoft appears in the root of this disk. Inside it only one empty directory is present, the full path is
    D:EmurasoftEmEditorWorkspace

    Unfortunately, I cannot find out at what moment it is created. I tried restarting EmEditor, closing tray icon, reopening EE again, saving and restoring workspace (since the directory name suggests that it has something to do with workspaces), but all in vain, the directory does not appear, and the workspace is saved and restored correctly, using “Local SettingsApplication DataEmurasoft” directory in my profile. Of course, I don’t monitor the root of the drive constantly, but after some time I navigate there for something or other, and – bump! – “Emurasoft” is sitting there again.

    I think I’m going to write a simple monitoring program that will look for appearance of this directory for me and notify with messagebox, but before that I decided to write here and ask, maybe, you have any idea how this could happen?

    #9831

    Stefan
    Participant

    Hi.

    Same OS here and portable EmEditor version with ini instead of registry.

    I never have seen such folder in the root.
    That folder belongs to your \%AppData\% folder in your profil folder.
    For me (as portable) i have an AppData folder in my EmEditor folder.

    For an test:
    what path do you get if you type \%appdata\% in the address bar of TC?

    Because you mentioned D as system drive you should see something like
    “D:Documents and SettingsFlintApplication Data”
    but in your language

    and there should be the subfolder “EmurasoftEmEditorWorkspace”

    .

    #9832

    CaptainFlint
    Participant

    As I wrote, the AppData directory and EE workspace location are absolutely correct and always working. \%APPDATA\% points to “D:Documents and SettingsApplication Data”, EmEditor workspace storage is located in “D:Documents and SettingsLocal SettingsApplication DataEmurasoftEmEditorWorkspace”, it is saved when I call Save Workspace, and restored when I call Restore Workspace command.

    But sometimes, for unknown reason and unknown purpose, at some unknown moment of time in the drive root an empty “D:EmurasoftEmEditorWorkspace” directory suddenly appears. I can remove it, then work for several days or even weeks without appearing of this directory, even though I use various EE functions (including saving/restoring workspaces and files). But some day it appears again.

    #9833

    Yutaka Emura
    Keymaster

    Hi Flint,

    Are you using INI settings (portable) or the Registry?

    #9834

    CaptainFlint
    Participant

    Registry.

    #9835

    CaptainFlint
    Participant

    OK, I wrote a program for watching for the directory, and today found out what the problem was. The directory appears when I run git commit command, which I customized to use a separate EmEditor instance (with /sp argument) as commit message editor.

    I compared environment variables of this instance of EmEditor with variables of EmEditor started normally (using Process Explorer), and saw that APPDATA path is invalid in the instance started by git. The problem is, my Windows account name is cyrillic, and when I start git it changes the current codepage or something like that, and cyrillic name in the path becomes gibberish.

    So, probably, there is nothing EmEditor can do about it. 🙁


    OK, I just wrote a simple wrapper that changes all the environment variables to their appropriate values and then starts EmEditor, and customized git to use this wrapper. So far seems to work fine, without creating the D:Emurasotf directory. 🙂

    BTW, it’s not APPDATA that caused this problem but USERPROFILE variable.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone