Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #20108

    JohnQSmith
    Participant

    EmEditor 15.1.2 64 bit

    I have a large file (~130MB) of pipe delimited data (link to obfuscated data compressed to ~10MB for faster download). I want to delete all lines that have the text “ABCD00000” in one of the data fields (running in text mode, not CSV mode since I don’t need columnar view, just straight text editing). To do this, I did a search and replace using the following regex…

    Find: ^.*ABCD00000.*\n
    Replace with: [nothing]

    After noticing it was taking longer than I expected, I cancelled the operation. At this point, clicking anywhere in the text edit window causes corruption and the file must be closed and reopened to be usable again. I can post a demo video if that helps. Tried on two different computers; one running EmEd from my USB stick using .ini files, the other using an install for everyone installation.

    BTW… Cygwin64’s sed completed in a little over 1 second on my computer.

    $ time sed -e "/ABCD00000/ d" data.csv > out.txt
    
    real    0m1.147s
    user    0m1.046s
    sys     0m0.030s
    #20129

    Yutaka Emura
    Keymaster

    Hello JohnQSmith,

    I reproduced the issue, and I will look into the issue.

    For this task, you might want to use the Filter toolbar.

    You can enter “ABCD00000” with the “Negative” button pressed. After filtered, press the “Extract All” to get all lines without “ABCD00000”.

    Thanks,

    #20158

    JohnQSmith
    Participant

    Hi Yutaka,

    The filter is MUCH more powerful than I had originally thought. I had used it before to isolate lines of a log file, but had not noticed the “negative” option. EmEditor is becoming more and more my go-to tool.

    JohnQSmith

    #20176

    Yutaka Emura
    Keymaster

    Hello JohnQSmith,

    This issue was fixed on v15.1.4.

    Thank you!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.