Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #22327

    sky
    Participant

    Problem 1:
    “Allow newlines in double quotes” check box is enable. (Default setting)
    Type a Double quotation mark ” at the last column, it will be garbled.
    No matter if Cell Selection Mode or non-Cell Selection Mode in CSV & DSV Mode.
    If disable “Allow newlines in double quotes”, it will be OK.
    And if type ” at the other column, it is OK.

    Problem 2
    “Allow delimiters in double quotes” check box is enable. (Default setting)
    Type a Double quotation mark ” at the Cell Toolbar in any column, one Double quotation mark will become two.
    If disable “Allow delimiters in double quotes”, it will be OK.

    TSV (Tab-separated) mode is OK for above two problems.

    Example:

    a,b,c,
    d,e,f,

    CSV

    #22351

    Yutaka Emura
    Keymaster

    The Problem 1 will be fixed on the next version.

    The Problem 2 is actually NOT a bug, but it is how EmEditor works.
    When you enter a string in the Cell toolbar, EmEditor automatically converts the string according to the CSV rule described in:

    https://en.wikipedia.org/wiki/Comma-separated_values

    I hope this helps.

    Thanks,

    #22352

    sky
    Participant

    Thanks for your explain.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone