Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #11280

    Just
    Participant

    Hi All,

    I’m using the EmEditor to edit the Linux files (Linux drives are mapped to Windows). Each time I’m saving the edited file, its mode is being changed to the ‘executable’ one…
    So, I would not like the EmEditor will change the files mode @Linux. What settings should I do in order to change this behavior of the EmEditor?

    Thank you!

    #11282

    Yutaka Emura
    Keymaster

    Hi,

    I am not sure what you mean by ‘executable”. Can you explain more? If you use backup settings in the Configuration Properties, maybe you might want to disable the backup, and see if this can help.

    Thanks!

    #11296

    Just
    Participant

    Okay, as for the Unix/Linux files, they have the readable/writable/executable attributes. Files or example, when I do a listing of the files, I can see these attribute:
    So, when I map a linux drive to windows and use EmEditor to edit the files, after I save the files they become ‘executable’ (see the examples below):

    BEFORE ‘SAVE’ command in EmEditor:
    \%> ls -al
    -rw-r–r– file1.txt
    -rw-r–r– file2.txt
    where ‘r’ is for ‘readable’
    where ‘w’ is for ‘writable’

    AFTER ‘SAVE’ command in EmEditor:
    \%> ls -al
    -rwxr–r– file1.txt
    -rwxr–r– file2.txt
    where ‘x’ is for ‘executable’

    So, I’d like the EmEditor WILL NOT CHANGE ATTRIBUTES of the files.

    Hopefully you caught my point…

    Thank you

    #11297

    Just
    Participant

    BTW, I tried to disable the ‘BackUp’ option in the ‘Configuration Properties’ – it doesn’t help.

    #11298

    CaptainFlint
    Participant

    I don’t think the Windows side can do anything about it, the SMB protocol does not contain any information about UNIX-style attributes.

    Check your Samba settings for the share you’re using and set the create mask option to 0644 (or whatever you like).

    #11299

    Just
    Participant

    “Check your Samba settings for the share you’re using and set the create mask option to 0644 (or whatever you like)” – how can I do so?

    #11300

    CaptainFlint
    Participant

    Somewhere in system settings, their names and locations are different in different Linux distributions.

    You could try direct editing of /etc/samba/smb.conf (root permissions are required). There you find a section named like your share name (e.g. if in Windows you disk is mapped to machine_nameMyShare, then you look for the section [MyShare] in smb.conf). Within this section, if there is create mask option already, just modify its value to 0644. Otherwise append a new line with this option:

    create mask = 0644

    (space within “create mask” is not a typo!). Save the file and restart the Samba service. The way to do it, again, depends on your Linux system, I’d try the command

    /etc/init.d/samba restart

    (again, with root permissions), or simply reboot the machine.

    #11301

    Just
    Participant

    okay, thank you, but I don’t have ROOT/ADMIN rights to change these files …

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.