Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #8626

    Yutaka Emura
    Keymaster

    EmEditor Professional v10 RC 18 (9.90.27) is available for download.

    Updates from RC 17 include:

    – bug fixes

    For details of other new features and screenshots of EmEditor Professional 10, please see:
    http://www.emeditor.com/modules/feature1/rewrite/tc_36.html

    Please download:
    http://www.emeditor.com/pub/updates/emed32_9.90.27.exe (32-bit, v10 key required)
    http://www.emeditor.com/pub/updates/emed64_9.90.27.exe (64-bit, v10 key required)
    http://www.emeditor.com/pub/updates/emed32_9.90.27_trial.exe (32-bit, trial, no key required)

    It is recommended that you uninstall previous v9 before you install a new version.

    This RC version requires you to enter a registration key for v10 except for the trial version. Please go to Emurasoft Customer Center https://www.emurasoft.com/support/ , and go to Purchase History to request a new registration key for v10.

    This version expires on July 31, 2010. Before this date, you will need to update to then newer version, or purchase the release version.

    Supported OS: Windows 7/Vista/XP/2000 SP4/Server 2008/Server 2003

    The portable version can be produced from the Import/Export wizard on the Tools menu after you use the installer. However, the portable version runs slower than the one using the Registry.

    Please don’t hesitate to write any comments or bug reports in this forum.

    Thank you for trying EmEditor RC versions!

    #8628

    owilsky
    Participant

    Is it possible in Hex view to also edit in the right ascii column? That would be really fine and then I’d never need a hex editor again 😉

    #8631

    Yutaka Emura
    Keymaster

    Hello owilsky,

    Currently, it is not possible to edit the right ascii column. I might consider that in future versions. Thanks for your inputs!

    Please let me know if you have further questions or comments.
    Thank you,

    #8634

    pfletch101
    Member

    There appears to be a problem with the file association functionality in (at least) the 64 bit edition of the current RC under Windows 7. I have only just downloaded and installed the beta/RC, so I do not know whether the issue is new or just previously unreported.
    After installing the program and opening (e.g.) a php file, I go to Tools|Properties for Current configuration. The tab that opens gives “Associated Extensions” as PHP and PHP3. However, clicking on files with these extensions in Explorer does not open them in EmEditor. Returning to the same tab in EmEditor and pressing the ‘Associate with EmEditor’ button pops up a UAC dialog, to which I respond appropriately, and I then see a new dialog box, showing only a txt association. Deleting this and adding appropriate php associations still does not affect Explorer’s behavior.
    Even more strangely, Windows own File Association manager will not allow me to add the necessary associations. EmEditor is not shown as an option in the normal dialog (even by expanding ‘Other Programs”) and navigating the dialog to the program folder and ‘Opening’ EmEditor.exe neither associates it nor adds EmEditor to the available options.
    Help!!

    #8643

    Yutaka Emura
    Keymaster

    Hello pfletch101,

    Thank you for trying out EmEditor Professional RC.

    The Association tab of configuration properties associate file types to EmEditor configurations, but it won’t associate file extensions from Explorer. If you want to associate the file extensions from Explorer, you will need to associate in the Associate with EmEditor dialog box, which you already tried.

    I don’t know why your change didn’t affect Explorer’s behavior. I don’t know why Windows own File Association manager will not allow you to change associations either. I will do more research. Meanwhile, do you use an Administrative account on Windows 7? Do you have any system policy that might prohibit changing file associations? Any hints might help.

    Thank you!

    #8668

    pfletch101
    Member

    I do use an account with full privileges and I do not have any relevant system policies.

    FWIW, I returned to the fray today, and found that EmEditor had appeared as a possible “recommended” option in Windows Association Manager, but only for a couple of php? extensions (php2, php3, ….). When I tried to use the Windows Association Manager to associate .bat files (which don’t have a default association under W7) with EmEditor, however, I saw the same behavior I described before. EmEditor did not appear on the list of options (“preferred” or “other”), and browsing to the executable within the dialog and “Opening” it did not establish the association. I am a long-time EmEditor user, and I have not had this sort of problem with prior versions (<= 9.x).

    Later….The problem with not being able to associate file types within EmEditor goes away if you “run it as administrator”, which does actually make sense, and may have been true before, but it would be nice if EmEditor warned you about that if you try to do it when running it as a regular user, rather than just failing silently. The problem doing it with Windows Association Manager persists.

    I am using the latest RC, BTW.

    #8669

    Yutaka Emura
    Keymaster

    Hi,

    Thanks for your comments.

    Would you please use our last RC – RC 23 (9.90.32).
    You can download at http://www.emeditor.com/modules/newbb/viewtopic.php?topic_id=1528&forum=12&post_id=4919#forumpost4919

    There are some registry changes between your version and this newest version, so there might be some improvements. If this doesn’t work, I will work on your registry settings to get it work.

    Thank you,

    #8670

    pfletch101
    Member

    The most recent results I reported were using RC 23.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone