Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #5796

    LTT
    Participant

    It seems the “Export all settings into ini files” action does not export ALL the settings. I found at least customized menus, recents, and macros were ignored.

    BTW, how can I restore the data from ini to registry? By removing the ini files during running?

    #5797

    Yutaka Emura
    Keymaster

    LTT wrote:
    It seems the “Export all settings into ini files” action does not export ALL the settings. I found at least customized menus, recents, and macros were ignored.

    BTW, how can I restore the data from ini to registry? By removing the ini files during running?

    Can you make sure INI files are used? You can check from the About dialog box on the Help menu.

    You cannot restore the data from Ini to registry at this time. I will add this feature in future versions. Thanks!

    #5810

    LTT
    Participant

    Yutaka wrote:
    Can you make sure INI files are used? You can check from the About dialog box on the Help menu.

    Yes.

    Details:
    I customized the three list menus: (each to a submenu)
    Recent Files
    Macros
    Fonts
    And I customized the trayicon menu.

    When using ini, Recent Files and Macros are missing. Fonts are retained. But all the three are no longer submenus.
    Trayicon menu turned to the default.
    Recent Folders and Insert list are also missing.

    In eeCommon.ini (when just exported and before running EmEditor):
    Only these keys are retained in [Macros] section:
    Events0=16
    Events1=0
    Events2=0
    Events3=0
    Events4=0
    Events5=0
    UsedEvents=0
    In [Recent File List] section, there are only Attr keys (unsorted). No File keys.

    #5814

    Yutaka Emura
    Keymaster

    LTT wrote:

    Yutaka wrote:
    Can you make sure INI files are used? You can check from the About dialog box on the Help menu.

    Yes.

    Details:
    I customized the three list menus: (each to a submenu)
    Recent Files
    Macros
    Fonts
    And I customized the trayicon menu.

    When using ini, Recent Files and Macros are missing. Fonts are retained. But all the three are no longer submenus.
    Trayicon menu turned to the default.
    Recent Folders and Insert list are also missing.

    In eeCommon.ini (when just exported and before running EmEditor):
    Only these keys are retained in [Macros] section:
    Events0=16
    Events1=0
    Events2=0
    Events3=0
    Events4=0
    Events5=0
    UsedEvents=0
    In [Recent File List] section, there are only Attr keys (unsorted). No File keys.

    Some entries in the Registry are not saved until you exit EmEditor. If Quick Start option is checked, you will need to exit the tray icon too. Please restart EmEditor and try Export again.

    #5823

    LTT
    Participant

    Yutaka wrote:
    Please restart EmEditor and try Export again.

    Yes, that was just what I did. I checked to ensure no process of EmEditor or Emedtray remained.

    One more thing I can report is that, in eeCommon.ini, these items also lost their Size data:
    MainMenu-Size
    TrayMenu*-Size
    UserMenu*-Size
    Attr*-Size

    #5826

    Yutaka Emura
    Keymaster

    LTT wrote:

    Yutaka wrote:
    Please restart EmEditor and try Export again.

    Yes, that was just what I did. I checked to ensure no process of EmEditor or Emedtray remained.

    One more thing I can report is that, in eeCommon.ini, these items also lost their Size data:
    MainMenu-Size
    TrayMenu*-Size
    UserMenu*-Size
    Attr*-Size

    *-Size values exist only in INI files, and not necessary in the Registry.

    I don’t know why you cannot import some other values to the Registry. I will try to reproduce your issue, and will let you know. Thanks!

    #5827

    LTT
    Participant

    Thanks!

    Yutaka wrote:

    LTT wrote:
    One more thing I can report is that, in eeCommon.ini, these items also lost their Size data:
    MainMenu-Size
    TrayMenu*-Size
    UserMenu*-Size
    Attr*-Size

    *-Size values exist only in INI files, and not necessary in the Registry.

    I mean, the *-Size values listed above cannot be found in my eeCommon.ini.

    #5828

    Yutaka Emura
    Keymaster

    Sorry for my misunderstanding. You are right. I will fix that by next version.

    #5833

    Yutaka Emura
    Keymaster

    This has been fixed on 7.00.9 RC1. Please see:

    http://www.emeditor.com/modules/newbb/viewtopic.php?viewmode=flat&topic_id=701&forum=12

    Please try and see if all the issue was fixed.
    Thank you.

    #5834

    LTT
    Participant

    Everything is OK now. (Only the “List of Recent Files to Insert” hasn’t been exported. But it’s unimportant.)
    Thank YOU!

    #5842

    Yutaka Emura
    Keymaster

    LTT wrote:
    Everything is OK now. (Only the “List of Recent Files to Insert” hasn’t been exported. But it’s unimportant.)
    Thank YOU!

    I will fix the “List of Recent Files to Insert”. Thanks!

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.