Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #5963

    ToadLoadin
    Member

    1. While Importing all personal settings from a Reg file, multi-toolbar seetings can not be retained, i.e. while backuped my previous Emeditor settings into a Reg file, which has more than one toolbar, importing this setting to a newly installed Emeditor only retain the appearance of the first toolbar, other toolbars I’ve customized previously just got disappeared, so I must recustomize them again. :-(

    2. Exporting & Importing color schemes can not retain the extact font style, all font styles become “Normal”, i.e. while in a color scheme some keyword highlights or URL/Email links have set to be bold or italic or underlined, exporting it into a eetheme file then importing that to another Emeditor installation, all the bold or italic or underlined font style got disappeared. :-(

    #5964

    Yutaka Emura
    Keymaster

    ToadLoadin wrote:
    1. While Importing all personal settings from a Reg file, multi-toolbar seetings can not be retained, i.e. while backuped my previous Emeditor settings into a Reg file, which has more than one toolbar, importing this setting to a newly installed Emeditor only retain the appearance of the first toolbar, other toolbars I’ve customized previously just got disappeared, so I must recustomize them again. :-(

    2. Exporting & Importing color schemes can not retain the extact font style, all font styles become “Normal”, i.e. while in a color scheme some keyword highlights or URL/Email links have set to be bold or italic or underlined, exporting it into a eetheme file then importing that to another Emeditor installation, all the bold or italic or underlined font style got disappeared. :-(

    1. Thanks for reporting the bug. I have fixed it by the next minor versions. Meanwhile, you can double click the .REG file before lauching EmEditor to import the new settings.

    2. I could not reproduce the problem. I think you will need to save the theme by selecting “Save” in the menu when you click “>” by the theme name so that, for instance, “EmEditor Classic (modified)” should be displayed as “EmEditor Classic”. Then if you click Export or Export All, the theme you have just modified and saved will be exported to a file. I know it is a little complicated and might need some improvement here.

    #5966

    ToadLoadin
    Member

    2. I could not reproduce the problem. I think you will need to save the theme by selecting “Save” in the menu when you click “>” by the theme name so that, for instance, “EmEditor Classic (modified)” should be displayed as “EmEditor Classic”. Then if you click Export or Export All, the theme you have just modified and saved will be exported to a file. I know it is a little complicated and might need some improvement here.

    I think I’ve reproduced the color scheme exporting and importing problem for several times before reporting. Could you check if importing the color scheme file I’m currently using can retain the font styles?
    My Color Scheme file: http://www.box.net/shared/dbr4183s4w
    Screen record of my operation (flash swf file): http://www.box.net/shared/ws81k9gboo

    #5967

    Yutaka Emura
    Keymaster

    You are right! I have reproduced this bug, and have already fixed it for the next minor version. Thanks!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.