Tagged: ,

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #20805

    LifeTimer
    Participant

    After a recent update of EmEditor (to 15.9.0), I just noticed that filtering of lines containing backslashes doesn’t seem to work anymore (at least not when performed from a macro)?

    I’m using the following macro to filter out lines from my documents:

    document.Filter(document.selection.Text, 0, eeFindKeepPrevious | eeFindNegative);

    If it would be of relevance, I have this macro bound to the shortcut ctrl+d, which is what I’m using to execute it.

    The following example line in a text document can be used as a bug PoC:

    abc\def\ghi

    If I select the part “ghi” from the line above and execute my macro above (by pressing its shortcut, as described above), the line is filtered-away, just as expected.

    But, if I (after bringing it back again from the previous test case, of course) select the part “def\ghi” from the line and execute my macro above, it does NOT disappear as expected. It simply stays visible. If I look in the advanced filter dialog box, a filter entry has been added though, as follows, but seemingly still doesn’t work for some reason:

    def\\ghi | Whole line | EN

    And finally, even stranger, if I select the entire line (i.e. “abc\def\ghi”) and execute the macro, the following happens:

    1. The line still does not disappear.
    2. The line turns orange (as if there was a marker defined for it, but there is no marker defined with that color in my editor).
    3. (even stranger) The line is marked as “edited” in the editor (i.e. a yellow indicator to the left of the line), which I really don’t understand why, since my macro only performs a filter operation!?
    4. An entry is still created in the filter (abd\\def\\ghi | Whole line | EN), but apparently still not working.

    One guess would be that these backslash related problems were introduced as a result of the fix you implemented for my previous bug report regarding filter lines containing TAB characters (https://www.emeditor.com/forums/topic/exported-filters-containing-tab-cannot-be-re-imported/)?

    #20809

    Yutaka Emura
    Keymaster

    Hello,

    I have reproduce the issue, and it will be fixed on the next beta version.

    Thanks!

    #20810

    LifeTimer
    Participant

    Great, thanks!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone