Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #10695

    BobBailey
    Participant

    In earlier versions, if I opened a new EmEditor window by double clicking the tray icon, the cursor focus would go to the new window in the 1,1 position. I could immediately start typing.

    Now,
    win 7
    64 bit
    v12.latest (today)
    …I have to move the cursor to the window, click, and then I can start typing. This may have begun earlier, I tend to drag my feet on these things.

    Is this a bug? …a feature? …a setting?

    I have searched a bit in this forum and in help and see nothing.

    (It is also true that a macro that used to position the cursor at the end of the file no longer does that. Related?)

    EmEditor continues to be a go to tool for me. I use it in so many different ways. Thanks.

    …Bob

    #10698

    Yutaka Emura
    Keymaster

    Hello BobBailey,

    I can’t reproduce the issue. Can you please export registry at HKEY_CURRENT_USERSoftwareEmSoftEmEditor v3, zip the .reg file and email me as an attachment (tech@emurasoft.com)?

    Thank you!

    #11022

    BobBailey
    Participant

    I just tried this with v13 beta and still no focus. I tried double clicking the tray icon to open a new window, tried double clicking a .txt file, and tried opening a file from the recent files list in the tray.

    All opened the file but none retained focus.

    fwiw… Bob

    #11024

    BobBailey
    Participant

    I also have a shortcut that runs at startup:
    “C:Program FilesEmEditorEmEditor.exe” D:BobBootLog.txt /mf “D:My MacrosAddTimestampLine.jsee”

    AddTimestampLine.jsee Macro:
    document.selection.EndOfDocument(false);
    document.selection.InsertDate(eeDateDateTime);
    document.selection.NewLine(1);
    document.selection.CharLeft(false,1);
    document.selection.Text=” “;
    document.ReadOnly=false;
    editor.ExecuteCommandByID(4099);

    This used to run, insert the line, set the cursor at the end of the last line of data, not the last line of the file, and leave the focus on the EmEditor window. It still adds the date/time stamp but the cursor is at the top and there is no focus.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.