Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #7245

    Klortho
    Participant

    Hi,
    This question is really driving me crazy, not because the information is particularly useful, but just because I *need to know*! Do you know what I mean?

    I have a file that has some very obscure unicode characters in it – from the “Yi Syllables” block. I also pasted some regular Chinese characters into it to. The amazing thing is that it seems to be displaying correctly. Here are the contents (I doubt they’ll show up correctly here):
    U+A000 ꀀ YI SYLLABLE IT
    你好你好
    ꀂꀃꀄ
    I checked with BabelMap, and the only font on my system that has the Yi Syllables is Microsoft Yi Baiti, and it doesn’t have any regular Chinese characters. So that means that at least two fonts are being used in the display of EmEditor at once. How does this work? It doesn’t seem to matter what “Font Category” or “Font” I select.

    I really would like to understand more about how these “Font” and “Font Category” options work, and how they interact with the display fonts, and how they depend on the actual characters in the file. Is there anywhere in the documentation or help files where this is written up in detail?

    Thanks!

    #7257

    Yutaka Emura
    Keymaster

    Klortho wrote:
    Hi,
    This question is really driving me crazy, not because the information is particularly useful, but just because I *need to know*! Do you know what I mean?

    I have a file that has some very obscure unicode characters in it – from the “Yi Syllables” block. I also pasted some regular Chinese characters into it to. The amazing thing is that it seems to be displaying correctly. Here are the contents (I doubt they’ll show up correctly here):
    U+A000 ꀀ YI SYLLABLE IT
    你好你好
    ꀂꀃꀄ
    I checked with BabelMap, and the only font on my system that has the Yi Syllables is Microsoft Yi Baiti, and it doesn’t have any regular Chinese characters. So that means that at least two fonts are being used in the display of EmEditor at once. How does this work? It doesn’t seem to matter what “Font Category” or “Font” I select.

    I really would like to understand more about how these “Font” and “Font Category” options work, and how they interact with the display fonts, and how they depend on the actual characters in the file. Is there anywhere in the documentation or help files where this is written up in detail?

    Thanks!

    It is Windows feature called Font-Link or something like that, and it is not the feature of EmEditor. You can find the information about font-linking in Windows related or Microsoft website. In order to find the exact code value of each character in EmEditor, press CTRL + I where the cursor is at the left side of the character you want to inspect.

    #7259

    Klortho
    Participant

    Okay, thanks!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone