Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #7592

    gning
    Participant

    Something in our office has been guilty of sneaking byte-order marks into text files that cannot tolerate them, and it looks a lot like EmEditor 8 is the guilty party. I thought I had found a setting that stopped it from doing that, but the problem has apparently recurred. What settings would be good if I want to make sure that text files written by EmEditor never get a byte-order mark inserted?

    #7593

    Yutaka Emura
    Keymaster

    gning wrote:
    Something in our office has been guilty of sneaking byte-order marks into text files that cannot tolerate them, and it looks a lot like EmEditor 8 is the guilty party. I thought I had found a setting that stopped it from doing that, but the problem has apparently recurred. What settings would be good if I want to make sure that text files written by EmEditor never get a byte-order mark inserted?

    If you don’t change encoding when you save as a file, there should be no problem at all. If you need to change encoding when you a file, you should select UTF-8 without BOM. I don’t if there is a good way to prevent from selecting UTF-8 with BOM.

    #7594

    gning
    Participant

    Thank you.

    I think I’d better find or make a utility to scan files for BOMs.

    I think the problem happens when it loads files that contain only ASCII-7 and interprets them as UTF-8. I think one thing I can probably do that will help is to change the “opening encoding” for the configuration that these files get loaded with (which is “SQL”). I’ll change it from “system default” to “western european”. Will that prevent it from seeing ascii-7 as utf-8?

    #7606

    Yutaka Emura
    Keymaster

    gning wrote:
    Thank you.

    I think I’d better find or make a utility to scan files for BOMs.

    I think the problem happens when it loads files that contain only ASCII-7 and interprets them as UTF-8. I think one thing I can probably do that will help is to change the “opening encoding” for the configuration that these files get loaded with (which is “SQL”). I’ll change it from “system default” to “western european”. Will that prevent it from seeing ascii-7 as utf-8?

    If you always want to open in Western European, you might want to uncheck “Detect UTF-8” in the Configuration Properties > File tab. This should be enough to prevent from BOM being added. I hope this helps.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone