Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #5987

    jackrabbit
    Member

    Hi all,

    I created a new configuration. In the new configuration, the parenthesis matching does not work. If I move my mouse to the close parenthesis, it does not highlight the starting parenthesis.

    How to set it up?

    Thanks.

    #5988

    CaptainFlint
    Participant

    You should move not the mouse, but the text cursor to the parenthesis to highlight it.

    #5989

    jackrabbit
    Member

    Sorry, I mean move mouse cursor. It still does not work. i guess it should be set somewhere.

    #5990

    CaptainFlint
    Participant

    Highlighting by hovering the parenthesis with mouse is not implemented, as far as I know.

    #5991

    jackrabbit
    Member

    Sorry, I did not mean highlight when mouse hover the parenthesis. I am moving the cursor by keyboard. But it still does not highlight the matching parenthesis. Note this is in a new configuration. In the pre-defined configurations, it works.

    #5992

    CaptainFlint
    Participant

    In this case, I suppose, you just forgot to set specific coloring/font for parenthesis highlighting. See the Configuration -> Display tab.

    #5993

    jackrabbit
    Member

    Thanks for your suggestion. I compared my setting with an existing configuration setting. They are the same. The item I checked is “Matched parentheses/brackets”. My setting for Text color and Background color is default, the style is Bold. Searching Color is 1. This is the same as the C++ configuration setting. However, the parentheses matching works in C++ configuration, but not my newly created configuration. :-?

    #5994

    Yutaka Emura
    Keymaster

    Also check “Highlight Matching Parentheses/Brackets” in the Hightlight(2) tab of configuration properties.

    #5998

    jackrabbit
    Member

    You solved the problem. Thank you guys.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.