Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #11121

    David
    Participant

    Dear Friend,

    When using Emeditor, I often read some articles in English. However, some sentences included in the documents are German. These sentences exist at different positions of the documents.

    Currently, I have to copy these German sentences to Google translate manually. It’s not so convenient.

    So, I want to know if you have a plug-in for Emeditor: When choosing a sentence or a word and right click, the context menu display and a menu item called “Google translate” is at the menu. Once click this menu item, the expected language,for example English, is appeared in a dialog box(pop up a dialog box for displaying target language from Google).

    If there’s a setting for choosing source and target language, it will be better. I’m not so strong to create a macro or plug-in, so ,wish your help. Thanks a lot!

    Best regards!

    #11122

    Yutaka Emura
    Keymaster

    Hello David,

    You can create an external tool. Please go to the Tools menu, External Tools, Customize Tools, click “New” button, enter a name in the title, and then enter:

    http://translate.google.com/#auto/en/$(CurText)

    in the Command field. “en” means English, and you can replace it with another language name if your destination language is not English.

    Thanks!

    #11126

    David
    Participant

    Thank you,Yutaka-san.

    But it looks it doesn’t work on my computer.I change your command line to the following:

    http://translate.google.com/?&ie=UTF-8&sl=de#de/en/$(CurText)

    This command line can work while copying into internet explorer. But in Emeditor, it says:
    System can not find the specified file.

    May I trouble you again?

    #11128

    Yutaka Emura
    Keymaster

    Hello,

    Can you please make sure “http” protocol is associated with the Internet browser you use?

    I suggest you go to Default Programs in the Start menu, and set your default internet browser.

    Thanks,

    #11129

    David
    Participant

    Hello,Yutaka-san,

    If I deactivate option”use output bar”, then the command line works very well(it will open internet explorer and locate Google translate website automatically).
    If I activate this option. Then I get error.

    This option is available only if the Command field include .exe files?

    #11130

    Yutaka Emura
    Keymaster

    Hi David,

    Yes, that’s correct.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.