Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #7265

    Mike
    Member

    It doesn’t work unless the normal version is installed. I uninstalled the normal none portable version and the portable could not run any java script. I reinstalled the normal version and the javascript vorked. I tried this twice, same result.

    EmEditor 8.05 and Vista SP2, v.113 was used.

    #7268

    Yutaka Emura
    Keymaster

    Mike wrote:
    It doesn’t work unless the normal version is installed. I uninstalled the normal none portable version and the portable could not run any java script. I reinstalled the normal version and the javascript vorked. I tried this twice, same result.

    EmEditor 8.05 and Vista SP2, v.113 was used.

    I tesetd EmEditor portable version 8.05 on Vista SP1 (32-bit), but there was no problem. Do you have a limited account? Are there any security settings turned on or any anti-virus program running on your machine?

    #7269

    Mike
    Member

    No virus or other extra security layer.
    My vista might need a reinstall though.
    I can reproduce it now with the none portable version installed.
    The portable tries to find the EEMacro.tlb file through the registry first.
    And if that failes it cant run the .js file, even if it load the macro file from the portables directory.
    If I rename the key below it failes to run the script.
    HKEY_CLASSES_ROOTTypeLib{EEC66535-61A2-43A8-B34F-7A2863014D5E}
    And the data is in “/1.0/0/win32” = “C:Program FilesEmEditorEEMacro.tlb”

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone