Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #22954

    Pangius
    Participant

    Procedure to make Lines Displayed changes when Converting between “Wrap by Window” to “No Wrap”:
    1. Open a *.TXT File (Manually Select “Wrap by Window Width”).
    2. Open a *.CSV File (Automatically Selects “No Wrap”).
    3. The *.TXT Document Lines Displayed will have Changed based off the Number of Wrapped Lines above the First Line Originally Displayed.

    The problem is when you Open a *.CSV File, EmEditor always Defaults to No Wrap. If you have Tick “Synchronize Wrap Mode” (“Tools” Drop-down Menu => Customize => “View” Tab => Tick “Synchronize Wrap Mode”) any *.TXT Documents set to “Wrap by Window Width” will be changed to “No Wrap”. Then a Bug in EmEditor shifts the Displayed Lines in the *.TXT File down by however many Line Wraps there were Above the Top Row shown in the EmEditor Window before the *.CSV File was Opened (Wrapped Lines Below the Top Row have no effect).

    Hence this Bug doesn’t happen if:
    * You have No Line Wraps in the *.TXT Document Above the Top Row shown in the EmEditor Window before the *.CSV File was Opened.
    * The Top Line in the *.TXT Document was Line 1.

    The Cursor Position stays the Same in the *.TXT Document before & after the *.CSV File is opened. Its just the Lines shown in the EmEditor Window changes.

    This is an example of the Lines Displayed Shift on a 1000 Line Text Document with 1 Line Wrap on each Line:
    Top Line in *.TXT Before *.CSV Opened: Top Line in *.TXT After *.CSV Opened:
    50 99
    100 199
    150 299
    200 399
    250 499
    300 599

    This Bug happens wheather you have “Line and Column Display as” either “Display Coordinates”, “Logical Coord. (Full-width Char. as 2 Col)”, “Logical Coord. (Full-width Char. as 1 Col)”, “Logical w/Tab (Full-width Char. as 1 Col)”.

    The only work around to this Bug I’ve found is: “Tools” Drop-down Menu => Customize => “View” Tab => Untick “Synchronize Wrap Mode”.

    This was Tested in EmEditor 17.5, however it has been around for a long time.

    #22958

    Yutaka Emura
    Keymaster

    Hello,

    I am not sure exactly what the issue is, so can you please send me a screencast or screenshot to tech @ emurasoft.com? You can also send me sample files (after zipped) with steps to reproduce the issue.

    Thanks,

    #23043

    sky
    Participant

    Try to reproduce one of the issues as below:
    Step 1. Open test.txt, and set to “Wrap by Window”.
    1

    Step 2. Open test.csv.
    2

    Step 3. Back to “test.txt” tab, it became to “No Wrap”. => Problem here.
    3

    Step 4. Set to “Wrap by Window” again.

    Step 5. Switch to “test.csv” tab

    Step 6. Back to “test.txt” tab again, it is keep as “Wrap by Window”. => OK

    #23044

    Yutaka Emura
    Keymaster

    Thanks for explanation.
    This is the specs. To work around, as you already know, please go to the View page of the Customize dialog box, and clear the “Synchronize Wrap Mode”.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.