Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #9360

    emuser1
    Member

    I created this macro:

    document.selection.Text=”test”
    document.selection.SelectAll
    document.selection.Copy eeCopyUnicode
    document.selection.EndOfLine false,eeLineView
    document.selection.NewLine 1
    document.selection.Paste eeCopyUnicode

    then I save with test.vbs or vbsee or js. then I open back the ‘test.vbs’ macro and run. found the error ‘object required document’. but i already open a ‘file’.

    Also, I tested on examples emeditor.(template.js), when I used this macro, also has a error ‘object required wscript’

    ‘ VBScript sample using Windows Script Host

    Set WshShell = WScript.CreateObject(“WScript.Shell”)
    WshShell.Popup “Hello World!”

    Please test on portable version. May I don’t how to use macro.

    when I run macro and stop, that working. but after save, and open, the macro has a error. plese fix as soon as. or tell how to use macro.

    Many thanks.

    #9364

    Yutaka Emura
    Keymaster

    I tested on portable version, but some users report macros won’t run on portable version. I will keep looking into the issue. Meanwhile, please install EmEditor using the installer version. Thanks!

    #9367

    emuser1
    Member

    I used Windows vista 32bit Home Premium Sp1 genius is not work.

    But windows 7 64bit(32bit emeditor) can used macro(Save and run) on portable version.

    So, It windows vista vbs/js has a problems or missing open some servics ?

    but i tested on vista, when the macro ‘not save’ is can run. when save and open back, run has a error.

    please test on vista 32bit hp sp1, i think only this version windows issue. if found solve method, please tell me on here. Thanks support.

    #9368

    Yutaka Emura
    Keymaster

    Hi emuser1,

    I tried EmEditor portable version with the fresh install of Windows Vista 32bit Home Premium SP1 on Virtual PC, but I couldn’t reproduce this issue. Do you install any anti-virus program or any sort of security software? Are there any security policy that might cause the macros from running. Thank you!

    #9373

    emuser1
    Member

    Thanks For test. may my os already turn off some script function. also may be before i already used a emeditor install version. so that not detect the macro patch.

    But i 100\% sure, i has a macro problems. I don’t how to fix.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone