Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #22289

    sky
    Participant

    Macro “Runs at Events” doesn’t work after v17.0.0
    v16.9.3 is OK.

    #22290

    Patrick C
    Participant

    Yep – same here, just wanted to post the issue as well 😉
    Macro “Runs at Events” doesn’t work any more on my computer either.

    #22295

    Patrick C
    Participant

    Follow up question for Yutaka:

    How are the macro settings in versions 17+ now accessed from within a macro?

    Before v17 it was
    sMacro1 = editor.GetProfileString(eeRegMacros, “”, “Macro1”, -1);

    Consequently

    will probably have to be re-written.

    #22303

    Yutaka Emura
    Keymaster

    I will fix the “Runs at Events” bug on the next version.

    As for how to run a macro within a macro, please use ExecuteMacro Method:

    http://www.emeditor.org/en/macro_editor_editor_executemacro.html

    Thanks!

    #22308

    npnilsson
    Participant

    just wanted to post the same issue. macro “runs at events” does not work on my system as well…is there any way to downgrade to the last version that it worked until the bug is fixed?

    #22311

    Patrick C
    Participant

    I also tried downgrading – but at a price. The reason is that Emeditor transfers certain settings from version 16.9.3 to version 17. Those settings cannot be recovered when downgrading – except if you didn’t run “Delete old settings”. In my case I made a mess with my settings (own fault, I didn’t realise at first).

    In any case, if you didn’t run “Delete old settings”, then you can give downgrading a try (at your own risk):
    http://files.emeditor.com/emed64_16.9.3.exe

    #22312

    Yutaka Emura
    Keymaster

    Hello,

    I am sorry for inconveniences. The Runs at Events issue will be fixed on the next version (v17.1.1). Meanwhile, you can work around by adding a new registry value:

    UsedEvents

    as REG_DWORD at HKEY_CURRENT_USER\Software\EmSoft\EmEditor v3\Common, and set the value as 0xffffffff in hexadecimal (or 4294967295 in decimal).

    Notes that this workaround will NOT be needed anymore once v17.1.1 is released and installed.

    Thanks,

    #22317

    Patrick C
    Participant

    Yutaka’s workaround works on my machine 🙂

    Thank you!!! Presently I do need this feature quite often.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone