Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #10679

    ArthurZ
    Participant

    I was printing files in EmEditor that were created in SSMS by somebody.
    However, to my surprise, the printouts from EmEditor came out with long lines of code truncated.
    In contrast, SSMS prints them well.
    Image is at https://imageshack.us/photo/my-images/594/margins.jpg/.
    By the way, I feel important to mention I chose the option to not to wrap the lines around because the printouts in SSMS came out well with page setting for margins set to 0.75″.
    In EmEditor I needed to set the margins to 0.25″ to get the same results. Same Canon business class printer.
    I measured the margins and even did not see where it makes it 0.25″. SSMS does.
    I also suggest one more enhancement: the lines need to start at the most left position aligned, as SSMS does (e.g. the word Untitled must be inline with the rest of the text, otherwise we waste space.

    #10680

    Yutaka Emura
    Keymaster

    Hello,

    You can change all kinds of settings on Configuration Properties, the Print tab.

    – Print Line Numbers check box
    – Ignore Color and Underlines check box
    – Draw Separating Lines check box
    – Wrap by Page when Printing check box
    – Space Between Lines text box
    – Header check box
    – Header text box
    – Footer check box
    – Footer text box
    – Page Setup button
    – Font button

    For instance, the Header check box allows you to include the “Untitled” word on the print.

    Please let me know if these settings still can’t resolve your issues.

    #10681

    ArthurZ
    Participant

    Thank you Yutaka,

    But my issue is the absense of exact positioning.

    SSMS works as per specs, why not the same is possible in EMEditor?

    This makes me tweaking page setup.

    #10682

    Yutaka Emura
    Keymaster

    Hello,

    The Page Setup button allows you to change the margins of a page.

    If this doesn’t work, there may not be enough positioning settings for you. I am sorry, but EmEditor is not a word processor. I suggest you use a word processor to print the file you would like.

    Thank you!

    #10683

    ArthurZ
    Participant

    The page margin feature is what I used. But its setting is innacurate. Only rough. Not in other tools.
    Yet,if I will be editing files in EmEditor and printing in say Word it is not too productive and professional. Thing is I keep related files in a project.

    #10684

    Yutaka Emura
    Keymaster

    Hello ArthurZ,

    I understand what the issue was about the page margins. There was about 0.166 inch undocumented extra space on each side of a page. I am not sure if this margin depends on printer you use, but I reproduced this issue on my printer, too. I adjusted the margins with Notepad output. Also, there was space on the left side of line numbers, but that was intentional space EmEditor leaves — space assuming 4-digit line numbers. I adjusted this to 2-digit line numbers, and so that the space increases as the line number increases. I removed all the space, so you will see more accurate page margins on the next version.

    Thank you!

    #10685

    ArthurZ
    Participant

    Thank you,

    Yes, this is exactly the issue. I used a brand new Cannon printer with an uptodate driver. I at the moment have no access to any other printer, but I trust it is editor related 100\% because SSMS prints correctly. And your printer exibits the issue, too. I was not too eloquent describing the issue.

    One other small sugesstion I gave: the file name should be aligned with the text body and the footer info as page X out of Y text.

    #10686

    Yutaka Emura
    Keymaster

    The file name will be aligned to the text body on the next version.

    Thank you!

    #10704

    ArthurZ
    Participant

    Thank you. This now works well for me.

    One small item: the page margin settings got reverted back to 1″ (from 0.25″ that I defined to use).
    So, is it possible to preserve this setting between editor upgrades?

    #10708

    Yutaka Emura
    Keymaster

    Hello,

    Sorry, you will have to adjust the margin by yourself. I don’t think you need to go back to older version, so it is only once that you will have to do.

    Thanks!

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone