Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #23388

    LTT
    Participant

    Issue 1:
    When Find/Replace dialog is not open,
    R-click a regular-expression whole-word-only marker and select “Replace…”
    Now Replace dialog is open.
    ** But “Use Escape Sequence” option is also checked. And “\” in the string changed to “\\”.

    When Find/Replace dialog is open, with options unchecked,
    R-click a regular-expression whole-word-only marker and select “Replace…”
    ** The options are not set correspondingly.

    When Find/Replace dialog is open, with both “Use Regular Expressions” and “Use Escape Sequence” checked,
    R-click a regular-expression whole-word-only marker and select “Replace…”
    ** “Use Regular Expressions” is off.

    Issue 2:
    Such a Marker-to-Replace transfer never triggers the matched FRP.

    #23397

    Yutaka Emura
    Keymaster

    These issues will be addressed on v17.8.0. Thanks!

    #23436

    LTT
    Participant

    Issue 1-2:
    When Find dialog is open,
    A Marker-to-Replace transfer fails to send the string into the Find box.

    Issue 1-3:
    When Find/Replace dialog is open,
    A Marker-to-Replace transfer will uncheck these 2 options (if they are checked):
    Incremental Search
    In the Selection Only
    Is this inevitable?

    Issue 1-4:
    When Find/Replace dialog is open, with “Use Regular Expressions” checked,
    R-click a non-regex marker and select “Replace…”
    ** “Use Escape Sequence” is still grayed.

    Issue 2-2:
    When Find/Replace dialog is open,
    A Marker-to-Replace transfer never triggers the matched FRP.

    #23449

    Yutaka Emura
    Keymaster

    All these issues will be fixed on the next version. Thanks!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.