Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #5160

    chjfth
    Member

    When I upgrade EmEditor from 6.00.4 to 7.00.RC6, I found matching brackets in single or double brackets “() {}” can not be highlighted any more. I check that “Highlight Matching Parentheses/Brackets” has been checked, and the highlight color has been configured(actually the same as they are in EmEditor v6).

    I want the highlight back please.

    #5161

    Yutaka Emura
    Keymaster

    chjfth wrote:
    When I upgrade EmEditor from 6.00.4 to 7.00.RC6, I found matching brackets in single or double brackets “() {}” can not be highlighted any more. I check that “Highlight Matching Parentheses/Brackets” has been checked, and the highlight color has been configured(actually the same as they are in EmEditor v6).

    I want the highlight back please.

    Are you working on a huge file? Please create a small sample file to reproduce the issue. If you believe this was a bug, please send me the sample file after zipped and write detailed procedure how to reproduce the issue. My email is tech@emurasoft.com

    #5166

    chjfth
    Member

    I can’t believe you said that. I’ve tried it on at least three Windows machines(WinXP SP2 & Win2000 SP4 both involved), and they all exhibit what I’ve said. Just create an empty file, press F11 and select “C++”, then key in () “()”, — quotes should be keyed in. You see yourself whether the round brackets in the quotes are highlighted. In case yourself are cofused by what you will be seeing, please install EmEditor v6 and compare to it.

    If you demand a real Windows environment, please download this VMware virtual machine(brand new Win2000 Simplified Chinese version) and install EmEditor v7 RC6 in it and see. http://down.nlscan.com/Misc/Internet-Keep-Ref/_vmware-5-Win2kchs-nsExec-bug.7z

    #5167

    Yutaka Emura
    Keymaster

    I use Virtual PC 2007 for Windows 2000 environment. I press F11 and select “C++”, and then type “()”. Now “()” are highlighted. It seems all right to me. Do I need to type something else after “()”? If you installed any plug-ins, can you try uninstalling or disabling all extra plug-ins?

    #5168

    chjfth
    Member

    For EmEditor v7 RC6, whether something is typed after “()”, the brackets never highlight up to now.

    I install EmEditor v7 RC6 on a machine(that vmware machine I posted above) that EmEditor has never been installed and only install the default plugins bundled.

    See the screen shot please:

    Brackets highlighted:

    Brackets NOT highlighted in quotes:

    #5170

    Yutaka Emura
    Keymaster

    I am sorry for misunderstanding. You should have first showed me your screenshots. ( ) inside single or double quotes do not work any more. This is the specification of the new version. Most people want to jump to matching bracket (in programs), and want to ignore those inside single or double quotes.

    #5172

    chjfth
    Member

    Yup! That’s a useful feature anyway, can you tell me what the keyboard shortcut is for “jump to matching bracket”.

    However, I use EmEditor as my favorite editor for writing makefiles, and there are lots and lots of cases where brackets are inside double quotes. So, please give user a choice instead of dropping the old good feature. EmEditor has done a great job of providing options to various user preferences, so why not adhere to that good tradition.

    See my complex makefile here: http://gnumakeuniproc.svn.sourceforge.net/viewvc/gnumakeuniproc/GMU-main/trunk/GnumakeUniproc/GnumakeUniproc.mki?revision=413&view=markup

    #5173

    Yutaka Emura
    Keymaster

    chjfth wrote:
    Yup! That’s a useful feature anyway, can you tell me what the keyboard shortcut is for “jump to matching bracket”.

    However, I use EmEditor as my favorite editor for writing makefiles, and there are lots and lots of cases where brackets are inside double quotes. So, please give user a choice instead of dropping the old good feature. EmEditor has done a great job of providing options to various user preferences, so why not adhere to that good tradition.

    See my complex makefile here: http://gnumakeuniproc.svn.sourceforge.net/viewvc/gnumakeuniproc/GMU-main/trunk/GnumakeUniproc/GnumakeUniproc.mki?revision=413&view=markup

    CTRL + ] to jump to the matching bracket.

    If you can disable single/double quotation marks in the Highlight (2) tab of Properties, and then all matching brackets will be highlighted.

    #5174

    chjfth
    Member

    Well, I know what you mean. But that’s not a decent solution. Looking forward to your fix on this issue. Thank you in advance.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.