Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #9803

    Salabim
    Participant

    Am I the only one where, no matter how many times I have configured EmEditor to remember the previous window size & position, EmEditor constantly opens in a small(er) window size & position ?

    EmEditor v11.0.2 x64 (Windows7 64bit)

    Or perhaps it’s a user error after all ? In that case,
    where is the top priority configuration for default windows states & sizes to be found ?

    EDIT : it seems to be a random misbehaviour, but in one case it is a recurring (read : happening 100\% of the time) issue.

    When a text file (residing on the DESKTOP) is allready in the last state list (ie, it will be opened in a tab by default when running EmEditor), EmEditor is not running, and the file is doubleclicked on the desktop again, EmEditor seems to disregard the previous windows size & position, never.

    #9805

    Yutaka Emura
    Keymaster

    Hi Salabim,

    There are many settings related to the window size/position.

    Do you the automatic workspace? Please check the Window tab of the Customize dialog. If you use the automatic workspace, then the last window size/position is remembered automatically.

    If none of the workspace is used, then please check “Restore Tabbed Window Position” check box in the same dialog/tab. If this is checked, then the last used tabbed window position/size is used when the tab is enabled.

    If none of these is used, after you resize the current window, you can go to the same dialog/tab, and click “Save Current Window Position” button, and check “Restore Window Position” and “Restore Window Size”, and the current window size/position is remembered.

    I hope this helps. Thanks!

    #9806

    Salabim
    Participant

    Thanks for the response, Yutaka.
    I don’t know what is wrong for me, I added a screenshot with the settings I have.

    I don’t know which setting is incorrect for EmEditor not remembering settings for specific files.

    Please if you can, also tell me, what setting i need to change to have EmEditor ALWAYS open maximized, no matter what document or tab.

    #9810

    Yutaka Emura
    Keymaster

    I don’t know exactly what caused your issue. However, you can try selecting “None” for “Automatic Workspace”.
    Also, first maximize your EmEditor main window, come back to this Customize dialog, the Window tab, and then click “Save Current Window Position”, and click OK.

    Thanks!

    #9811

    Salabim
    Participant

    Selecting “None” just removed all my always-open-documents. 🙁

    Oh well, guess I’ll have to live with it.

    Really, noone is willing to recreate the problem ?
    It’s just simply opening up a document (Automatic Workspace = Save&Restore), closing EmEditor, and again double clicking the same document in explorer to see the bug in effect, but if noone is willing to try……

    #9812

    Ivan
    Participant

    Confirmed. (EmEditor 11.0.2 32-bit, Win7 32-bit)

    Seems like when double clicking the text file on the Desktop, the window position (top left corner) is set to the coordinates of 25×25 pixels and this position moves after each EmEditor launch using this way (i.e. to 50×50, 75×75, 100×100 etc.).
    When launching EmEditor using the Start menu shortcut (for example), the window position is right.

    #9813

    Salabim
    Participant

    At least someone is helpful.
    Thank you so much for acknowledging the problem, Ivan ! 🙂
    After investigating, it’s more than just the desktop, it happens with *every* file, which is doubleclicked but was already in the workspace.

    Yutaka, you’re willing to look into this bug now ?

    #9814

    Yutaka Emura
    Keymaster

    I reproduced this issue, so I will fix this issue. Thanks!

    #9817

    Salabim
    Participant

    Thanks a lot for finding it Yutaka ! 🙂

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone