Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #4463

    CaptainFlint
    Participant

    We have a new printer HP LJ 4350 here, and when I tested it a little from different programs I found that printing Russian characters from EE does not work properly: the characters printed are with correct codes, but from another codepage, even if I’m printing a Unicode file. That is, I print a Russian word “тест” (ANSI codes: 6F, 61, 6E, 6F in 1251 codepage) and instead I get “òåñò” (the same charcodes, but from 1252 codepage).

    Here is one not-completely-standard setting that I’ve set in my WinXP, and it may be the reason, though I don’t see how it could cause such a trouble. There is a problem in Windows that it copies text into clipboard from non-Unicode applications completely improperly: if my keyboard layout at the moment of pressing Ctrl+C is Russian, the text copied in Russian codepage, if English – in English codepage. As if the codepage of the text written years ago would immediately change when I switch my keyboard… 👿
    So, to fix this I had to reassign the 1252 codepage into c_1251.nls file, so that even when Windows wanted to copy text in 1252 codepage it worked with Russian 1251 codepage instead. Till now it worked fine, because I don’t need other languages from 1252 codepage (and even when I need them, I use Unicode, where there’s no such problem).

    To my greatest surprise, this change led EmEditor to exactly opposing effect! I’m trying to use 1251 codepage, but the text is converted into 1252, which normally isn’t accessible at all! How could this be? And how to get rid of it? (Of course, without returning the 1252 registry key back – I can’t work with these in the highest degree stupid sudden text conversions from normal Russian into some unreadable worms… 🙁 )

    I post it in this forum, because I tested some other Unicode programs (Word, Notepad) – and there are no such problems. So, it seems to be some problems in EmEditor itself.

    WinXP SP2 Pro eng x32 (with all Russian regional settings)
    EmEditor Pro 6.0.0.4

    #4467

    CaptainFlint
    Participant

    Well, I managed to fix it. In the printer settings I changed the setting True Type Font from Substitute with Device Font into Download as Softfont, and now it prints correctly.
    However, I’m not sure that it is the best solution and that the printer will not print something wrong someday…

    However, the source of the problem is still a complete mystery for me – if I change the “1252” registry key back to “c_1252.nls”, the printer prints Russian fonts correctly even with “Device Font” setting. But 1252 is not Russian codepage! It does not contain ANY Russian character! How can it affect printing Russian text then??? 😕

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone