Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #7948

    Klortho
    Participant

    Hi, I just installed the portable version, and I’m trying to put all my macros in a “macros” subdirectory of the installation directory. That way, I can have everything in one place.
    The problem is illustrated by this sequence of steps:
    1. I copied my macro “XMLEscape.jsee”, into the “macros” subdirectory of the EmEditor directory where I have the portable version
    2. I selected the menu option “Macros” – “Select”, and navigated to the file and clicked “Open”,
    3. In the “Macros” menu, I now see my macro listed as item # 2.
    4. If I try to click on it, though, I get a box saying “The system cannot find the file specified. macrosXMLEscape.jsee”

    I checked in the eeCommon.ini file, and found that the setting is
    MacroFile=macrosXMLEscape.jsee
    which is clearly wrong, the path shouldn’t start with “” — it should be relative.

    If I change that to remove the leading “”, and then restart EmEditor, then I can access the macro.

    The same problem occurs when you try to customize the macro menu through “Macros” – “Customize…”. If I click “New” and add macros using that box, then they appear in the menu, but clicking on them has the same problem. I found that to make the change permanent, so that these macros are always available from the “Macros” menu, I had to change the pathnames under the [Macros] section of the same .ini file.

    #7951

    Yutaka Emura
    Keymaster

    Klortho wrote:
    Hi, I just installed the portable version, and I’m trying to put all my macros in a “macros” subdirectory of the installation directory. That way, I can have everything in one place.
    The problem is illustrated by this sequence of steps:
    1. I copied my macro “XMLEscape.jsee”, into the “macros” subdirectory of the EmEditor directory where I have the portable version
    2. I selected the menu option “Macros” – “Select”, and navigated to the file and clicked “Open”,
    3. In the “Macros” menu, I now see my macro listed as item # 2.
    4. If I try to click on it, though, I get a box saying “The system cannot find the file specified. macrosXMLEscape.jsee”

    I checked in the eeCommon.ini file, and found that the setting is
    MacroFile=macrosXMLEscape.jsee
    which is clearly wrong, the path shouldn’t start with “” — it should be relative.

    If I change that to remove the leading “”, and then restart EmEditor, then I can access the macro.

    The same problem occurs when you try to customize the macro menu through “Macros” – “Customize…”. If I click “New” and add macros using that box, then they appear in the menu, but clicking on them has the same problem. I found that to make the change permanent, so that these macros are always available from the “Macros” menu, I had to change the pathnames under the [Macros] section of the same .ini file.

    I cannot reproduce your issue, so it might depend on OS version. Which OS do you use? Windows XP or Vista? Do you use the latest version of EmEditor — 9.06?

    #7954

    Klortho
    Participant

    Windows XP, and yes, the latest version. Note that I’m using the portable version.

    #7955

    Yutaka Emura
    Keymaster

    Klortho wrote:
    Windows XP, and yes, the latest version. Note that I’m using the portable version.

    I reproduced this issue in Windows XP. I am fixing this in the next version. Thanks!

    #7956

    ToadLoadin
    Member

    I think setting a enviroment variable such as $EmEditorPath$ in future version could help. 🙂

    #8553

    Klortho
    Participant

    I see that it is fixed. Thanks!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.