Tagged: 

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #21992

    David
    Participant

    It’s my first time to open so big file – 12MB XML file and view/change something(want to open whole file, not partial). During scrolling the vertical bar, I find the operation is not so smooth (feel slack). Experience is not so good as it on opening small file.

    I don’t know if there’s a way to improve experience? Thanks!

    My laptop environment:

    Operating system: Windows 7 Professional Service Pack 1 64 Bit
    Number of CPUs: 8
    Processor: Intel(R) Core(TM) i7-4710MQ CPU @ 2.50GHz
    Physical total memory: 8GB
    HDD: SSD 128GB
    EmEditor: version 16.6
    
    #21993

    Yutaka Emura
    Keymaster

    The 12 MB file is very small, and should be no problem with EmEditor. Can you please disable Outline if already enabled? Can you also disable all plug-ins?

    If the problem still persists, please export all settings first (Tools > Export and Import), and then try the “Reset All Settings” command (Tools menu > All Commands > Tools).

    Thanks,

    #21995

    sky
    Participant

    Suppose it is caused by the file with very long(column) text in one line or some lines.

    For example:
    1,000,000 lines of “0123456789\n” , 12MB,
    View “Wrap by Window” => Vertical bar is smooth; Horizontal bar is N/A.
    View “No Wrap” => Vertical bar is smooth; Horizontal bar is N/A.

    Try to remove all “\n”, it will become 1 line of “012345678901234567890123…..”, 10MB,
    View “Wrap by Window” => Vertical bar is not smooth; Horizontal bar is N/A.
    View “No Wrap” => Vertical bar is N/A; Horizontal bar is not smooth.

    #21996

    David
    Participant

    Hello,Sky:
    Yes. This file has only one row and 12,793,967 columns. It’s generated by a software. The contents are like
    <ap:TaskPriority Dirty="0000000000000000" TaskPriority="urn:Prio5"/></ap:TaskPriorityMarker></ap:TaskPriorityMarkers></ap:MarkersSetGroup></ap:Map>

    #21997

    David
    Participant

    Hello, Yutaka sang,
    Thanks for your reply. I have done as your suggestion. But it seems same as before.

    #21998

    sky
    Participant

    Workaround solution: find all “<ap:” replace with”\n<ap:”
    EmEditor can handle many lines file easily.

    #22242

    JohnQSmith
    Participant

    On the same lines as this. I have a 22MB XML file. There are about 94K instances of “<row>…</row>”. I am trying to split them onto individual lines.

    Using EmEditor 64bit 17.0.2 in portable mode. I backed up my EmEditor folder and then “Reset All Settings” as in your post. Using the replace window (CTRL-H) with “</row>” in the find box, “</row>\n” in the replace box and “Use Escape Sequence” checked, it has been running over 7 minutes and is only up to “6300 Found, Searching line 1 / 2” in the status dialog box.

    Using Cygwin64’s sed command takes less than 1 second.

    10:14:33 $ time sed -e "s_</row>_</row>\n_g" sheet1.xml > out.xml
    
    real    0m0.476s
    user    0m0.327s
    sys     0m0.077s

    I can email you the file for testing; it compresses to a 2.3MB ZIP file.

    #22248

    Yutaka Emura
    Keymaster

    I tried to reproduce the issue with similar file: 22MB xml file with 94K instances of the same tag, but it took only 6.547 seconds to complete the same Replace All. However, I just noticed that the portable version will take much, much longer time to complete. I will try to fix this issue.

    Thanks,

    #22249

    JohnQSmith
    Participant

    Screen cap of my advanced settings and the sample file have been sent. Glad to hear you’ve duplicated the problem. Thanks in advance.

    #22250

    Yutaka Emura
    Keymaster

    OK. Sorry for many revisions. I reproduced the issue if the Match Case option in the Replace dialog box was cleared as default. If the Match Case option is set, the Replace All operation will become much faster. Please set the Match Case if you try to do the similar operation. I will try to remedy the issue.

    Thanks,

    #22251

    JohnQSmith
    Participant

    Enabling “Match Case” required only 17 seconds to complete the replace all. I appreciate your continuing support.

    #22259

    Yutaka Emura
    Keymaster

    Hello,

    I addressed this issue on beta 6, which I released just now.

    Thanks!

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone