Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #27012
    sky
    Participant

    Text line 1: ABC
    Text line 2: DEF
    “Selected Text or Word at Cursor” or “Selected Text” is checked in Replace dialog box.

    Step 1. Select “ABC”
    Step 2. Press Ctrl+H, it is OK.
    Step 3. Select “ABC\nDEF”
    Step 4. Press Ctrl+H, it is still shown “ABC”, not selected text “ABC\nDEF”.

    Step 5. Press Ctrl+F, it is OK.
    Step 6. Select “DEF” (without \n)
    Step 7. Press Ctrl+H, it is OK.

    #27013
    Yutaka Emura
    Keymaster

    Hello sky,

    This is the correct behavior if you select multiple lines. In this case, EmEditor will set the In the Selection Only option instead.

    #27018
    LTT
    Participant

    You can use “Set Word to Find/Replace” commands to pick up a selection, no matter if it’s multi-line.

    @Yutaka ,

    ** But these 2 commands do not work as expected when “Find/Replace” dialog is open:
    In “Find/Replace” dialog, the current string does not change correspondingly, though the picked string is already at the top of the history dropdown.

    + Suggestion 1:
    Make these 2 commands also work for “Find/Replace in Files” dialog.

    + Suggestion 2:
    Add “selection” in the descriptions for these 2 commands:
    Sets the current word (or selection) as the find/replace string.

    #27027
    Yutaka Emura
    Keymaster

    Hello LTT,
    These issues and suggestions will be addressed on the next version. Thank you!

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.