Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #27551
    LTT
    Participant

    Is it possible to resolve the shortcut-key conflict between Snippets and the core, like what’s been done in WordComplete?

    #27555
    Yutaka Emura
    Keymaster

    Are you referring to the Snippets plug-in (global) Properties – Keyboard page, or each snippet item properties shortcut?
    The global Properties – Keyboard page should be exactly the same as the Word Complete plug-in Keyboard page.
    I am not sure what you mean by “resolve”. It doesn’t resolve, but it just shows a warning when there is a conflict.

    #27577
    LTT
    Participant

    Sorry for the delay…

    I confused the things in the above post.
    I mean “each snippet item properties shortcut”.

    Currently, a shortcut key assigned to a core command can be assigned to a snippet item without warning.

    And there are other issues. Try these steps:
    Assign a shortcut key to a core command.
    Assign the same key to 2 (or more) snippet items.
    Press the key. It shows the snippet items in a menu.
    Press Esc key to cancel the menu.
    ** Issue 1: There’s a sound.
    (There’s no sound if the key is not assigned to a core command.)

    Now go on:
    Suppose the key mentioned above is Ctrl+;.
    Assign Alt+; to another core command (X).
    Press Ctrl+; to show the snippet items in a menu.
    Press Alt key to cancel the menu.
    ** Issue 2: The core command (X) is triggered (by Alt+;).

    #27582
    Yutaka Emura
    Keymaster

    The snippets plug-in item properties should warn you if the keyboard shortcut conflicts with a core command. I am not sure why you didn’t see the warning.

    I’ve fixed your second issue.

    #27587
    LTT
    Participant

    Um… I can’t recall how I added those shortcuts for the snippet items…
    Now I see: It warns only when I changed the shortcut and confirm the dialog.

    However, issue 3:
    The warning can be bypassed:
    Open the Properties of a snippet.
    Add a shortcut that conflicts (e.g. Ctrl+N).
    Then enable “Use Default Shortcut”.
    Confirm and reopen the dialog.
    Disable “Use Default Shortcut”.
    Confirm the dialog.
    ** It doesn’t warn.

    However again, issue 4:
    ** Clicking “Edit” button in the dialog always triggers the warning if the shortcut conflicts.
    I don’t think it’s necessary.

    #27589
    LTT
    Participant

    This thread reminds me of some other suggestions:

    emeditor.com/forums/reply/23709/

    emeditor.com/forums/topic/snippets-2/
    The 6th (and other ones).

    #27591
    Yutaka Emura
    Keymaster

    I’ve fixed these issue and suggestions on 20.8.906.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.