Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #20962

    Skeeve
    Participant

    Found this issue in 16.1.0 but it also may occur in earlier versions. (Not tested)

    Steps to reproduce:

    1.) Enable CSV mode and load a document with multiple columns. (I’m using user defined separated mode)
    2.) Disable Cell Selection Mode
    3.) Try to sort specific columns with the ‘Sort by multiple colums’ function.

    After re-enabling Cell Selection Mode, this is working fine. So, not a big issue, but irritating to find the reason.

    Let me know if you can’t reproduce the issue or if you need more info.

    Thanks,
    Kind regards,
    Skeeve

    #20967

    Yutaka Emura
    Keymaster

    Hello,

    I can’t reproduce the problem. Does the “Sort by Multiple Columns” dialog box appear when you click on the “Sort by Multiple Columns” button on the CSV/Sort toolbar?

    #20968

    Skeeve
    Participant

    Hi Yutaka,

    Yes, the dialog box appears, but regardless the settings, no sort operation is performed when I choose “Sort now” or “Sort opposite”.

    I’ll send you a more detailed report with a sample file via mail, because I haven’t found a possibility here to attach files.

    Kind regards,
    Skeeve

    #20969

    Yutaka Emura
    Keymaster

    I received your email, and finally reproduced the issue. You will have to de-select any selections before you try to sort, otherwise, EmEditor will try to sort only the selection. If only one line is selected, EmEditor will try to sort only one line, which doesn’t make sense. Therefore, I will disable the selection sort if only one line is selected on the next version, and this behavior will not happen anymore.

    Thanks!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone