Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #9686

    scriptkit
    Participant

    tab char can’t select 😮

    #9687

    Yutaka Emura
    Keymaster

    Hi scriptkit,

    You should be able to select a tab using the mouse or keyboard. Can you please describe more in details? Thanks!

    #9688

    scriptkit
    Participant

    For example:
    “hello (t)”

    a ‘tab’ at the end of the “hello”.

    i can’t select “hello” without a tab.
    and can not select a single tab..
    it well be selected “o (t)”

    #9691

    Yutaka Emura
    Keymaster

    Hi,

    I am using the latest version (v11.0.1), and I can’t reproduce your issue. Maybe, you can reset all settings of EmEditor, and see if you can reproduce the issue. To reset settings, the easiest way is to uninstall EmEditor, and during uninstall, you may be asked to save settings so please select “No”. Then you can install EmEditor again.

    Thanks!

    #9699

    jimmy
    Participant

    I can reproduce this issue.
    For example, a txt file with the following line (“t” is a tab char).

    ttline twot455

    1> when selecting the tab char near the end of the line, the char just before the tab char will also be selected. (in the eg, “ot” will be selected)

    2> the second tab from the head of the line cannot be selected. (instead, the 2 tabs will be selected together)

    #9700

    LTT
    Participant

    I also met this annoying issue since v11 and can reproduce it with many (maybe most) of my fonts, except for a few (e.g., Fixedsys).

    Tested with all the registry data removed and without any plugin.

    For example, input “AAAA” before 2 or more tabs.
    “AAAAtt+” is expected.
    But the actual result is “At+AAAt”.

    Or, double click a word, the following tabs will be inevitably selected.

    #9703

    Yutaka Emura
    Keymaster

    Hi LTT,

    Can you please let me know which font you are using to reproduce this issue? Thanks!

    #9705

    Yutaka Emura
    Keymaster

    Hi jimmy,

    I reproduced this issue under certain condition.

    You can work around this by running RegEdit.exe, and add “UseUniscribe” value as DWORD in the following key:

    HKEY_CURRENT_USERSoftwareEmSoftEmEditor v3Common

    and UseUniscribe = 1

    I will fix this in future versions. I am sorry for any inconveniences.

    #9706

    LTT
    Participant

    “UseUniscribe = 1” works.

    Thank you!

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone