Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #23556

    LTT
    Participant

    Issue 1:
    emeditor_en.chm::/howto/plugin/plugin_wordcomplete.htm:
    Match Case:
    If Only in Candidates is selected, both ABC and abc are used as a candidate, and typing A or a displays both ABC and abc.
    If Both in Candidates and in Typing is selected, both ABC and abc are used as a candidate, but typing A displays only ABC, and typing a displays only abc.

    ** But currently “Only in Candidates” is behaving the same way as “Both in Candidates and in Typing”.

    Example:
    The default dictionary has:
    Orange/M
    orange/MS

    —————
    Issue 2:
    ** The refreshment of the candidate list is slower when “Both in Candidates and in Typing” is set. (Especially with lowercase typing.)

    —————
    Issue 3:
    Open 2 windows with the same configuration.
    Change the “Match Case” option in WordComplete properties in one window.
    ** The behavior in another window does not follow the change instantly.
    (I didn’t test on other options.)

    —————
    Issue 4:
    Open WordComplete Properties.
    Select any configuration. Open its Properties.
    In Options page, “Number of Characters” is 1 by default.
    Change it to 2 and click OK.
    Now select all the configurations. Open the Properties.
    ** In Options page, “Number of Characters” now is 0.

    ===============
    Suggestion 1:
    Thank you for adding “Complete (Keep Typed Case)” command.
    Is it possible to enhance it further:
    When the “Match Case” option is “Never and Keep Original Text when Completes”, “Complete (Keep Typed Case)” command reverses the function (i.e. completes with the candidate case).

    —————
    Suggestion 2:
    I think a Reset button is necessary for every page in WordComplete (sub-)Properties for configuration(s) dialog box. So we can see the default settings temporarily.

    —————
    Suggestion 3:
    Clicking “…” button (in Dictionaries page) should open the path according to the (absolute/relative) path in the “Dictionary File” box when valid. (And the file should be selected when the dialog box is open.)
    Otherwise it should open the default “Dictionaries” folder.

    When open, the default type should be: All Files (*.*)

    Currently it opens EmEditor’s current directory (OpenDir).
    And the type is always *.txt

    #23563

    Yutaka Emura
    Keymaster

    Hello LTT,
    All issues except 2 and 3 will be addressed on the next version. I am not sure if I understand/reproduce the Issue 2, but it might be also addressed on the next version. Please see if it is fixed when the next version is released.
    All suggestions will be also addressed on the next version.
    Thanks,

    #23614

    LTT
    Participant

    > Issue 2:
    Options page: “Number of Characters” = 1.
    “Both in Candidates and in Typing” is set.
    Type “s” (lower case).
    ** The candidate list is very very slow.

    ==========
    > Suggestion 3:
    Clicking “…” button (in Dictionaries page) should open the default “Dictionaries” folder when the “Dictionary File” box is empty, or when the path is unavailable/invalid.

    #23620

    Yutaka Emura
    Keymaster

    v18.0.4 fixes the Suggestion 3 issue.
    I can’t reproduce the Issue 2. However, it is not unusual that the candidate list is displayed somewhat slower if the dictionary size is large.
    Can you please write numbers in details (how many seconds to display the list, and how large the dictionary is)?

    #23627

    LTT
    Participant

    > Issue 2:
    Seems it doesn’t occur initially.
    The more text you type in the current tab, the slower it goes. While either of the other three options works fine.
    Several lines would be enough to see the obvious slowdown.
    Later the delay could be more than 10 seconds. And see the CPU usage.
    (The default dictionary is used.)

    Issue A:
    Disable and enable WordComplete.
    Type “s”. The list shows the candidates instantly and stably (without any flicker).
    Delete and type “s” again.
    ** The list flickers. (Say it in slow motion: blink-blaaank-show.)
    I think this still needs to be optimized.

    Issue B:
    Open a new tab. Type something. WordComplete works.
    Detach the tab. Type something.
    ** WordComplete does not work, till you disable and enable it again, or use “Show Candidates Manually” command once.

    Issue C:
    When both a (snippet/ActiveString) tooltip and the WordComplete candidate list show simultaneously, sometimes the list dodges the tooltip, but sometimes the tooltip covers the list.
    Can this be optimized?

    Suggestion C1:
    I think “Show Candidates Manually” command could be a toggle switch. So one can close the candidate list via this shortcut key.
    Currently, when both a tooltip and the WordComplete candidate list show simultaneously, Esc key closes the tooltip first.

    Suggestion C2:
    Should also be able to temporarily close the ActiveString tooltip by using Esc key.

    > Suggestion 2:
    The Reset button is only displayed for English and Japanese language?

    > Suggestion 3:
    “…” button (in Dictionaries page) is not working properly.
    When the “Dictionary File” box is empty, or when the path is unavailable/invalid:
    Click “…”. Select a file. Open.
    ** See the result in the “Dictionary File” box.

    #23641

    Yutaka Emura
    Keymaster

    Hello LTT,

    We’ve fixed Issue 2 and Issue A on v18.0.6. Issue B is due to the slowness because a new window group is opened, and please wait a few seconds until the candidate list becomes ready (v18.0.6 should be much faster).

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.