Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #26805
    LTT
    Participant

    > The Wrap Indent option now ignores full-width spaces.
    ▲ Please add an option for this.

    1:
    Enable “Wrap Indent”.
    A line with very long leading whitespaces clings to the right edge when it wraps. (Hope this can be optimized somehow.)
    Disable “Wrap Indent”.
    ** The line now clings to the left edge.
    The line should be rearranged.

    #26820
    Yutaka Emura
    Keymaster

    Hi LTT,
    I made the full-width spaces optional on 19.8.94.
    1. I understand it clings to the right edge. How would you like to correct it? I am not sure what you mean by “clings to the left edge.”

    #26985
    LTT
    Participant

    Oh I forgot this thread.

    > I understand it clings to the right edge. How would you like to correct it?

    Is it possible to release the value that determines the min length of a wrapped line?
    e.g. If I set it to 50, the wrapped line should be 50-char long in width, overriding “Wrap Indent”.

    —————
    > I am not sure what you mean by “clings to the left edge.”

    See the screenshots:
    i.ibb.co/RDqv48S/Em-Editor-Wrap-Indent.png

    1:
    Initial view, when “Wrap Indent” is already enabled.

    2:
    Disable “Wrap Indent”.
    ** EmEditor just pans the text to the left edge. It does not rearrange the text instantly.

    3:
    Toggle wrap methods (or change window size).
    Now the text is rearranged.

    4:
    Enable “Wrap Indent”.
    ** EmEditor just pans the text to the right edge. (And there’s no horizontal scrollbar.)

    #26992
    Yutaka Emura
    Keymaster

    Thank you for explaining but this will need another option to set the min length. I might think about it in future versions.
    The bug on toggling the wrap indent was addressed on beta 8 (20.0.908).

    #27005
    LTT
    Participant

    Take the picture as example again:
    Set the caret at the end of the logical line.
    Toggle “Wrap Indent”.
    ** The caret blinks at a false position.

    #27007
    Yutaka Emura
    Keymaster

    Hello LTT,
    This issue will be fixed on the next version.
    Thank you!

    #27083
    LTT
    Participant

    The last issue is not fixed yet.

    #27086
    Yutaka Emura
    Keymaster

    I am not sure if I understand your last issue. Are you referring to this?:

    Take the picture as example again:
    Set the caret at the end of the logical line.
    Toggle “Wrap Indent”.
    ** The caret blinks at a false position.

    If so, can you post a sample file (or screenshot) and where the cursor is?

    #27093
    LTT
    Participant

    i.ibb.co/cQ8sKXd/Em-Editor-Wrap-Indent-Cursor.png
    ▲ Middle: When I turn off “Wrap Indent”.
    ▲ Right: When I turn on “Wrap Indent” again.

    #27094
    LTT
    Participant

    2:
    I was not able to describe how to reproduce another issue till now:

    Enable “Wrap Indent”.
    Indent a wrapped line (as the left image shows ▲).
    ** Such lines cannot be redrawn well, e.g. minimap/tooltip/WordComplete/menu covering leaves blanks in the wrapped view lines.

    #27100
    Yutaka Emura
    Keymaster

    I’ve reproduced both these issues, and they will be fixed on v20.2.902. Thank you!

    #27114
    LTT
    Participant

    The cursor position is correct now.
    ** But after “Wrap Indent” is toggled, the “current line background color” doesn’t follow.
    See the right image:
    img4.imagetitan.com/img4/nggNgpEvY8uEZLt/23/23_emeditor_wrapindent_currentlinebgcolor.png

    #27125
    Yutaka Emura
    Keymaster

    This issue was fixed on v20.3 beta 5 (20.2.905). Thank you.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.