Tagged: 

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #20399

    netsking
    Participant

    is anyone having the same problem? The wrap-up function can’t work properly. I checked out the wrap up in properties for all. But EE is open new file as no wrap in each time.

    #20400

    Stefan
    Participant

    Please excuse my ignorance, but what exactly is “””The wrap-up function””” ?
    Can you point to some menu entry or help page please?
    Or explain with more details and what you do.

    Thanks.

     

     

    #20402

    netsking
    Participant

    Sorry about that. It’s tag “in all configurations properties”. Before I selected “word wrap”, the new file will be opened as wrap characters/wrap window each time.
    … but now, it opens as no wrap. don’t know the reason.

    #20403

    Stefan
    Participant

    Thanks for clarifying! To help the author locate that problem, he may have some more need for details:
    Which was the EmEditor version and bitness architecture (32/64) this works for you?
    Which version and bitness do you use now you got this problem with?
    Do you have EmEditor installed or do you use the portable version?
    On which operation system (XP/W7/W8/W10) ?

    Thanks for your support.

    #20404

    netsking
    Participant

    Which was the EmEditor version and bitness architecture (32/64) this works for you?
    EE ver14 64-bit version
    Which version and bitness do you use now you got this problem with?
    ver 15.2, 64-bit (noticed it, maybe even earlier)
    Do you have EmEditor installed or do you use the portable version?
    Installed version
    On which operation system (XP/W7/W8/W10) ?
    Win7 64-bit Pro

    #20405

    Stefan
    Participant

    I think I found the solution .
    Nothing to do with version or bittness, but possible wrongly use of configuration?
    (Good example that’s always a good idea to provide
    as much details as possible on such questions)
     

    Tested on: 15.4.0 beta 2 / 32-bit portable on 64-bit Win7
     

    Test 1:
    Tools > Properties All Configuration
    [Wrap]
    [x] Word Wrap
    [_] Wrap after marks
    [X] Wrap These Characters

    Open a file with long lines.
    The lines are NOT wrapped-up.
     

    Test 2:
    Tools > Properties All Configuration
    [General]
    Wrap by: Specified Characters

    Open a file with long lines.
    The lines ARE wrapped-up.
     
     

    Now I only have to find out which options is for which purpose…..
     

    HTH?

    #20406

    Stefan
    Participant

    BTW, Yutaka,

    If I go again into “Tools > Properties All Configuration >[General]”, the “Wrap by: ” field shows nothing. But it works by wrapping at 80 chars.
    If I go into . . . . “Tools > Properties Current Configuration >[General]”, the “Wrap by: ” field shows “Specified Characters” as expected.
     
    Me think the “Wrap by: ” on “Tools > Properties All Configuration >[General]” should show the current chosen setting too? Instead of nothing.
     
     
    .

    #20408

    Stefan
    Participant

    @netsking
    Did you worked that out now?

     
    .

    #20409

    netsking
    Participant

    Stefan,
    No. I followed your instruction. It is still working as before.
    I found my selection of “wrap by” was nothing in all-property configuration.
    After chosen “wrap by special characters”, open a new file, EE will dispay as what I selected.
    However, the chosen property won’t be saved because closed and re-opened EE, the display became no wrap again.
    And wrap by in general is nothing.
    I changed other selections, all of them can be saved when closed and re-opened.
    Maybe this is the reason.
    BTW, I am using 64-bit EE.

    #20416

    netsking
    Participant

    Stefan,
    Did you figure out the reason or have any update info?

    #20436

    Stefan
    Participant

    Hi netsking,
    no, I can’t imagine what happens here.
     
    I am not an expert, but I would close EmEditor and rename the Registry key of EmEditor
    HKEY_CURRENT_USER\SOFTWARE\EmSoft\EmEditor v3\
    for example to HKEY_CURRENT_USER\SOFTWARE\EmSoft-problem\EmEditor v3\
    to disable it for the moment, launch EmEditor again to see if there was any culprit in your settings.
     
    If that brings you nowhere, delete the new created key and rename the old key back by removing that ‘-problem‘ string again.
     

    netsking wrote:

    Before if I select “word wrap”, the new file will be opened
    as wrap characters/wrap window each time.
    … but now, it opens as no wrap. don’t know the reason.

    Worked fine on: EE ver14 64-bit version / Installed version
    Got Problem since: ver 15.2, 64-bit / Installed version (noticed it, maybe even earlier)
    Operation system: Win7 64-bit Pro

    Tools > Properties All Configuration > [General] > “Wrap by” shows nothing.
    After chosen “wrap by special characters”, open a new file, EE will dispay as what I selected.
    However, the chosen property won’t be saved because closed and re-opened EE, the display became no wrap again.
    If I chang other selections, all of them can be saved when closed and re-opened.

     

    HTH?           ( Best try with the brand new 15.5.0 release, see the Blog )
     
     

    #20590

    netsking
    Participant

    Stefan,

    Did you notice this problem come back again in the version 15.7.2.
    My computer did not change: WinPro 7, 64bit OS, EE 15.7.2.
    The “no wrap” issue comes back.

    #20594

    netsking
    Participant

    No one hear me?

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone