Patrick C

Actually I’m surprised that non EmEditor’s highlighted string features are activated by default in your case.
Anyway regarding:

on double-clicking text there is no feature that highlights matches

There is:
1) Tools → Customise Markers → Enable AutoMarker

2) To change the highlighting colour (also useful if enabling AutoMarker alone doesn’t work due to no colour being assigned to mark matches)
Tools → Properties for all Configurations → Display → scroll down to “Auto Marker” → change the text and background colour to your liking