#7606

Yutaka Emura
Keymaster

gning wrote:
Thank you.

I think I’d better find or make a utility to scan files for BOMs.

I think the problem happens when it loads files that contain only ASCII-7 and interprets them as UTF-8. I think one thing I can probably do that will help is to change the “opening encoding” for the configuration that these files get loaded with (which is “SQL”). I’ll change it from “system default” to “western european”. Will that prevent it from seeing ascii-7 as utf-8?

If you always want to open in Western European, you might want to uncheck “Detect UTF-8” in the Configuration Properties > File tab. This should be enough to prevent from BOM being added. I hope this helps.